summaryrefslogtreecommitdiff
path: root/media-sound/linuxsampler
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/linuxsampler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/linuxsampler')
-rw-r--r--media-sound/linuxsampler/Manifest3
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-0.5.1-gcc43.patch36
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch20
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-0.5.1-pkgconfiginit.patch12
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch13
-rw-r--r--media-sound/linuxsampler/linuxsampler-0.5.1.ebuild52
-rw-r--r--media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild54
-rw-r--r--media-sound/linuxsampler/linuxsampler-2.0.0.ebuild50
-rw-r--r--media-sound/linuxsampler/metadata.xml5
9 files changed, 245 insertions, 0 deletions
diff --git a/media-sound/linuxsampler/Manifest b/media-sound/linuxsampler/Manifest
new file mode 100644
index 00000000000..036e3e20b57
--- /dev/null
+++ b/media-sound/linuxsampler/Manifest
@@ -0,0 +1,3 @@
+DIST linuxsampler-0.5.1.tar.bz2 614500 SHA256 e0d42f98813abf187b636f52d3fe3d5c1add228a2e783bdda409ebae1c7f901f
+DIST linuxsampler-1.0.0.tar.bz2 701591 SHA256 bf4f4f83b9ab706e8e8b017aafb560c363bb7663413aeae46d49f1f56110c9cf SHA512 50b27ff16ef0f393e0808d992ca58f8a4ec12ce909bf3a461502e7e2a2bcfcbfb1558dd07a5ff5af2cbf26bc5f7b878a736005a8e90e4d5e92ca9b868e9bc204 WHIRLPOOL e7668fb4a1c802411de89fb73bdbca78150a8fc6386c42d9c3b9f8c7c1d4576260ef6c89e283f1fbcbcf397515d565e5e13f1e5286a07b6cb8240bb26e437bf6
+DIST linuxsampler-2.0.0.tar.bz2 1318939 SHA256 1943d05006d96a9fb49f74a6f38129a4585cb78cc0648885fca9f056529c5c28 SHA512 f4a57117dbec3eeb9d6d670fec76e928ef9d9e49a1a8c6bd654d6114efdc203861e7865005f06265c172e29b5e0a948eac160377dcdabc5244caed5e5ca7e441 WHIRLPOOL d8af13229d8dafd8ed68950038968d19e01a010465a91ddd54866fb626c47081931dba7dda9a073c17274c26dec9a1ec51cf30a00fe4831716354c9e9fcf4cf4
diff --git a/media-sound/linuxsampler/files/linuxsampler-0.5.1-gcc43.patch b/media-sound/linuxsampler/files/linuxsampler-0.5.1-gcc43.patch
new file mode 100644
index 00000000000..e65c6cbb106
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-0.5.1-gcc43.patch
@@ -0,0 +1,36 @@
+Index: linuxsampler-0.5.1/src/db/InstrumentsDbUtilities.h
+===================================================================
+--- linuxsampler-0.5.1.orig/src/db/InstrumentsDbUtilities.h
++++ linuxsampler-0.5.1/src/db/InstrumentsDbUtilities.h
+@@ -24,6 +24,7 @@
+ #define __LS_INSTRUMENTSDBUTILITIES_H__
+
+ #include <vector>
++#include <memory>
+ #include <gig.h>
+ #include <sqlite3.h>
+ #include <sys/stat.h>
+Index: linuxsampler-0.5.1/src/drivers/midi/midi.h
+===================================================================
+--- linuxsampler-0.5.1.orig/src/drivers/midi/midi.h
++++ linuxsampler-0.5.1/src/drivers/midi/midi.h
+@@ -21,6 +21,7 @@
+ #ifndef __LS_MIDI_H__
+ #define __LS_MIDI_H__
+
++#include <stdint.h>
+ #include <string.h>
+
+ namespace LinuxSampler {
+Index: linuxsampler-0.5.1/src/network/lscpserver.cpp
+===================================================================
+--- linuxsampler-0.5.1.orig/src/network/lscpserver.cpp
++++ linuxsampler-0.5.1/src/network/lscpserver.cpp
+@@ -21,6 +21,7 @@
+ * MA 02111-1307 USA *
+ ***************************************************************************/
+
++#include <algorithm>
+ #include "lscpserver.h"
+ #include "lscpresultset.h"
+ #include "lscpevent.h"
diff --git a/media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch b/media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch
new file mode 100644
index 00000000000..3c4add20637
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch
@@ -0,0 +1,20 @@
+Index: linuxsampler-0.5.1/configure.in
+===================================================================
+--- linuxsampler-0.5.1.orig/configure.in
++++ linuxsampler-0.5.1/configure.in
+@@ -38,6 +38,7 @@ LSCP_RELEASE_MINOR=3
+ AC_DEFINE_UNQUOTED(LSCP_RELEASE_MAJOR, ${LSCP_RELEASE_MAJOR}, [LSCP spec major version this release complies with.])
+ AC_DEFINE_UNQUOTED(LSCP_RELEASE_MINOR, ${LSCP_RELEASE_MINOR}, [LSCP spec minor version this release complies with.])
+
++AC_PROG_CXX
+ AM_PROG_LIBTOOL
+
+ AC_SUBST(SHLIB_VERSION_ARG)
+@@ -1082,7 +1083,6 @@ AM_CONFIG_HEADER(config.h)
+ AM_INIT_AUTOMAKE(linuxsampler, "$LINUXSAMPLER_RELEASE_MAJOR.$LINUXSAMPLER_RELEASE_MINOR.$LINUXSAMPLER_RELEASE_BUILD")
+
+ AC_LANG_CPLUSPLUS
+-AC_PROG_CXX
+
+ # some gcc 4.0 versions need -msse for SSE register allocations
+ if test "$config_asm" = "yes"; then
diff --git a/media-sound/linuxsampler/files/linuxsampler-0.5.1-pkgconfiginit.patch b/media-sound/linuxsampler/files/linuxsampler-0.5.1-pkgconfiginit.patch
new file mode 100644
index 00000000000..551f1512e12
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-0.5.1-pkgconfiginit.patch
@@ -0,0 +1,12 @@
+Index: linuxsampler-0.5.1/configure.in
+===================================================================
+--- linuxsampler-0.5.1.orig/configure.in
++++ linuxsampler-0.5.1/configure.in
+@@ -52,6 +52,7 @@ AC_SUBST(target_cpu)
+ AC_SUBST(target_os)
+ AC_SUBST(target_vendor)
+
++PKG_PROG_PKG_CONFIG
+
+ ###########################################################################
+ # General Checks
diff --git a/media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch b/media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch
new file mode 100644
index 00000000000..e46fb243b6c
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/414033
+
+--- a/src/common/Pool.h
++++ b/src/common/Pool.h
+@@ -393,7 +393,7 @@ class RTList : public RTListBase<T> {
+ inline Iterator allocAppend() {
+ if (pPool->poolIsEmpty()) return RTListBase<T>::begin();
+ Iterator element = pPool->alloc();
+- append(element);
++ this->append(element);
+ #if CONFIG_DEVMODE
+ element.list = this;
+ #endif // CONFIG_DEVMODE
diff --git a/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild b/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
new file mode 100644
index 00000000000..79def7f1e52
--- /dev/null
+++ b/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="LinuxSampler is a software audio sampler engine with professional grade features"
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jack sqlite"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3.3 )
+ >=media-libs/libgig-3.2.1
+ media-libs/alsa-lib
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-pkgconfiginit.patch"
+ epatch "${FILESDIR}/${P}-libtool22.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf --enable-alsa-driver \
+ $(use_enable jack jack-driver) \
+ $(use_enable sqlite instruments-db)
+ emake -j1 || die "emake failed."
+
+ if use doc; then
+ emake -j1 docs || die "emake docs failed."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+}
diff --git a/media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild b/media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild
new file mode 100644
index 00000000000..cf7592f4b3b
--- /dev/null
+++ b/media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="LinuxSampler is a software audio sampler engine with professional grade features"
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jack sqlite static-libs"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3.3 )
+ >=media-libs/libgig-3.3.0
+ media-libs/alsa-lib
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ econf --enable-alsa-driver \
+ --disable-arts-driver \
+ $(use_enable jack jack-driver) \
+ $(use_enable sqlite instruments-db) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ emake docs
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+
+ prune_libtool_files
+}
diff --git a/media-sound/linuxsampler/linuxsampler-2.0.0.ebuild b/media-sound/linuxsampler/linuxsampler-2.0.0.ebuild
new file mode 100644
index 00000000000..70199562962
--- /dev/null
+++ b/media-sound/linuxsampler/linuxsampler-2.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="LinuxSampler is a software audio sampler engine with professional grade features"
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jack sqlite static-libs"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3.3 )
+ >=media-libs/libgig-4.0.0
+ media-libs/alsa-lib
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --enable-alsa-driver \
+ --disable-arts-driver \
+ $(use_enable jack jack-driver) \
+ $(use_enable sqlite instruments-db) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ emake docs
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+
+ prune_libtool_files
+}
diff --git a/media-sound/linuxsampler/metadata.xml b/media-sound/linuxsampler/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-sound/linuxsampler/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>