summaryrefslogtreecommitdiff
path: root/media-sound/lltag
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lltag
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lltag')
-rw-r--r--media-sound/lltag/Manifest1
-rw-r--r--media-sound/lltag/lltag-0.14.4-r1.ebuild45
-rw-r--r--media-sound/lltag/metadata.xml5
3 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/lltag/Manifest b/media-sound/lltag/Manifest
new file mode 100644
index 00000000000..a6eedb29d06
--- /dev/null
+++ b/media-sound/lltag/Manifest
@@ -0,0 +1 @@
+DIST lltag-0.14.4.tar.bz2 48137 SHA256 5fe8d993289136395eb040ac6f1fa633cd8fd6a02a39de2db6f0ff1397ec948d SHA512 d2dbc513ce5e75a808acb7676a2513ece34322d134d52e1f5ea44f51b7c134699a0a8e368265c2594fd275873e4908a21af135c8714278954d0b45f2fc239bf7 WHIRLPOOL 62caf3b3e5fc05dd081cf4323b1b90e302306feee4a42c3a8a7e92703cbf08986f82b8f8a5d3faf4a13f69e59d4148a35b1b0c507e1284285ed6cc9893298dbb
diff --git a/media-sound/lltag/lltag-0.14.4-r1.ebuild b/media-sound/lltag/lltag-0.14.4-r1.ebuild
new file mode 100644
index 00000000000..53dbc80e8a0
--- /dev/null
+++ b/media-sound/lltag/lltag-0.14.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit perl-module
+
+DESCRIPTION="Automatic command-line mp3/ogg/flac file tagger and renamer"
+HOMEPAGE="http://home.gna.org/lltag"
+SRC_URI="http://download.gna.org/lltag/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac mp3 ogg readline"
+
+RDEPEND="dev-perl/libwww-perl
+ mp3? ( media-sound/mp3info dev-perl/MP3-Tag )
+ ogg? ( media-sound/vorbis-tools )
+ flac? ( media-libs/flac )
+ readline? ( dev-perl/Term-ReadLine-Perl )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ mylltagopts=(
+ "DESTDIR=${D}"
+ "PREFIX=/usr"
+ "SYSCONFDIR=/etc"
+ "MANDIR=/usr/share/man"
+ "PERL_INSTALLDIRS=vendor"
+ "DOCDIR=/usr/share/doc/${PF}"
+ )
+}
+
+src_compile() {
+ emake "${mylltagopts[@]}"
+}
+
+src_install() {
+ emake "${mylltagopts[@]}" install{,-doc,-man}
+ dodoc Changes
+ perl_delete_localpod
+ # Move config to recommended location
+ mv "${D}usr/share/doc/${PF}"/config "${D}"etc/lltag/ || die
+}
diff --git a/media-sound/lltag/metadata.xml b/media-sound/lltag/metadata.xml
new file mode 100644
index 00000000000..ae573a60407
--- /dev/null
+++ b/media-sound/lltag/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>