summaryrefslogtreecommitdiff
path: root/media-sound/moosic
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/moosic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/moosic')
-rw-r--r--media-sound/moosic/Manifest1
-rw-r--r--media-sound/moosic/metadata.xml5
-rw-r--r--media-sound/moosic/moosic-1.5.6-r1.ebuild36
3 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/moosic/Manifest b/media-sound/moosic/Manifest
new file mode 100644
index 00000000000..4c34af5fe94
--- /dev/null
+++ b/media-sound/moosic/Manifest
@@ -0,0 +1 @@
+DIST moosic-1.5.6.tar.gz 165916 SHA256 bdb04e7f26b7ff1f5266fe24ed11fb47f3bd5c2723ef0548fcf13bef3219db69 SHA512 06cf060dbcadd793bd045c378d2993636f875a4ccd320258ecbaa36bfd0341870e10f362380006ce3e6a9d9180e272bec6c216947ab80c39f04c7aecb8e80da3 WHIRLPOOL 06bf94fd030bec44092ec2bd20826e6412c1871039ea473da980d9f50576cb5438b04db446b80d4cb8b65cf6757d923114297852ae4789072ce97317cb023805
diff --git a/media-sound/moosic/metadata.xml b/media-sound/moosic/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-sound/moosic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/moosic/moosic-1.5.6-r1.ebuild b/media-sound/moosic/moosic-1.5.6-r1.ebuild
new file mode 100644
index 00000000000..ba87d977d89
--- /dev/null
+++ b/media-sound/moosic/moosic-1.5.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Music player that focuses on easy playlist management"
+HOMEPAGE="http://www.nanoo.org/~daniel/moosic"
+SRC_URI="http://www.nanoo.org/~daniel/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e 's:distutils.core:setuptools:' setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/*.html )
+
+ distutils-r1_python_install_all
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ newbashcomp examples/completion ${PN}
+ dodoc doc/{Moosic_API.txt,moosic_hackers.txt,Todo}
+ dodoc examples/server_config
+}