summaryrefslogtreecommitdiff
path: root/media-sound/mp3_check
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mp3_check
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mp3_check')
-rw-r--r--media-sound/mp3_check/Manifest1
-rw-r--r--media-sound/mp3_check/files/mp3_check-1.98-makefile.patch23
-rw-r--r--media-sound/mp3_check/metadata.xml8
-rw-r--r--media-sound/mp3_check/mp3_check-1.98.ebuild29
4 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/mp3_check/Manifest b/media-sound/mp3_check/Manifest
new file mode 100644
index 00000000000..1a6a263815e
--- /dev/null
+++ b/media-sound/mp3_check/Manifest
@@ -0,0 +1 @@
+DIST mp3_check-1.98.tar.gz 83098 SHA256 bd63a63789f808d0632ad9e9b9448b8bf24f258629ec9195663ecce5fe889461
diff --git a/media-sound/mp3_check/files/mp3_check-1.98-makefile.patch b/media-sound/mp3_check/files/mp3_check-1.98-makefile.patch
new file mode 100644
index 00000000000..906ad468f0f
--- /dev/null
+++ b/media-sound/mp3_check/files/mp3_check-1.98-makefile.patch
@@ -0,0 +1,23 @@
+Index: mp3_check-1.98/Makefile
+===================================================================
+--- mp3_check-1.98.orig/Makefile
++++ mp3_check-1.98/Makefile
+@@ -2,7 +2,7 @@
+
+ CC ?= gcc
+ LOCALBASE ?= /usr/local
+-CFLAGS += -Wall -Werror
++#CFLAGS += -Wall -Werror
+ OPT_FLAGS = -L${LOCALBASE}/lib
+ OBJS = mp3_check.o \
+ mp3_check_misc.o
+@@ -16,8 +16,7 @@ norm: $(OBJS)
+ $(CC) -g $(CFLAGS) $(OBJS) -o mp3_check
+
+ trim: $(OBJS)
+- $(CC) $(CFLAGS) $(OPT_FLAGS) $(OBJS) -o mp3_check
+- strip mp3_check
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OPT_FLAGS) $(OBJS) -o mp3_check
+ cat MILESTONE.INTRO
+
+ install: all
diff --git a/media-sound/mp3_check/metadata.xml b/media-sound/mp3_check/metadata.xml
new file mode 100644
index 00000000000..b285f3ae22f
--- /dev/null
+++ b/media-sound/mp3_check/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">mp3check</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/mp3_check/mp3_check-1.98.ebuild b/media-sound/mp3_check/mp3_check-1.98.ebuild
new file mode 100644
index 00000000000..d0a75ca15ae
--- /dev/null
+++ b/media-sound/mp3_check/mp3_check-1.98.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MP3 consistency checker"
+HOMEPAGE="http://sourceforge.net/projects/mp3check/"
+SRC_URI="mirror://sourceforge/mp3check/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ dobin mp3_check || die "dobin failed"
+ dodoc WISHLIST TODO THANKYOU README *NOTES FOR_TESTING GOALS MILESTONE*
+}