summaryrefslogtreecommitdiff
path: root/media-sound/mp3asm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mp3asm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mp3asm')
-rw-r--r--media-sound/mp3asm/Manifest1
-rw-r--r--media-sound/mp3asm/metadata.xml8
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/mp3asm/Manifest b/media-sound/mp3asm/Manifest
new file mode 100644
index 00000000000..5ad3191c50b
--- /dev/null
+++ b/media-sound/mp3asm/Manifest
@@ -0,0 +1 @@
+DIST mp3asm-0.1.3-1.tar.bz2 46530 SHA256 14d67f040e99eb33369e3f7b136d60eca45c59b946ce58a6af9fb4954a87adc7
diff --git a/media-sound/mp3asm/metadata.xml b/media-sound/mp3asm/metadata.xml
new file mode 100644
index 00000000000..68c47aa31f4
--- /dev/null
+++ b/media-sound/mp3asm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">mp3asm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
new file mode 100644
index 00000000000..4f427eaca77
--- /dev/null
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_PV="${PV}-1" # Patchlevel
+
+DESCRIPTION="A command line tool to clean and edit mp3 files"
+HOMEPAGE="http://sourceforge.net/projects/mp3asm/"
+SRC_URI="mirror://sourceforge/mp3asm/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+
+# the author uses weird numbering...
+S="${WORKDIR}/mp3asm-0.1"
+
+src_compile() {
+ econf || die "econf failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin src/mp3asm || die "install failed"
+ dodoc Changelog README
+}