summaryrefslogtreecommitdiff
path: root/media-sound/mp3splt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mp3splt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mp3splt')
-rw-r--r--media-sound/mp3splt/Manifest1
-rw-r--r--media-sound/mp3splt/metadata.xml12
-rw-r--r--media-sound/mp3splt/mp3splt-2.6.1a.ebuild32
3 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/mp3splt/Manifest b/media-sound/mp3splt/Manifest
new file mode 100644
index 00000000000..14dbab5e727
--- /dev/null
+++ b/media-sound/mp3splt/Manifest
@@ -0,0 +1 @@
+DIST mp3splt-2.6.1a.tar.gz 260476 SHA256 9cd24b7483bbca7bf4a1c306fbf2afc2bb111defd0d88e9d87f642c1b519bb50 SHA512 5c0f6a56e09c0b33f83360bc4ea5d4c9398fa6ec9bc39e7e9ab34b0ff19e46ddacbbc69ff51953ee399f1a172f2d634c57c256abdfe51def593e5f981490cc17 WHIRLPOOL a511c8627afcce86ec290c76628520b0f520c94445ee13bf8ad1c47ab344c485035ab9061f2bfa6522a4a19cbb232dc131f27b1b80f2b6ee2843b2c7f6de9b43
diff --git a/media-sound/mp3splt/metadata.xml b/media-sound/mp3splt/metadata.xml
new file mode 100644
index 00000000000..ab638f070ef
--- /dev/null
+++ b/media-sound/mp3splt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mp3splt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/mp3splt/mp3splt-2.6.1a.ebuild b/media-sound/mp3splt/mp3splt-2.6.1a.ebuild
new file mode 100644
index 00000000000..d714db807d7
--- /dev/null
+++ b/media-sound/mp3splt/mp3splt-2.6.1a.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit multilib
+
+DESCRIPTION="a command line utility to split mp3 and ogg files without decoding"
+HOMEPAGE="http://mp3splt.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ~ppc ~ppc64 sparc x86"
+IUSE="flac"
+
+RDEPEND="~media-libs/libmp3splt-0.9.1a[flac?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ econf \
+ --enable-oggsplt_symlink \
+ $(use_enable flac flacsplt_symlink) \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}