summaryrefslogtreecommitdiff
path: root/media-sound/mpg321
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-08-12 23:39:47 +0200
committerMichael Weber <xmw@gentoo.org>2015-08-12 23:40:14 +0200
commitb8c6db7e6b2033dc1d30bca8ba8edd8fc6f4c8c1 (patch)
treed672f5fd3cbd41c291234c5278eb89c128dc1358 /media-sound/mpg321
parentf07fb676860df6f8a74ae449551c048f9f7d1b1b (diff)
downloadgentoo-b8c6db7e6b2033dc1d30bca8ba8edd8fc6f4c8c1.tar.gz
gentoo-b8c6db7e6b2033dc1d30bca8ba8edd8fc6f4c8c1.tar.xz
media-sound/mpg321: Version bump (bug 444418), USE=alsa (bug 475620), format-security (bug 557132, thanks René Rhéaume).
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/mpg321')
-rw-r--r--media-sound/mpg321/Manifest1
-rw-r--r--media-sound/mpg321/files/mpg321-0.3.2-format-security.patch38
-rw-r--r--media-sound/mpg321/mpg321-0.3.2.ebuild52
3 files changed, 91 insertions, 0 deletions
diff --git a/media-sound/mpg321/Manifest b/media-sound/mpg321/Manifest
index 03c59343dc8..d4da505ca5a 100644
--- a/media-sound/mpg321/Manifest
+++ b/media-sound/mpg321/Manifest
@@ -1 +1,2 @@
DIST mpg321-0.3.1.tar.gz 151104 SHA256 0b9c23d75a89236ade9830e0319d7e799efea9f6af262d6defda962037d65579 SHA512 77a7b975f2d31f670eb786ccb9601820945e60b19a188e7337bd2ff0237c7ee47970c27adf78cf633d4a561e89b06de3eacf9f2ec11373abcdcb75c322f19eee WHIRLPOOL 81ee33186d25fdadc288cb09cfa9a124531ac1fbe8e7c10cf748b5960f12de46d536ff7bde9fbb98979d57939fe10ad87179c193bf350dd4932731276eb330bf
+DIST mpg321-0.3.2.tar.gz 151139 SHA256 056fcc03e3f5c5021ec74bb5053d32c4a3b89b4086478dcf81adae650eac284e SHA512 f1bead2c11e4cde0f1a87e1b2e3d216ef80c9a5dd8b219841961688d44a5fc63a54b7af07359766fde0b2712ddc5d0a90b20149c3228cb2d70e830e15c8ab234 WHIRLPOOL 01db416053b2ee883aa31b98251b276a368a339f4a645cf30a066ae498eab2811be09349d04301c30393c1e9ba5804758c71db67526ca79121a24ffb47528ebb
diff --git a/media-sound/mpg321/files/mpg321-0.3.2-format-security.patch b/media-sound/mpg321/files/mpg321-0.3.2-format-security.patch
new file mode 100644
index 00000000000..732ca2c6022
--- /dev/null
+++ b/media-sound/mpg321/files/mpg321-0.3.2-format-security.patch
@@ -0,0 +1,38 @@
+--- /var/tmp/portage/media-sound/mpg321-0.3.2/work/mpg321-0.3.2-orig/mpg321.c 2012-03-25 14:27:49.000000000 +0200
++++ /tmp/mpg321.c 2015-08-12 23:34:20.395331151 +0200
+@@ -183,7 +183,7 @@
+ else{
+ #endif
+ if(!(options.opt & MPG321_ENABLE_BUFFER))
+- fprintf(stderr,"Volume: %ld%% \r",volume);
++ fprintf(stderr,"Volume: %d%% \r",volume);
+ #ifdef HAVE_ALSA
+ }
+ #endif
+@@ -233,7 +233,7 @@
+ else{
+ #endif
+ if(!(options.opt & MPG321_ENABLE_BUFFER))
+- fprintf(stderr,"Volume: %ld%% \r",volume);
++ fprintf(stderr,"Volume: %d%% \r",volume);
+ #ifdef HAVE_ALSA
+ }
+ #endif
+@@ -447,7 +447,7 @@
+ {
+ if(!names[i])
+ {
+- printf(emptystring);
++ printf("%s", emptystring);
+ }
+
+ else
+@@ -465,7 +465,7 @@
+ for (i=0; i<=5; i++) {
+ fprintf (stderr, "%s", info_id3[i].name);
+ if (!names[i]) {
+- fprintf (stderr, emptystring);
++ fprintf (stderr, "%s", emptystring);
+ } else {
+ fprintf (stderr, "%s", names[i]);
+ free (names[i]);
diff --git a/media-sound/mpg321/mpg321-0.3.2.ebuild b/media-sound/mpg321/mpg321-0.3.2.ebuild
new file mode 100644
index 00000000000..29744d2de88
--- /dev/null
+++ b/media-sound/mpg321/mpg321-0.3.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="http://mpg321.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="alsa ipv6"
+
+RDEPEND="app-eselect/eselect-mpg123
+ >=media-libs/libao-1
+ media-libs/libid3tag
+ media-libs/libmad
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-orig
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.12-check-for-lround.patch \
+ "${FILESDIR}"/${P}-format-security.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-mpg123-symlink \
+ $(use_enable ipv6) \
+ $(use_enable alsa)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS BUGS HACKING README* THANKS TODO # NEWS and ChangeLog are dead
+ mv "${ED}"/usr/bin/mpg321{,-mpg123}
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}