summaryrefslogtreecommitdiff
path: root/media-sound/muine
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/muine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/muine')
-rw-r--r--media-sound/muine/Manifest1
-rw-r--r--media-sound/muine/files/muine-0.8.11-drop-deprecated.patch31
-rw-r--r--media-sound/muine/files/muine-0.8.11-multimedia-keys.patch26
-rw-r--r--media-sound/muine/metadata.xml6
-rw-r--r--media-sound/muine/muine-0.8.11-r3.ebuild80
5 files changed, 144 insertions, 0 deletions
diff --git a/media-sound/muine/Manifest b/media-sound/muine/Manifest
new file mode 100644
index 00000000000..97fefffcc38
--- /dev/null
+++ b/media-sound/muine/Manifest
@@ -0,0 +1 @@
+DIST muine-0.8.11.tar.bz2 647177 SHA256 fac70bd9ab8a3c7c48c1f48d10f06080f6b5a42ce32cce21a6ab472cb178ecd4 SHA512 13063c1057cc4a5fb9c2cfca6249e3014415cbfa735a89f1ae411705412e379f1252789787aaca5e11f844fcd8c31a319c408c73539ffe173bc03985b3606d79 WHIRLPOOL c1bbe48293d23f922bd34a3b613942d96ae33d419ee7220b9c2dfe33bf769b59f5fe8984ac6549e9c9a5a16c53460c06db3366fabbd2df9e3e4a7996cb161da0
diff --git a/media-sound/muine/files/muine-0.8.11-drop-deprecated.patch b/media-sound/muine/files/muine-0.8.11-drop-deprecated.patch
new file mode 100644
index 00000000000..fa4b6d8ca2d
--- /dev/null
+++ b/media-sound/muine/files/muine-0.8.11-drop-deprecated.patch
@@ -0,0 +1,31 @@
+From 86e885f1f17db2ec3caa31b0ff7955dfe2b4e543 Mon Sep 17 00:00:00 2001
+From: daniel g. siegel <dgsiegel@gnome.org>
+Date: Tue, 27 Apr 2010 18:22:57 +0000
+Subject: replace some deprecated gtk functions
+
+use gtk_widget_has_focus instead of GTK_WIDGET_HAS_FOCUS and
+gtk_widget_get_state instead of GTK_WIDGET_STATE
+---
+diff --git a/libmuine/rb-cell-renderer-pixbuf.c b/libmuine/rb-cell-renderer-pixbuf.c
+index 42cff41..abf6958 100644
+--- a/libmuine/rb-cell-renderer-pixbuf.c
++++ b/libmuine/rb-cell-renderer-pixbuf.c
+@@ -295,14 +295,14 @@ rb_cell_renderer_pixbuf_render (GtkCellRenderer *cell,
+
+ if ((flags & GTK_CELL_RENDERER_SELECTED) == GTK_CELL_RENDERER_SELECTED)
+ {
+- if (GTK_WIDGET_HAS_FOCUS (widget))
++ if (gtk_widget_has_focus (widget))
+ state = GTK_STATE_SELECTED;
+ else
+ state = GTK_STATE_ACTIVE;
+ }
+ else
+ {
+- if (GTK_WIDGET_STATE (widget) == GTK_STATE_INSENSITIVE)
++ if (gtk_widget_get_state (widget) == GTK_STATE_INSENSITIVE)
+ state = GTK_STATE_INSENSITIVE;
+ else
+ state = GTK_STATE_NORMAL;
+--
+cgit v0.8.3.1
diff --git a/media-sound/muine/files/muine-0.8.11-multimedia-keys.patch b/media-sound/muine/files/muine-0.8.11-multimedia-keys.patch
new file mode 100644
index 00000000000..5bce0ca765c
--- /dev/null
+++ b/media-sound/muine/files/muine-0.8.11-multimedia-keys.patch
@@ -0,0 +1,26 @@
+From d4dd66d73885db1b2aea2a267197413559bed5bc Mon Sep 17 00:00:00 2001
+From: Priit Laes <plaes@plaes.org>
+Date: Wed, 16 Sep 2009 21:30:06 +0000
+Subject: Fix multimedia key support for >=Gnome-2.22
+
+---
+diff --git a/src/GnomeMMKeys.cs b/src/GnomeMMKeys.cs
+index dd99718..af5419a 100644
+--- a/src/GnomeMMKeys.cs
++++ b/src/GnomeMMKeys.cs
+@@ -37,11 +37,11 @@ namespace Muine
+ public class GnomeMMKeys : IDisposable
+ {
+ private const string BusName = "org.gnome.SettingsDaemon";
+- private const string ObjectPath = "/org/gnome/SettingsDaemon";
++ private const string ObjectPath = "/org/gnome/SettingsDaemon/MediaKeys";
+
+ private delegate void MediaPlayerKeyPressedHandler(string application, string key);
+
+- [Interface("org.gnome.SettingsDaemon")]
++ [Interface("org.gnome.SettingsDaemon.MediaKeys")]
+ private interface ISettingsDaemon
+ {
+ void GrabMediaPlayerKeys(string application, uint time);
+--
+cgit v0.8.3.1
diff --git a/media-sound/muine/metadata.xml b/media-sound/muine/metadata.xml
new file mode 100644
index 00000000000..42d1ea6516d
--- /dev/null
+++ b/media-sound/muine/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <herd>gstreamer</herd>
+</pkgmetadata>
diff --git a/media-sound/muine/muine-0.8.11-r3.ebuild b/media-sound/muine/muine-0.8.11-r3.ebuild
new file mode 100644
index 00000000000..f26d8faff34
--- /dev/null
+++ b/media-sound/muine/muine-0.8.11-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit gnome2 mono-env eutils multilib
+
+DESCRIPTION="A music player for GNOME"
+HOMEPAGE="http://muine.gooeylinux.org/"
+SRC_URI="mirror://gnome/sources/muine/0.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="flac mad vorbis"
+
+RDEPEND="
+ x11-themes/gnome-icon-theme
+ >=dev-lang/mono-2
+ >=x11-libs/gtk+-2.6:2
+ >=dev-dotnet/gtk-sharp-2.12.9:2
+ >=dev-dotnet/glade-sharp-2.12.6:2
+ >=dev-dotnet/gnome-sharp-2.6:2
+ >=dev-dotnet/gconf-sharp-2.6:2
+ >=dev-dotnet/gnomevfs-sharp-2.6:2
+ >=dev-dotnet/ndesk-dbus-0.4
+ >=dev-dotnet/ndesk-dbus-glib-0.3
+ >=dev-dotnet/taglib-sharp-2.0.3
+ sys-libs/gdbm
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-gconf:0.10
+ media-plugins/gst-plugins-gnomevfs:0.10
+ flac? ( media-plugins/gst-plugins-flac:0.10 )
+ mad? ( media-plugins/gst-plugins-mad:0.10 )
+ vorbis? (
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-vorbis:0.10
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/scrollkeeper
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.29
+"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS PLUGINS README TODO"
+
+ # Fix multimedia key support for >=Gnome-2.22
+ epatch "${FILESDIR}/${P}-multimedia-keys.patch"
+
+ # Replace some deprecated gtk functions
+ epatch "${FILESDIR}/${P}-drop-deprecated.patch"
+
+ # Update icons, upstream bug #623480
+ sed "s:stock_timer:list-add:g" -i src/AddWindow.cs src/StockIcons.cs || die
+ sed "s:stock_music-library:folder-music:g" -i data/glade/PlaylistWindow.glade \
+ src/Actions.cs src/StockIcons.cs || die
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ insinto /usr/$(get_libdir)/${PN}/plugins
+ doins "${S}"/plugins/TrayIcon.dll
+}