summaryrefslogtreecommitdiff
path: root/media-sound/pasystray
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-04 13:25:34 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-04 13:26:03 +0800
commit0677252ab67d69cd5f1a7a02356ea34322663bed (patch)
treea1daf181a059567f01520a08456d7dc46956e418 /media-sound/pasystray
parent3aeaf9c82a8e9ee91c08b08749577e1e282e50c8 (diff)
downloadgentoo-0677252ab67d69cd5f1a7a02356ea34322663bed.tar.gz
gentoo-0677252ab67d69cd5f1a7a02356ea34322663bed.tar.xz
media-sound/pasystray: bump to -0.5.2, prior versions skipped
Now maintained by 'proxy' user P. Healy added under proxy-maintainers herd in metadata, authority to add proxy-maintainers herd by pacho in the gentoo bug, closes said bug. eclass autotools, eautoreconf added Gentoo bug: #462292 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/pasystray')
-rw-r--r--media-sound/pasystray/Manifest1
-rw-r--r--media-sound/pasystray/metadata.xml6
-rw-r--r--media-sound/pasystray/pasystray-0.5.2.ebuild46
3 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/pasystray/Manifest b/media-sound/pasystray/Manifest
index c669c188f50..72f748abf3c 100644
--- a/media-sound/pasystray/Manifest
+++ b/media-sound/pasystray/Manifest
@@ -1 +1,2 @@
DIST pasystray-0.2.1.tar.bz2 100456 SHA256 d24fe23773e0a25fd32aefe101bb703ca42a487c8e25411c831621332cee61a7 SHA512 db7c05c2eb5fd3dada2e3c23f28978497d17a2147078390ab3e8c88654c4bd8ce48d07a15e9a5b3834acffcc2d86fa719ce2403255915bdfb2eb610bd0549041 WHIRLPOOL 71e4519b9bf6012e770820cf1a72bfb875a34eb87e74eab87edc4a18e01d88ecabf56b88e30686ae409d6fe2456a1058a3194ce539e72934410ba402d72cdd22
+DIST pasystray-0.5.2.tar.gz 51738 SHA256 0cb574843bd7883c51291de03cca237e53a89821d6965c8413dd89e42d8ffc3e SHA512 ef305f354e7e012bb3cf999e7e91b7d1ed2298f633fa67270f9998cb95476460e65a7e3c7fb512da69928ed6ad6579e2c97c4cbf74016e868415f4ba875e0aa7 WHIRLPOOL bbf6cbc416a452ae25495b9a68e153a13ad24cf085462caa18936253addbf1d83cea22fef07de94b16c7c8466944418f3a0389e54bae8be94edae019d79392fe
diff --git a/media-sound/pasystray/metadata.xml b/media-sound/pasystray/metadata.xml
index ea0ac98285b..19d8b1ed5db 100644
--- a/media-sound/pasystray/metadata.xml
+++ b/media-sound/pasystray/metadata.xml
@@ -2,6 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sound</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>lists@xunil.at</email>
+ <name>Stefan Weichinger</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
<upstream>
<remote-id type="github">christophgysin/pasystray</remote-id>
</upstream>
diff --git a/media-sound/pasystray/pasystray-0.5.2.ebuild b/media-sound/pasystray/pasystray-0.5.2.ebuild
new file mode 100644
index 00000000000..16780cbe860
--- /dev/null
+++ b/media-sound/pasystray/pasystray-0.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnome2-utils autotools
+
+DESCRIPTION="PulseAudio system tray"
+HOMEPAGE="https://github.com/christophgysin/pasystray"
+SRC_URI="https://github.com/christophgysin/${PN}/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ >=media-sound/pulseaudio-5.0-r3[glib,zeroconf]
+ >=net-dns/avahi-0.6
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README.md TODO"
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ eautoreconf
+}
+src_configure() {
+ econf $(use_enable libnotify notify)
+ sed -i -e 's:volume:volume;:' "data/pasystray.desktop"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ${DOCS}
+ doman man/pasystray.1
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }