summaryrefslogtreecommitdiff
path: root/media-sound/pasystray
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/pasystray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/pasystray')
-rw-r--r--media-sound/pasystray/Manifest1
-rw-r--r--media-sound/pasystray/metadata.xml8
-rw-r--r--media-sound/pasystray/pasystray-0.2.1.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/pasystray/Manifest b/media-sound/pasystray/Manifest
new file mode 100644
index 00000000000..c669c188f50
--- /dev/null
+++ b/media-sound/pasystray/Manifest
@@ -0,0 +1 @@
+DIST pasystray-0.2.1.tar.bz2 100456 SHA256 d24fe23773e0a25fd32aefe101bb703ca42a487c8e25411c831621332cee61a7 SHA512 db7c05c2eb5fd3dada2e3c23f28978497d17a2147078390ab3e8c88654c4bd8ce48d07a15e9a5b3834acffcc2d86fa719ce2403255915bdfb2eb610bd0549041 WHIRLPOOL 71e4519b9bf6012e770820cf1a72bfb875a34eb87e74eab87edc4a18e01d88ecabf56b88e30686ae409d6fe2456a1058a3194ce539e72934410ba402d72cdd22
diff --git a/media-sound/pasystray/metadata.xml b/media-sound/pasystray/metadata.xml
new file mode 100644
index 00000000000..ea0ac98285b
--- /dev/null
+++ b/media-sound/pasystray/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="github">christophgysin/pasystray</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/pasystray/pasystray-0.2.1.ebuild b/media-sound/pasystray/pasystray-0.2.1.ebuild
new file mode 100644
index 00000000000..9b9cf4e02de
--- /dev/null
+++ b/media-sound/pasystray/pasystray-0.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome2-utils
+
+DESCRIPTION="A system tray for pulseaudio controls (replacement for the deprecated padevchooser)"
+HOMEPAGE="http://github.com/christophgysin/pasystray"
+SRC_URI="mirror://github/christophgysin/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ || ( >=media-sound/pulseaudio-1.0[glib,avahi] >=media-sound/pulseaudio-5.0-r3[glib,zeroconf] )
+ >=net-dns/avahi-0.6
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README TODO"
+
+src_configure() {
+ econf $(use_enable libnotify notify)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }