summaryrefslogtreecommitdiff
path: root/media-sound/protux
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/protux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/protux')
-rw-r--r--media-sound/protux/Manifest1
-rw-r--r--media-sound/protux/metadata.xml6
-rw-r--r--media-sound/protux/protux-0.50.100.ebuild44
3 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/protux/Manifest b/media-sound/protux/Manifest
new file mode 100644
index 00000000000..583b167ced1
--- /dev/null
+++ b/media-sound/protux/Manifest
@@ -0,0 +1 @@
+DIST protux-0.50.100.tar.gz 392027 RMD160 e8806ce35a72e6b93e3df15e6fcd65a254e9950a SHA1 067bbc12ceaa9aef97cd45a4174e5536a31d0e09 SHA256 cb8edab6684ea58c13e5cfcec0b6925f32e35cfca4129ca5ab668234541f78e2
diff --git a/media-sound/protux/metadata.xml b/media-sound/protux/metadata.xml
new file mode 100644
index 00000000000..5fcf89fb6d1
--- /dev/null
+++ b/media-sound/protux/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/media-sound/protux/protux-0.50.100.ebuild b/media-sound/protux/protux-0.50.100.ebuild
new file mode 100644
index 00000000000..5534c62283a
--- /dev/null
+++ b/media-sound/protux/protux-0.50.100.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+DESCRIPTION="Professional Audio Tools for GNU/Linux"
+HOMEPAGE="http://protux.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/releases/${P}.tar.gz"
+
+IUSE="source"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc x86"
+
+DEPEND=">=virtual/jdk-1.5
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ # bug #318589
+ sed -i '/com.sun.jmx.snmp.Enumerated/d' "${S}/src/org/protux/core/GlobalProperties.java" || die
+}
+
+src_compile() {
+ cd src
+ ejavac -encoding latin1 $(find . -name "*.java")
+ jar cf ${PN}.jar $(find . -name "*.class") || die
+}
+
+src_install() {
+ java-pkg_dojar src/${PN}.jar
+ dodoc AUTHORS BUGLIST ChangeLog COPYRIGHT INSTALL README TODO || die
+ use source && java-pkg_dosrc src/org
+ # pwd like this because it does not find resources otherwise
+ java-pkg_dolauncher ${PN} \
+ --main org.protux.Main \
+ --pwd /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r resources || die
+}