summaryrefslogtreecommitdiff
path: root/media-sound/pwavecat
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/pwavecat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/pwavecat')
-rw-r--r--media-sound/pwavecat/Manifest1
-rw-r--r--media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch27
-rw-r--r--media-sound/pwavecat/files/pwavecat-0.4.5.diff27
-rw-r--r--media-sound/pwavecat/metadata.xml5
-rw-r--r--media-sound/pwavecat/pwavecat-0.4.5.ebuild32
5 files changed, 92 insertions, 0 deletions
diff --git a/media-sound/pwavecat/Manifest b/media-sound/pwavecat/Manifest
new file mode 100644
index 00000000000..93ffd6dfaa5
--- /dev/null
+++ b/media-sound/pwavecat/Manifest
@@ -0,0 +1 @@
+DIST pwavecat-0.4.5.tgz 13110 RMD160 cd335312d0339cd84df44556b2ffdd04563f7a10 SHA1 8f5d15dd7151b88571c3119e8ed55764c7ccb30a SHA256 3a7d270f09fc918ac7c78258bb99b38369744b90f2217f9f7aa30393f6467db7
diff --git a/media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch b/media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch
new file mode 100644
index 00000000000..f3d54221bc7
--- /dev/null
+++ b/media-sound/pwavecat/files/pwavecat-0.4.5-overflow.patch
@@ -0,0 +1,27 @@
+diff --git a/parts.c b/parts.c
+index 670d0d5..a59ad98 100644
+--- a/parts.c
++++ b/parts.c
+@@ -338,10 +338,10 @@ if(! file_header)
+ return 0;
+ }
+
+-strcpy(file_header -> main_chunk, "RIFF");
++memcpy(file_header -> main_chunk, "RIFF", 4);
+ file_header -> length = length + header_size - 8;
+-strcpy(file_header -> chunk_type, "WAVE");
+-strcpy(file_header -> sub_chunk, "fmt "); // watch out the zero termination overwrites next var
++memcpy(file_header -> chunk_type, "WAVE", 4);
++memcpy(file_header -> sub_chunk, "fmt ", 4); // watch out the zero termination overwrites next var
+ file_header -> length_chunk = 16; //always 16
+ file_header -> format = 1; //PCM
+ file_header -> modus = modus; // stereo
+@@ -349,7 +349,7 @@ file_header -> sample_fq = sample_fq; // 44100, 48000, etc...
+ file_header -> byte_p_sec = byte_p_sec; // little endian
+ file_header -> byte_p_spl = byte_p_spl; // 4 stereo
+ file_header -> bit_p_spl = bit_p_spl; // 16 bits
+-strcpy(file_header -> data_chunk, "data"); // watch out the zero termination overwrites next var
++memcpy(file_header -> data_chunk, "data", 4); // watch out the zero termination overwrites next var
+ file_header -> data_length = (unsigned long)length;
+
+ if(debug_flag)
diff --git a/media-sound/pwavecat/files/pwavecat-0.4.5.diff b/media-sound/pwavecat/files/pwavecat-0.4.5.diff
new file mode 100644
index 00000000000..abe00c69dae
--- /dev/null
+++ b/media-sound/pwavecat/files/pwavecat-0.4.5.diff
@@ -0,0 +1,27 @@
+diff -Naur pwavecat-0.4.5.orig/Makefile pwavecat-0.4.5/Makefile
+--- pwavecat-0.4.5.orig/Makefile 2005-10-06 15:52:56.000000000 +0200
++++ pwavecat-0.4.5/Makefile 2007-10-06 16:27:25.000000000 +0200
+@@ -15,9 +15,9 @@
+ parts.o
+
+ all:
+- gcc $(CFLAGS) -c $(SRC1)
++ $(CC) $(CFLAGS) -c $(SRC1)
+
+- gcc -o pwavecat $(OBJECT1) $(LIBRARY)
++ $(CC) $(LDFLAGS) -o pwavecat $(OBJECT1) $(LIBRARY)
+
+ # DEPENDENCIES
+ pwavecat.o : pwavecat.c pwavecat.h pwavecat_proto.h parts.h wave_header.h
+diff -Naur pwavecat-0.4.5.orig/pwavecat.h pwavecat-0.4.5/pwavecat.h
+--- pwavecat-0.4.5.orig/pwavecat.h 2005-10-06 15:52:56.000000000 +0200
++++ pwavecat-0.4.5/pwavecat.h 2007-10-06 16:27:50.000000000 +0200
+@@ -27,7 +27,7 @@
+
+ char *input_filename[MAX_FILES];
+
+-#define VERSION "0.4.4"
++#define VERSION "0.4.5"
+
+ #endif /* _PWAVECAT_H_ */
+
diff --git a/media-sound/pwavecat/metadata.xml b/media-sound/pwavecat/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-sound/pwavecat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/pwavecat/pwavecat-0.4.5.ebuild b/media-sound/pwavecat/pwavecat-0.4.5.ebuild
new file mode 100644
index 00000000000..2c8ee6ef9ec
--- /dev/null
+++ b/media-sound/pwavecat/pwavecat-0.4.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="concatenates any number of audio files to stdout"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.diff" \
+ "${FILESDIR}"/${P}-overflow.patch
+}
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin pwavecat || die
+ dodoc CHANGES README
+}