summaryrefslogtreecommitdiff
path: root/media-sound/qtscrobbler
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/qtscrobbler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/qtscrobbler')
-rw-r--r--media-sound/qtscrobbler/Manifest1
-rw-r--r--media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch46
-rw-r--r--media-sound/qtscrobbler/files/qtscrobbler-0.10-free.patch16
-rw-r--r--media-sound/qtscrobbler/metadata.xml11
-rw-r--r--media-sound/qtscrobbler/qtscrobbler-0.10.ebuild72
5 files changed, 146 insertions, 0 deletions
diff --git a/media-sound/qtscrobbler/Manifest b/media-sound/qtscrobbler/Manifest
new file mode 100644
index 00000000000..da126463401
--- /dev/null
+++ b/media-sound/qtscrobbler/Manifest
@@ -0,0 +1 @@
+DIST qtscrob-0.10.tar.bz2 132507 SHA256 b77451625d4943a1e19e4418616417944091339db7b31983c593f4bf7d73ee7b
diff --git a/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch b/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch
new file mode 100644
index 00000000000..0558b72c9bf
--- /dev/null
+++ b/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch
@@ -0,0 +1,46 @@
+--- src/cli/Makefile
++++ src/cli/Makefile
+@@ -1,4 +1,4 @@
+-CC = g++
++CXX ?= g++
+ mingw = false
+ WINDRES =
+ RES =
+@@ -27,7 +27,7 @@
+ LINKOBJ = scrobble-cli.o libscrobble.o md5.o ConvertUTF.o mtp.o $(RES)
+ endif
+
+-CFLAGS = -Wall -O2 -g $(INCLUDE) $(CURL_FLAGS) $(MTP_FLAGS)
++CXXFLAGS += -Wall $(INCLUDE) $(CURL_FLAGS) $(MTP_FLAGS)
+
+ .PHONY: all all-before all-after clean clean-custom
+
+@@ -37,22 +37,22 @@
+ rm -f *.o *~ *.d $(BIN) $(BIN).exe
+
+ $(BIN): $(OBJ)
+- $(CC) $(LINKOBJ) -o $(BIN) $(LIBS)
++ $(CXX) $(LDFLAGS) $(LINKOBJ) -o $(BIN) $(LIBS)
+
+ scrobble-cli.o: scrobble-cli.cpp
+- $(CC) -c scrobble-cli.cpp -o scrobble-cli.o $(CFLAGS)
++ $(CXX) -c scrobble-cli.cpp -o scrobble-cli.o $(CXXFLAGS)
+
+ libscrobble.o: ../lib/libscrobble.cpp
+- $(CC) -c ../lib/libscrobble.cpp -o libscrobble.o $(CFLAGS)
++ $(CXX) -c ../lib/libscrobble.cpp -o libscrobble.o $(CXXFLAGS)
+
+ md5.o: ../lib/md5.c
+- $(CC) -c ../lib/md5.c -o md5.o $(CFLAGS)
++ $(CXX) -c ../lib/md5.c -o md5.o $(CXXFLAGS)
+
+ ConvertUTF.o: ../lib/ConvertUTF.c
+- $(CC) -c ../lib/ConvertUTF.c -o ConvertUTF.o $(CFLAGS)
++ $(CXX) -c ../lib/ConvertUTF.c -o ConvertUTF.o $(CXXFLAGS)
+
+ mtp.o: ../lib/mtp-libmtp.cpp
+- $(CC) -c ../lib/mtp-libmtp.cpp -o mtp.o $(CFLAGS)
++ $(CXX) -c ../lib/mtp-libmtp.cpp -o mtp.o $(CXXFLAGS)
+
+ install:
+ install -D -m 755 scrobble-cli -p $(DESTDIR)$(bindir)/scrobble-cli
diff --git a/media-sound/qtscrobbler/files/qtscrobbler-0.10-free.patch b/media-sound/qtscrobbler/files/qtscrobbler-0.10-free.patch
new file mode 100644
index 00000000000..d6802751f0e
--- /dev/null
+++ b/media-sound/qtscrobbler/files/qtscrobbler-0.10-free.patch
@@ -0,0 +1,16 @@
+g++ -c ../lib/mtp-libmtp.cpp -o mtp.o -Wall -I../lib `curl-config --cflags` `pkg-config --cflags libmtp` -DHAVE_LIBMTP
+../lib/mtp-libmtp.cpp: In member function ‘void Scrobble::mtp_iterate(bool)’:
+../lib/mtp-libmtp.cpp:104:30: error: ‘free’ was not declared in this scope
+
+http://bugs.gentoo.org/405667
+
+--- src/lib/mtp-libmtp.cpp
++++ src/lib/mtp-libmtp.cpp
+@@ -16,6 +16,7 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. *
+ ***************************************************************************/
+
++#include <cstdlib> /* free */
+ #include <iostream>
+ #include "libscrobble.h"
+
diff --git a/media-sound/qtscrobbler/metadata.xml b/media-sound/qtscrobbler/metadata.xml
new file mode 100644
index 00000000000..dd2281bd0c8
--- /dev/null
+++ b/media-sound/qtscrobbler/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="cli">Build commandline client</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">qtscrob</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/qtscrobbler/qtscrobbler-0.10.ebuild b/media-sound/qtscrobbler/qtscrobbler-0.10.ebuild
new file mode 100644
index 00000000000..1ce682cae3f
--- /dev/null
+++ b/media-sound/qtscrobbler/qtscrobbler-0.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils gnome2-utils qt4-r2 toolchain-funcs
+
+MY_PN=qtscrob
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Updates a last.fm profile using information from a supported portable music player"
+HOMEPAGE="http://qtscrob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="cli +qt4"
+
+RDEPEND=">=media-libs/libmtp-1.1.0
+ net-misc/curl
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-free.patch
+}
+
+src_configure() {
+ if use qt4; then
+ pushd src/qt >/dev/null
+ eqmake4 ${MY_PN}.pro
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ if use cli; then
+ tc-export CXX
+ emake -C src/cli
+ fi
+
+ if use qt4; then
+ emake -C src/qt
+ fi
+}
+
+src_install() {
+ if use cli; then
+ newbin src/cli/scrobble-cli qtscrobbler-cli
+ fi
+
+ if use qt4; then
+ pushd src/qt >/dev/null
+ newbin qtscrob qtscrobbler
+ insinto /usr/share/icons/hicolor/128x128/apps
+ newins resources/icons/128.png qtscrobbler.png
+ make_desktop_entry qtscrobbler QtScrobbler
+ popd >/dev/null
+ fi
+
+ dodoc AUTHORS CHANGELOG README
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }