summaryrefslogtreecommitdiff
path: root/media-sound/shoutcast-search
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/shoutcast-search
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/shoutcast-search')
-rw-r--r--media-sound/shoutcast-search/Manifest2
-rw-r--r--media-sound/shoutcast-search/metadata.xml5
-rw-r--r--media-sound/shoutcast-search/shoutcast-search-0.3.1.ebuild40
-rw-r--r--media-sound/shoutcast-search/shoutcast-search-0.3.ebuild27
4 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/shoutcast-search/Manifest b/media-sound/shoutcast-search/Manifest
new file mode 100644
index 00000000000..2c9e7b2c230
--- /dev/null
+++ b/media-sound/shoutcast-search/Manifest
@@ -0,0 +1,2 @@
+DIST shoutcast-search-0.3.1.tar.gz 130203 RMD160 3df0d834e36d8bbe70c9dc1649337b4e313f4bb3 SHA1 c815a8eb4da5e185a74a25d9ac808217835d6a2d SHA256 ee21ffdca8e9f2697fce03ad57597a3ba778c2da8671b7a5ab60bfe66673ec83
+DIST shoutcast-search-0.3.tar.gz 18025 RMD160 81aa5a80e69efdc29cb4c215736b3d60df6d281d SHA1 daa222d1150089a60664059dc252bb9cfa80f29e SHA256 48b51980749e3046c681b2f9652f9132eb6f206ff44f57d282d16ca362470575
diff --git a/media-sound/shoutcast-search/metadata.xml b/media-sound/shoutcast-search/metadata.xml
new file mode 100644
index 00000000000..ae573a60407
--- /dev/null
+++ b/media-sound/shoutcast-search/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/shoutcast-search/shoutcast-search-0.3.1.ebuild b/media-sound/shoutcast-search/shoutcast-search-0.3.1.ebuild
new file mode 100644
index 00000000000..8c5daa88a9f
--- /dev/null
+++ b/media-sound/shoutcast-search/shoutcast-search-0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="shoutcast_search"
+
+inherit distutils
+
+DESCRIPTION="A command-line tool for searching SHOUTcast stations"
+HOMEPAGE="http://www.k2h.se/code/shoutcast-search.html"
+SRC_URI="http://github.com/halhen/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S=${WORKDIR}/halhen-${PN}-fc6b3aa
+
+src_prepare() {
+ python_convert_shebangs 2 ${PN}
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+ dodoc documentation.md || die
+}
diff --git a/media-sound/shoutcast-search/shoutcast-search-0.3.ebuild b/media-sound/shoutcast-search/shoutcast-search-0.3.ebuild
new file mode 100644
index 00000000000..a19cfc1513b
--- /dev/null
+++ b/media-sound/shoutcast-search/shoutcast-search-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit distutils
+
+DESCRIPTION="A command-line tool for searching SHOUTcast stations"
+HOMEPAGE="http://www.k2h.se/code/shoutcast-search.html"
+SRC_URI="http://www.k2h.se/code/dl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_install() {
+ distutils_src_install
+ dobin ${PN} || die "dobin failed"
+ doman ${PN}.1 || die "doman failed"
+ dodoc documentation.md || die "dodoc failed"
+}