summaryrefslogtreecommitdiff
path: root/media-sound/skype-call-recorder
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/skype-call-recorder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/skype-call-recorder')
-rw-r--r--media-sound/skype-call-recorder/Manifest1
-rw-r--r--media-sound/skype-call-recorder/files/skype-call-recorder-0.8-cmake.patch19
-rw-r--r--media-sound/skype-call-recorder/metadata.xml8
-rw-r--r--media-sound/skype-call-recorder/skype-call-recorder-0.8.ebuild39
4 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/skype-call-recorder/Manifest b/media-sound/skype-call-recorder/Manifest
new file mode 100644
index 00000000000..b402edcb6a0
--- /dev/null
+++ b/media-sound/skype-call-recorder/Manifest
@@ -0,0 +1 @@
+DIST skype-call-recorder-0.8.tar.gz 83842 SHA256 b115f728e09602cca7aa51479faa868de1f9b7cf887ed3d7c82f4935309c32c6 SHA512 f93b4aaf4f03b05bd74500485715b0ce97212f82ab9c9c1eeab57cc9589012ff4a96d81829f51605975328db27d0a6ab20c88e78c513ff61bb4e4b8038ca2b3c WHIRLPOOL 1f6fb8bce06bd98cca999fa86afaaa0bb0ba5970414d9fd90e247f95148d9afc7ba5a4a8d7292fc7064d624faa559636a0a5ddf79aa59a5eaeb04934166f81e0
diff --git a/media-sound/skype-call-recorder/files/skype-call-recorder-0.8-cmake.patch b/media-sound/skype-call-recorder/files/skype-call-recorder-0.8-cmake.patch
new file mode 100644
index 00000000000..74989e02591
--- /dev/null
+++ b/media-sound/skype-call-recorder/files/skype-call-recorder-0.8-cmake.patch
@@ -0,0 +1,19 @@
+diff -ruN skype-call-recorder-0.8/CMakeLists.txt my/CMakeLists.txt
+--- skype-call-recorder-0.8/CMakeLists.txt 2008-11-18 23:39:18.000000000 +0100
++++ my/CMakeLists.txt 2011-07-23 15:39:56.456877971 +0200
+@@ -5,14 +5,9 @@
+ PROJECT(skype-call-recorder)
+ SET(TARGET skype-call-recorder)
+
+-SET(CMAKE_BUILD_TYPE RELEASE)
+-#SET(CMAKE_BUILD_TYPE DEBUG)
+-
+ # compiler flags
+
+-SET(CMAKE_CXX_FLAGS "-Wall -W -pipe -fno-exceptions")
+-SET(CMAKE_CXX_FLAGS_DEBUG "-ggdb")
+-SET(CMAKE_CXX_FLAGS_RELEASE "-O2 -s")
++SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -W -pipe -fno-exceptions")
+
+ # sources
+
diff --git a/media-sound/skype-call-recorder/metadata.xml b/media-sound/skype-call-recorder/metadata.xml
new file mode 100644
index 00000000000..f9c2d89f349
--- /dev/null
+++ b/media-sound/skype-call-recorder/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-sound/skype-call-recorder/skype-call-recorder-0.8.ebuild b/media-sound/skype-call-recorder/skype-call-recorder-0.8.ebuild
new file mode 100644
index 00000000000..ce6bcfcd9eb
--- /dev/null
+++ b/media-sound/skype-call-recorder/skype-call-recorder-0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Records Skype calls to MP3/Ogg/WAV files"
+HOMEPAGE="http://atdot.ch/scr/"
+SRC_URI="http://atdot.ch/scr/files/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ media-libs/id3lib
+ >=media-libs/libogg-1.2.0
+ >=media-libs/libvorbis-1.2.0
+ media-sound/lame
+ >=dev-qt/qtcore-4.4:4
+ >=dev-qt/qtdbus-4.4:4
+ >=dev-qt/qtgui-4.4:4
+"
+RDEPEND="${DEPEND}
+ net-im/skype[-qt-static(-)]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ append-ldflags $(no-as-needed) -lvorbis -logg # bug 482744
+}