summaryrefslogtreecommitdiff
path: root/media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 12:02:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 13:11:20 +0100
commita5158f5deff99f65e872ce7a915f87a618b19341 (patch)
treef0bb9a380696401dff34db3dbf49755419d63d7b /media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild
parent91431e5f017626b04099f4d015b2699a97fb6d2f (diff)
downloadgentoo-a5158f5deff99f65e872ce7a915f87a618b19341.tar.gz
gentoo-a5158f5deff99f65e872ce7a915f87a618b19341.tar.xz
media-sound/soundkonverter: Fix add dirs to Replay Gain tool, EAPI-7
Fix HOMEPAGE. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild')
-rw-r--r--media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild b/media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild
new file mode 100644
index 00000000000..b930b9c11d2
--- /dev/null
+++ b/media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Frontend to various audio converters"
+HOMEPAGE="https://www.linux-apps.com/p/1126634/ https://github.com/dfaust/soundkonverter"
+SRC_URI="https://github.com/dfaust/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_kdeapps_dep libkcddb)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ >=media-libs/taglib-1.10
+ media-sound/cdparanoia
+"
+RDEPEND="${DEPEND}
+ !media-sound/soundkonverter:4
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-deps.patch"
+ "${FILESDIR}/${P}-fix-add-dirs.patch"
+ "${FILESDIR}/${P}-metainfodir.patch"
+)
+
+S="${WORKDIR}"/${P}/src
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog "soundKonverter optionally supports many different audio formats."
+ elog "You will need to install the appropriate encoding packages for the"
+ elog "formats you require. For a full listing, consult the README file"
+ elog "in /usr/share/doc/${PF}"
+}