summaryrefslogtreecommitdiff
path: root/media-sound/soundkonverter
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/soundkonverter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/soundkonverter')
-rw-r--r--media-sound/soundkonverter/Manifest2
-rw-r--r--media-sound/soundkonverter/metadata.xml6
-rw-r--r--media-sound/soundkonverter/soundkonverter-2.0.3.ebuild33
-rw-r--r--media-sound/soundkonverter/soundkonverter-2.1.2.ebuild36
4 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/soundkonverter/Manifest b/media-sound/soundkonverter/Manifest
new file mode 100644
index 00000000000..8bbc3d8f112
--- /dev/null
+++ b/media-sound/soundkonverter/Manifest
@@ -0,0 +1,2 @@
+DIST 29024-soundkonverter-2.0.3.tar.gz 591340 SHA256 86e1a62a47433ab446c165c16b8950d3ed00cf73dfb3d411019717e8e5d73f0c SHA512 106620e82162280c96ee809145d7196bec049f2a69c6808dce2528ccda5be1976c5a6aad32e25fb6b5578417e535263f4425edc1ebe4b28f6a2f5fdcb9478c98 WHIRLPOOL 2df0edd1342e63cde2407d8a36484d323304e8bddff89ad9f112e218e5f23a0820c51fb7b03d3303623681348df76a9b5895e243f358c6e3af6115722c8c4139
+DIST 29024-soundkonverter-2.1.2.tar.gz 756039 SHA256 b7b984cfcebb31c5e16fb3e04fc811b58453ef5454ea9e567e8510fcdd498957 SHA512 fdbb782eea4702d1b6bfe0135ed8ca482bd43422bc4c825b8b1afe3226faf315b618b4392223d5b3169e831c8e867ee64a11f22e22c53df7cb6b92dc5f1dda23 WHIRLPOOL 7f19644aff536d1715935b58f3c5bab27f7b967aadf7503ed26d168ba1fe1a92a76ba4bec28709c23053a46f32b593034e4941c2ec0e054e0eb8a79ad6097da2
diff --git a/media-sound/soundkonverter/metadata.xml b/media-sound/soundkonverter/metadata.xml
new file mode 100644
index 00000000000..3cbd34b008e
--- /dev/null
+++ b/media-sound/soundkonverter/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/media-sound/soundkonverter/soundkonverter-2.0.3.ebuild b/media-sound/soundkonverter/soundkonverter-2.0.3.ebuild
new file mode 100644
index 00000000000..367b0cc1bc8
--- /dev/null
+++ b/media-sound/soundkonverter/soundkonverter-2.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="cs de es et fr hu it pt pt_BR ru"
+inherit kde4-base
+
+DESCRIPTION="Frontend to various audio converters"
+HOMEPAGE="http://www.kde-apps.org/content/show.php/soundKonverter?content=29024"
+SRC_URI="http://kde-apps.org/CONTENT/content-files/29024-${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdeapps_dep libkcddb)
+ media-libs/taglib
+ media-sound/cdparanoia
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+pkg_postinst() {
+ elog "soundKonverter optionally supports many different audio formats."
+ elog "You will need to install the appropriate encoding packages for the"
+ elog "formats you require. For a full listing, consult the README file"
+ elog "in /usr/share/doc/${PF}"
+}
diff --git a/media-sound/soundkonverter/soundkonverter-2.1.2.ebuild b/media-sound/soundkonverter/soundkonverter-2.1.2.ebuild
new file mode 100644
index 00000000000..c97cd0ad9c4
--- /dev/null
+++ b/media-sound/soundkonverter/soundkonverter-2.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="ca cs de es et fr hu it pt pt_BR ro ru sl sv zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="Frontend to various audio converters"
+HOMEPAGE="http://www.kde-apps.org/content/show.php/soundKonverter?content=29024"
+SRC_URI="http://kde-apps.org/CONTENT/content-files/29024-${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdeapps_dep libkcddb)
+ media-libs/phonon[qt4]
+ media-libs/taglib
+ media-sound/cdparanoia
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ elog "soundKonverter optionally supports many different audio formats."
+ elog "You will need to install the appropriate encoding packages for the"
+ elog "formats you require. For a full listing, consult the README file"
+ elog "in /usr/share/doc/${PF}"
+}