summaryrefslogtreecommitdiff
path: root/media-sound/tudor-volumed
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/tudor-volumed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/tudor-volumed')
-rw-r--r--media-sound/tudor-volumed/Manifest1
-rw-r--r--media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch43
-rw-r--r--media-sound/tudor-volumed/metadata.xml8
-rw-r--r--media-sound/tudor-volumed/tudor-volumed-0_pre20110427.ebuild33
4 files changed, 85 insertions, 0 deletions
diff --git a/media-sound/tudor-volumed/Manifest b/media-sound/tudor-volumed/Manifest
new file mode 100644
index 00000000000..de70e54b2a2
--- /dev/null
+++ b/media-sound/tudor-volumed/Manifest
@@ -0,0 +1 @@
+DIST tudor-volumed-0_pre20110427.tar.gz 5651 SHA256 e531a8ddab8910ebe0e639167f9cb81210426b3665eab6da2e36710be774124c SHA512 e05e8fef96985355b2e12b34a8858b98fd508e1849bff377c96593a5fee6cdf542decae2b9f1292c25b886cdd44545d99350c4c614553665fa3c7ea21ce5bd51 WHIRLPOOL 259374ddb24809c4ea99f2dd0cfc7859c7b9fc2aebbdcf0b9ede2999e3ec81fb594c5105506962f32c16cb482668f9505c9835dcf54297470765125d08574107
diff --git a/media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch b/media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch
new file mode 100644
index 00000000000..73a5090665e
--- /dev/null
+++ b/media-sound/tudor-volumed/files/tudor-volumed-0_pre20110427-build.patch
@@ -0,0 +1,43 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue May 29 11:49:50 UTC 2012
+Subject: build system
+
+respect LDFLAGs, CXXFLAGs and CXX
+
+--- Makefile
++++ Makefile
+@@ -3,12 +3,12 @@
+ all: $(BIN)
+
+ $(BIN): $(OBJECTS)
+- $(CXX) $(CXXFLAGS) $^ -o $(BIN) $(LIBS) -ggdb
++ $(CXX) $(CXXFLAGS) $^ -o $(BIN) $(LDFLAGS) $(LIBS)
+
+ %.o: %.cpp
+- $(CXX) $(CXXFLAGS) -c $^ -o $@ -ggdb
++ $(CXX) $(CXXFLAGS) -c $^ -o $@
+
+ clean:
+ rm -f $(BIN) $(OBJECTS)
+
+-.PHONY: clean all
+\ No newline at end of file
++.PHONY: clean all
+--- config.mk
++++ config.mk
+@@ -2,7 +2,7 @@
+
+ NAME := tudor-volumed
+ OS := $(shell uname -o)
+-CXX := gcc
++CXX ?= gcc
+
+ LIBS := -lX11 -lstdc++
+ BIN := $(NAME)
+@@ -17,4 +17,4 @@
+ ifdef OSSLIBDIR
+ CXXFLAGS += -DUSE_OSS -I${OSSLIBDIR}/include/sys
+ OBJECTS += ossmixer.o
+-endif
+\ No newline at end of file
++endif
diff --git a/media-sound/tudor-volumed/metadata.xml b/media-sound/tudor-volumed/metadata.xml
new file mode 100644
index 00000000000..8e4208ba648
--- /dev/null
+++ b/media-sound/tudor-volumed/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="github">darvid/tudor-volumed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/tudor-volumed/tudor-volumed-0_pre20110427.ebuild b/media-sound/tudor-volumed/tudor-volumed-0_pre20110427.ebuild
new file mode 100644
index 00000000000..6ab69e4ba0c
--- /dev/null
+++ b/media-sound/tudor-volumed/tudor-volumed-0_pre20110427.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Lightweight, desktop environment agnostic volume management daemon"
+HOMEPAGE="https://github.com/darvid/tudor-volumed"
+SRC_URI="https://github.com/darvid/${PN}/tarball/7fc04cb2fb71e6f8815ddd87fd7ef5d02022edeb -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+pkg_setup() {
+ tc-export CXX
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ dobin ${PN}
+}