summaryrefslogtreecommitdiff
path: root/media-sound/vbrfixc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/vbrfixc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/vbrfixc')
-rw-r--r--media-sound/vbrfixc/Manifest1
-rw-r--r--media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch11
-rw-r--r--media-sound/vbrfixc/metadata.xml12
-rw-r--r--media-sound/vbrfixc/vbrfixc-0.24.ebuild29
4 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/vbrfixc/Manifest b/media-sound/vbrfixc/Manifest
new file mode 100644
index 00000000000..e75f12e1f98
--- /dev/null
+++ b/media-sound/vbrfixc/Manifest
@@ -0,0 +1 @@
+DIST vbrfixc-0.24.tar.gz 656877 SHA256 02d6363949407ac0e4b39ed76c60e49de0c286dbdce4f15363f771320430b364
diff --git a/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch b/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
new file mode 100644
index 00000000000..89e20e3aade
--- /dev/null
+++ b/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
@@ -0,0 +1,11 @@
+diff -ur vbrfixc-0.24/vbrfixc/vbrfix.cpp vbrfixc-0.24.dmd/vbrfixc/vbrfix.cpp
+--- vbrfixc-0.24/vbrfixc/vbrfix.cpp 2003-07-17 13:58:21.000000000 -0400
++++ vbrfixc-0.24.dmd/vbrfixc/vbrfix.cpp 2008-06-11 11:26:42.000000000 -0400
+@@ -16,6 +16,7 @@
+ ***************************************************************************/
+ #include "vbrfix.h"
+ //#include "stdafx.h"//include in mfc version
++#include <cstring>
+ int getXHpos(int ver,int chan);
+ VbrFix::VbrFix(){
+ frameptrs=NULL;flags=0;
diff --git a/media-sound/vbrfixc/metadata.xml b/media-sound/vbrfixc/metadata.xml
new file mode 100644
index 00000000000..63e33ea16ce
--- /dev/null
+++ b/media-sound/vbrfixc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Reconstructs MP3 files removing unwanted data, recreates VBR Tag with
+ seek information if it is VBR, can remove ID3v1/ID3v2/FHG/VBRI tags, can
+ keep the LAME part of the VBR tag while replacing the seek/bitrate info.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/vbrfixc/vbrfixc-0.24.ebuild b/media-sound/vbrfixc/vbrfixc-0.24.ebuild
new file mode 100644
index 00000000000..552d2652ebb
--- /dev/null
+++ b/media-sound/vbrfixc/vbrfixc-0.24.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Vbrfix fixes MP3s and re-constructs VBR headers"
+HOMEPAGE="http://home.gna.org/vbrfix/"
+SRC_URI="ftp://mirror.bytemark.co.uk/gentoo/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# bin endian ones need vbrfixc-0.24-bigendian.diff from gentoo-x86 cvs Attic
+KEYWORDS="amd64 x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README TODO
+ dohtml vbrfixc/docs/en/*.html
+}