summaryrefslogtreecommitdiff
path: root/media-sound/volti
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/volti
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/volti')
-rw-r--r--media-sound/volti/Manifest1
-rw-r--r--media-sound/volti/metadata.xml8
-rw-r--r--media-sound/volti/volti-0.2.3-r1.ebuild27
-rw-r--r--media-sound/volti/volti-0.2.3.ebuild29
4 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/volti/Manifest b/media-sound/volti/Manifest
new file mode 100644
index 00000000000..f13cee13a13
--- /dev/null
+++ b/media-sound/volti/Manifest
@@ -0,0 +1 @@
+DIST volti-0.2.3.tar.gz 164833 SHA256 216ca23cd4e8921ea73922125048e4f23fd3146045c0ef17cc4e10108dbd80dc SHA512 a2af2ad8c5475e6c2a08e5382748e7b5ed64130c6ac988afc8800ec505abf80ef1f73b3506ad4de2fc5177968aee806b779d0f0924ee92b1b734cf662f4266a3 WHIRLPOOL 91b6189ab6e8520244f0f919173aad6663a8bf6ea0d8665ce95c2fdf2b3e8ef3b7e682edcb3aa522e8f160530fdd0f67b368c279f6746f27172531450b6d06a5
diff --git a/media-sound/volti/metadata.xml b/media-sound/volti/metadata.xml
new file mode 100644
index 00000000000..b7f49681830
--- /dev/null
+++ b/media-sound/volti/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="google-code">volti</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/volti/volti-0.2.3-r1.ebuild b/media-sound/volti/volti-0.2.3-r1.ebuild
new file mode 100644
index 00000000000..c082652feee
--- /dev/null
+++ b/media-sound/volti/volti-0.2.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="GTK+ application for controlling audio volume from system tray/notification area"
+HOMEPAGE="http://code.google.com/p/volti/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="libnotify X"
+
+RDEPEND=">=dev-python/pygtk-2.16
+ >=dev-python/pyalsaaudio-0.7-r1
+ dev-python/dbus-python
+ X? ( >=dev-python/python-xlib-0.15_rc1 )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND=""
+
+DOCS=( AUTHORS ChangeLog README )
diff --git a/media-sound/volti/volti-0.2.3.ebuild b/media-sound/volti/volti-0.2.3.ebuild
new file mode 100644
index 00000000000..9fdb21a46c8
--- /dev/null
+++ b/media-sound/volti/volti-0.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="GTK+ application for controlling audio volume from system tray/notification area"
+HOMEPAGE="http://code.google.com/p/volti/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="libnotify X"
+
+RDEPEND=">=dev-python/pygtk-2.16
+ >=dev-python/pyalsaaudio-0.6
+ dev-python/dbus-python
+ X? ( >=dev-python/python-xlib-0.15_rc1 )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND=""
+
+DOCS="AUTHORS ChangeLog README"