summaryrefslogtreecommitdiff
path: root/media-sound/vsound
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/vsound
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/vsound')
-rw-r--r--media-sound/vsound/Manifest1
-rw-r--r--media-sound/vsound/files/vsound-0.6-stdout.patch13
-rw-r--r--media-sound/vsound/metadata.xml5
-rw-r--r--media-sound/vsound/vsound-0.6-r1.ebuild46
4 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/vsound/Manifest b/media-sound/vsound/Manifest
new file mode 100644
index 00000000000..afb38c7252c
--- /dev/null
+++ b/media-sound/vsound/Manifest
@@ -0,0 +1 @@
+DIST vsound-0.6.tar.gz 118026 RMD160 c39163dc0f7654987730b18dcc9f4f1078f853b0 SHA1 09ecea581546e6fb18427cde9c03b875f83eed80 SHA256 80711f2495f0faffd8b2d46afbdc3623e6701fcc20e6b85be82b6c4fdf467197
diff --git a/media-sound/vsound/files/vsound-0.6-stdout.patch b/media-sound/vsound/files/vsound-0.6-stdout.patch
new file mode 100644
index 00000000000..86cc6eb16c6
--- /dev/null
+++ b/media-sound/vsound/files/vsound-0.6-stdout.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/show_bug.cgi?id=117320
+diff -Naur vsound-0.6-orig/vsound.in vsound-0.6/vsound.in
+--- vsound-0.6-orig/vsound.in 2004-07-11 04:08:43.000000000 -0600
++++ vsound-0.6/vsound.in 2007-03-11 22:05:20.000000000 -0600
+@@ -153,7 +153,7 @@
+
+ export VSOUND_DATA=./vsound$$.au
+
+-if [ "$verbose" ] && [ "$VSOUND_STDOUT" ]; then
++if [ "$verbose" = 1 ] && [ "$VSOUND_STDOUT" ]; then
+ echo "Error : cannot specify both --verbose and --stdout."
+ exit 1
+ fi
diff --git a/media-sound/vsound/metadata.xml b/media-sound/vsound/metadata.xml
new file mode 100644
index 00000000000..e1774e3d9ad
--- /dev/null
+++ b/media-sound/vsound/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/vsound/vsound-0.6-r1.ebuild b/media-sound/vsound/vsound-0.6-r1.ebuild
new file mode 100644
index 00000000000..4e85fbbe27a
--- /dev/null
+++ b/media-sound/vsound/vsound-0.6-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="A virtual audio loopback cable"
+HOMEPAGE="http://www.vsound.org/"
+SRC_URI="http://www.vsound.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=media-sound/sox-14.2.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-stdout.patch
+ AT_M4DIR="." eautoreconf
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ elog
+ elog "To use this program to, for instance, record audio from realplayer:"
+ elog "vsound realplay realmediafile.rm"
+ elog
+ elog "Or, to listen to realmediafile.rm at the same time:"
+ elog "vsound -d realplay realmediafile.rm"
+ elog
+ elog "See ${HOMEPAGE} or /usr/share/doc/${PF}/README.bz2 for more info"
+ elog
+}