summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-31 00:12:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-31 00:12:28 +0100
commitf22a8107e9fab131ce3bc4bdaff7f2886312595b (patch)
tree3f187f2873f188b3184cd1a8593b085aee73dedb /media-sound
parent6810badb48c1e376b7e67644ae4610100168d5c3 (diff)
downloadgentoo-f22a8107e9fab131ce3bc4bdaff7f2886312595b.tar.gz
gentoo-f22a8107e9fab131ce3bc4bdaff7f2886312595b.tar.xz
media-sound/pamix: Upstream now uses cmake instead of autotools.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pamix/pamix-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-sound/pamix/pamix-9999.ebuild b/media-sound/pamix/pamix-9999.ebuild
index 05816380caa..acdf22771d0 100644
--- a/media-sound/pamix/pamix-9999.ebuild
+++ b/media-sound/pamix/pamix-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=6
SCM=""
[[ "${PV}" == 9999 ]] && SCM="git-r3"
-inherit autotools ${SCM}
+inherit cmake-utils ${SCM}
unset SCM
DESCRIPTION="A PulseAudio NCurses mixer"
@@ -30,9 +30,15 @@ DEPEND="sys-devel/autoconf-archive
src_prepare() {
default
- eautoreconf
+
+ # ugly hackaround for split tinfo ncurses libs
+ sed '/link_libraries.*ncurses/s@\(")\)@" "tinfo\1@' \
+ -i CMakeLists.txt || die
}
src_configure() {
- econf $(use_enable unicode)
+ local mycmakeargs=(
+ -DWITH_UNICODE="$(usex unicode)"
+ )
+ cmake-utils_src_configure
}