summaryrefslogtreecommitdiff
path: root/media-tv/wis-go7007/wis-go7007-0.9.8-r3.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-tv/wis-go7007/wis-go7007-0.9.8-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-tv/wis-go7007/wis-go7007-0.9.8-r3.ebuild')
-rw-r--r--media-tv/wis-go7007/wis-go7007-0.9.8-r3.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/media-tv/wis-go7007/wis-go7007-0.9.8-r3.ebuild b/media-tv/wis-go7007/wis-go7007-0.9.8-r3.ebuild
new file mode 100644
index 00000000000..05523665b3c
--- /dev/null
+++ b/media-tv/wis-go7007/wis-go7007-0.9.8-r3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils linux-mod udev
+
+MY_PN=${PN}-linux
+DESCRIPTION="Linux drivers for go7007 chipsets (Plextor ConvertX PVR)"
+HOMEPAGE="http://oss.wischip.com/ http://home.comcast.net/~bender647/go7007/"
+SRC_URI="http://oss.wischip.com/${MY_PN}-${PV}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+DEPEND="virtual/udev
+ sys-apps/fxload"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KERNELSRC=${KERNEL_DIR}"
+ CONFIG_CHECK="HOTPLUG MODULES KMOD FW_LOADER I2C VIDEO_DEV SOUND SND USB
+ USB_DEVICEFS USB_EHCI_HCD"
+
+ if use alsa; then
+ CONFIG_CHECK="${CONFIG_CHECK} SND_MIXER_OSS SND_PCM_OSS"
+ fi
+
+ if ! kernel_is ge 2 6 26; then
+ eerror "This ebuild version will only work with a 2.6.26 kernel"
+ die "Needs a different kernel"
+ fi
+
+ linux-mod_pkg_setup
+ MODULE_NAMES="go7007(extra:${S}:${S}/kernel)
+ go7007-usb(extra:${S}:${S}/kernel)
+ snd-go7007(extra:${S}:${S}/kernel)
+ wis-ov7640(extra:${S}:${S}/kernel)
+ wis-sony-tuner(extra:${S}:${S}/kernel)
+ wis-tw9903(extra:${S}:${S}/kernel)
+ wis-uda1342(extra:${S}:${S}/kernel)
+ wis-saa7113(extra:${S}:${S}/kernel)
+ wis-saa7115(extra:${S}:${S}/kernel)"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if kernel_is ge 2 6 26; then
+ epatch "${FILESDIR}/wis-go7007-updates.diff"
+ epatch "${FILESDIR}/wis-go7007-2.6.21-typdefs.diff"
+ epatch "${FILESDIR}/wis-go7007-2.6.24-no_algo_control.diff"
+ epatch "${FILESDIR}/wis-go7007-2.6.26-nopage.diff"
+ fi
+}
+
+src_compile() {
+ linux-mod_src_compile || die "failed to build driver "
+}
+
+src_install() {
+ cd "${S}/apps"
+ make KERNELDIR="${KERNEL_DIR}" DESTDIR="${D}" PREFIX=/usr install || die "failed to install"
+ cd "${S}"
+ dodir "/lib/modules"
+ insinto "/lib/modules"
+ dodoc README README.saa7134 RELEASE-NOTES
+ cd "${S}/kernel"
+ linux-mod_src_install || die "failed to install modules"
+
+ insinto "${KERNEL_DIR}/include/linux"
+ doins "${S}/include/*.h"
+ insinto "/lib/firmware"
+ doins "${S}/firmware/*.bin"
+ insinto "/lib/firmware/ezusb"
+ doins "${S}/firmware/ezusb/*.hex"
+ udev_dorules "${S}/udev/wis-ezusb.rules"
+
+ exeinto "/usr/bin"
+ use alsa && doexe "${S}/apps/gorecord"
+ doexe "${S}/apps/modet"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ elog ""
+ elog "For more information on how to use the Plextor devices with Gentoo"
+ elog "you can follow this thread for tips and tricks:"
+ elog "http://forums.gentoo.org/viewtopic-t-306559-highlight-.html"
+ elog ""
+ elog "Also, the unofficial Gentoo wiki has a HOWTO page:"
+ elog "http://gentoo-wiki.com/HARDWARE_go7007"
+ elog ""
+ ewarn "Don't forget to add your modules to /etc/modules.autoload.d/kernel.2.6"
+ ewarn "so they will load on startup:"
+ ewarn ""
+ ewarn "snd_go7007"
+ ewarn "go7007"
+ ewarn "go7007_usb"
+ ewarn "wis_saa7115"
+ ewarn "wis_uda1342"
+ ewarn "wis_sony_tuner"
+}