summaryrefslogtreecommitdiff
path: root/media-video/cclive
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-16 20:07:42 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-16 20:07:42 +0200
commit54f3e84cd0d244d3fc999a50a85be32194619155 (patch)
tree193d3b645a46c9c498cd8b059b9fd2c85df384ae /media-video/cclive
parent79bc101fff20b9b0b841c52fa7f934ff851dda07 (diff)
downloadgentoo-54f3e84cd0d244d3fc999a50a85be32194619155.tar.gz
gentoo-54f3e84cd0d244d3fc999a50a85be32194619155.tar.xz
media-video/cclive: Add subslot operator to dev-libs/boost
* EAPI 6 Bug: https://bugs.gentoo.org/show_bug.cgi?id=503462 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-video/cclive')
-rw-r--r--media-video/cclive/cclive-0.9.3-r2.ebuild (renamed from media-video/cclive/cclive-0.9.3-r1.ebuild)19
1 files changed, 10 insertions, 9 deletions
diff --git a/media-video/cclive/cclive-0.9.3-r1.ebuild b/media-video/cclive/cclive-0.9.3-r2.ebuild
index f3ab9b185f9..36533f23301 100644
--- a/media-video/cclive/cclive-0.9.3-r1.ebuild
+++ b/media-video/cclive/cclive-0.9.3-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils flag-o-matic
+inherit flag-o-matic
DESCRIPTION="Command line tool for extracting videos from various websites"
HOMEPAGE="http://cclive.sourceforge.net/"
@@ -13,9 +13,10 @@ LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
-RDEPEND=">=media-libs/libquvi-0.4.0
+RDEPEND="
+ >=media-libs/libquvi-0.4.0:0=
>=dev-cpp/glibmm-2.24:2
- >=dev-libs/boost-1.49
+ >=dev-libs/boost-1.49:=
>=dev-libs/glib-2.24:2
>=net-misc/curl-7.20
>=dev-libs/libpcre-8.02[cxx]"
@@ -23,10 +24,10 @@ DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-iostream.patch #527658
- epatch "${FILESDIR}"/${P}-boost-ver-check.patch #548310
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-iostream.patch #527658
+ "${FILESDIR}"/${P}-boost-ver-check.patch #548310
+)
src_configure() {
append-cxxflags -std=c++11 #567174