summaryrefslogtreecommitdiff
path: root/media-video/dfbsee
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/dfbsee
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/dfbsee')
-rw-r--r--media-video/dfbsee/Manifest1
-rw-r--r--media-video/dfbsee/dfbsee-0.7.4-r1.ebuild36
-rw-r--r--media-video/dfbsee/files/dfbsee-0.7.4-direcfb-0.9.24.patch21
-rw-r--r--media-video/dfbsee/files/dfbsee-0.7.4-gcc4.patch65
-rw-r--r--media-video/dfbsee/files/dfbsee-0.7.4-standardtypes.patch43
-rw-r--r--media-video/dfbsee/metadata.xml8
6 files changed, 174 insertions, 0 deletions
diff --git a/media-video/dfbsee/Manifest b/media-video/dfbsee/Manifest
new file mode 100644
index 00000000000..7f20a41dbc1
--- /dev/null
+++ b/media-video/dfbsee/Manifest
@@ -0,0 +1 @@
+DIST DFBSee-0.7.4.tar.gz 147346 SHA256 778115b9fba23de3dabc9ac117b73e2762d795fc97c299075434d74ae2dd87e8 SHA512 c2c3c78b72fae804d5923891be5ec07827162189ecb22d71cf061130ec3bf5a63d121b093ebc90e185d1c890c7ca98d4484f2bee91e42ee84993889d93b2d6ea WHIRLPOOL 083547c7a13136caaabf88fa5dfeeaeede9278d534f00a7d5cd8618e1639de70f514c8d66185ea9c37898b114f7ad639d0aee5da5a9afa09a8279b2d1dbb5477
diff --git a/media-video/dfbsee/dfbsee-0.7.4-r1.ebuild b/media-video/dfbsee/dfbsee-0.7.4-r1.ebuild
new file mode 100644
index 00000000000..7224a72aca1
--- /dev/null
+++ b/media-video/dfbsee/dfbsee-0.7.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+MY_PN="DFBSee"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="an image viewer and video player based on DirectFB"
+HOMEPAGE="http://directfb.org/index.php?path=Projects%2FDFBSee"
+SRC_URI="http://www.directfb.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 -sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/DirectFB-0.9.24[png]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-direcfb-0.9.24.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-standardtypes.patch"
+}
+
+src_configure() {
+ tc-export CC
+ default
+}
diff --git a/media-video/dfbsee/files/dfbsee-0.7.4-direcfb-0.9.24.patch b/media-video/dfbsee/files/dfbsee-0.7.4-direcfb-0.9.24.patch
new file mode 100644
index 00000000000..8a8d0cf4d3f
--- /dev/null
+++ b/media-video/dfbsee/files/dfbsee-0.7.4-direcfb-0.9.24.patch
@@ -0,0 +1,21 @@
+diff -Nru orig-DFBSee-0.7.4/src/main.c DFBSee-0.7.4/src/main.c
+--- orig-DFBSee-0.7.4/src/main.c 2005-12-05 15:12:38.000000000 +0800
++++ DFBSee-0.7.4/src/main.c 2005-12-05 15:14:14.000000000 +0800
+@@ -53,7 +53,7 @@
+ main (int argc,
+ char **argv)
+ {
+- DFBCardCapabilities caps;
++ DFBGraphicsDeviceDescription caps;
+ DFBSurfaceDescription dsc;
+ IDirectFBEventBuffer *buffer;
+ IDirectFBSurface *image_area;
+@@ -78,7 +78,7 @@
+ /* create the super interface */
+ DFBCHECK (DirectFBCreate (&dfb));
+
+- dfb->GetCardCapabilities (dfb, &caps);
++ dfb->GetDeviceDescription (dfb, &caps);
+ hw_stretchblit = caps.acceleration_mask & DFXL_STRETCHBLIT;
+
+ dfb->SetCooperativeLevel (dfb, DFSCL_FULLSCREEN);
diff --git a/media-video/dfbsee/files/dfbsee-0.7.4-gcc4.patch b/media-video/dfbsee/files/dfbsee-0.7.4-gcc4.patch
new file mode 100644
index 00000000000..5f17937b85e
--- /dev/null
+++ b/media-video/dfbsee/files/dfbsee-0.7.4-gcc4.patch
@@ -0,0 +1,65 @@
+diff -Nru orig-DFBSee-0.7.4/src/rotate.c DFBSee-0.7.4/src/rotate.c
+--- orig-DFBSee-0.7.4/src/rotate.c 2005-12-05 15:37:52.000000000 +0800
++++ DFBSee-0.7.4/src/rotate.c 2005-12-05 15:38:10.000000000 +0800
+@@ -43,9 +43,9 @@
+ {\
+ *d = *s;\
+ s++;\
+- (__u8*)d += dest_pitch;\
++ d = ((void*) d) + dest_pitch;\
+ }\
+- (__u8*)src += src_pitch;\
++ src = ((void*) src) + src_pitch;\
+ }\
+ }\
+
+@@ -53,7 +53,7 @@
+ {\
+ type d;\
+ type s;\
+- (__u8 *) dest += (height - 1) * dest_pitch;\
++ dest = ((void*) dest) + (height - 1) * dest_pitch;\
+ for (w = 0; w < width; w++)\
+ {\
+ h = height;\
+@@ -63,9 +63,9 @@
+ {\
+ *d = *s;\
+ s++;\
+- (__u8*)d -= dest_pitch;\
++ d = ((void*) d) - dest_pitch;\
+ }\
+- (__u8*)src += src_pitch;\
++ src = ((void*) src) + src_pitch;\
+ }\
+ }\
+
+@@ -73,7 +73,7 @@
+ {\
+ type d;\
+ type s;\
+- (__u8 *) dest += (height - 1) * dest_pitch;\
++ dest = ((void*) dest) + (height - 1) * dest_pitch;\
+ while (--height)\
+ {\
+ d = (type) dest + width - 1;\
+@@ -85,8 +85,8 @@
+ s++;\
+ d--;\
+ }\
+- (__u8*)src += src_pitch;\
+- (__u8*)dest -= dest_pitch;\
++ src = ((void*) src) - src_pitch;\
++ dest = ((void*) dest) + dest_pitch;\
+ }\
+ }\
+
+@@ -172,7 +172,7 @@
+ source->Lock (source, DSLF_READ, &src, &src_pitch);
+ destination->Lock (destination, DSLF_READ, &dest, &dest_pitch);
+
+- (__u8 *) dest += dest_pitch * y + DFB_BYTES_PER_PIXEL (pixelformat) * x;
++ dest += dest_pitch * y + DFB_BYTES_PER_PIXEL (pixelformat) * x;
+
+ rotate (dest, dest_pitch,
+ src, src_pitch, width, height, DFB_BYTES_PER_PIXEL (pixelformat),
diff --git a/media-video/dfbsee/files/dfbsee-0.7.4-standardtypes.patch b/media-video/dfbsee/files/dfbsee-0.7.4-standardtypes.patch
new file mode 100644
index 00000000000..c1a864965e8
--- /dev/null
+++ b/media-video/dfbsee/files/dfbsee-0.7.4-standardtypes.patch
@@ -0,0 +1,43 @@
+Index: DFBSee-0.7.4/src/rotate.c
+===================================================================
+--- DFBSee-0.7.4.orig/src/rotate.c
++++ DFBSee-0.7.4/src/rotate.c
+@@ -110,10 +110,10 @@ rotate (void *dest,
+ switch (bpp)
+ {
+ case 2:
+- ROTATE_LEFT (__u16 *)
++ ROTATE_LEFT (uint16_t *)
+ break;
+ case 4:
+- ROTATE_LEFT (__u32 *)
++ ROTATE_LEFT (uint32_t *)
+ break;
+ default:
+ break;
+@@ -125,10 +125,10 @@ rotate (void *dest,
+ switch (bpp)
+ {
+ case 2:
+- ROTATE_RIGHT (__u16 *)
++ ROTATE_RIGHT (uint16_t *)
+ break;
+ case 4:
+- ROTATE_RIGHT (__u32 *)
++ ROTATE_RIGHT (uint32_t *)
+ break;
+ default:
+ break;
+@@ -139,10 +139,10 @@ rotate (void *dest,
+ switch (bpp)
+ {
+ case 2:
+- ROTATE_HALF (__u16 *)
++ ROTATE_HALF (uint16_t *)
+ break;
+ case 4:
+- ROTATE_HALF (__u32 *)
++ ROTATE_HALF (uint32_t *)
+ break;
+ default:
+ break;
diff --git a/media-video/dfbsee/metadata.xml b/media-video/dfbsee/metadata.xml
new file mode 100644
index 00000000000..1cadc2e4ec2
--- /dev/null
+++ b/media-video/dfbsee/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>media-video@gentoo.org</email>
+</maintainer>
+</pkgmetadata>