summaryrefslogtreecommitdiff
path: root/media-video/ffmpegthumbnailer/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/ffmpegthumbnailer/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/ffmpegthumbnailer/files')
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch23
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch47
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch46
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch13
4 files changed, 129 insertions, 0 deletions
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
new file mode 100644
index 00000000000..60849455921
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
@@ -0,0 +1,23 @@
+From 9c2a5fe997a6d8b00bef49eabb7bc49840882ec6 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Wed, 29 Apr 2015 20:19:58 +0200
+Subject: [PATCH] Fixed configuration summary
+
+---
+ .travis.yml | 1 +
+ CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 22803d9..6b6e515 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -239,7 +239,7 @@ ELSE ()
+ MESSAGE(STATUS "register thumbnailer : disabled")
+ ENDIF ()
+
+-IF (ENABLE_UNITTEST)
++IF (ENABLE_TESTS)
+ MESSAGE(STATUS "unittests : enabled")
+ ELSE ()
+ MESSAGE(STATUS "unittests : disabled")
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
new file mode 100644
index 00000000000..33a96b85735
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
@@ -0,0 +1,47 @@
+From 621274d694dee1f8c92f5db99a5cff98e82c6bd4 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Sat, 2 May 2015 09:33:34 +0200
+Subject: [PATCH] Use proper gnu installation dirs (Thanks to Vallimar)
+
+---
+ CMakeLists.txt | 15 ++++++++-------
+ ChangeLog | 1 +
+ 2 files changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6b6e515..badb7cf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,6 +25,7 @@ ENDIF ()
+
+ PROJECT(${PACKAGE})
+ INCLUDE(CPack)
++INCLUDE(GNUInstallDirs)
+
+ SET(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+@@ -189,17 +190,17 @@ ELSE ()
+ ENDIF ()
+
+ INSTALL(TARGETS ffmpegthumbnailer ${STATIC_LIB} ${SHARED_LIB}
+- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
+- RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
+- ARCHIVE DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
+- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_PREFIX}/include/libffmpegthumbnailer
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/libffmpegthumbnailer
+ )
+
+-INSTALL(FILES man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
+-INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
++INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+ IF (ENABLE_THUMBNAILER)
+- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_PREFIX}/share/thumbnailers)
++ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_DATADIR}/thumbnailers)
+ ENDIF ()
+
+ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/config.h.in ${CMAKE_BINARY_DIR}/config.h)
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
new file mode 100644
index 00000000000..b1a198a93a1
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
@@ -0,0 +1,46 @@
+From 718f1b1147fe7e9138e2d503ed151e589d643772 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Sat, 18 Jul 2015 10:24:28 +0200
+Subject: [PATCH] Set locale to the user specified locale
+
+---
+ main.cpp | 5 ++---
+ test/testrunner.cpp | 7 ++-----
+ 2 files changed, 4 insertions(+), 8 deletions(-)
+
+diff --git a/main.cpp b/main.cpp
+index 6cb6c55..7cb7089 100644
+--- a/main.cpp
++++ b/main.cpp
+@@ -54,10 +54,9 @@ int main(int argc, char** argv)
+ string outputFile;
+ string imageFormat;
+
+- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
++ if (!std::setlocale(LC_CTYPE, ""))
+ {
+- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
+- return 1;
++ std::cerr << "Failed to set locale" << std::endl;
+ }
+
+ while ((option = getopt (argc, argv, "i:o:s:t:q:c:afwhvp")) != -1)
+diff --git a/test/testrunner.cpp b/test/testrunner.cpp
+index 7023d25..20a4903 100644
+--- a/test/testrunner.cpp
++++ b/test/testrunner.cpp
+@@ -4,12 +4,9 @@
+ #include <gtest/gtest.h>
+
+ int main(int argc, char **argv) {
+- std::cout << "Running ffmpegthumbnailer tests" << std::endl;
+-
+- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
++ if (!std::setlocale(LC_CTYPE, ""))
+ {
+- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
+- return 1;
++ std::cerr << "Failed to set locale" << std::endl;
+ }
+
+ testing::InitGoogleTest(&argc, argv);
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch
new file mode 100644
index 00000000000..5b9c68613e7
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch
@@ -0,0 +1,13 @@
+libffmpegthumbnailer/pngwriter.cpp: In function 'void ffmpegthumbnailer::writeDataCallback(png_structp, png_bytep, png_size_t)':
+libffmpegthumbnailer/pngwriter.cpp:111:52: error: 'memcpy' was not declared in this scope
+
+--- libffmpegthumbnailer/pngwriter.cpp
++++ libffmpegthumbnailer/pngwriter.cpp
+@@ -17,6 +17,7 @@
+ #include "pngwriter.h"
+ #include <stdexcept>
+ #include <cassert>
++#include <cstring>
+
+ using namespace std;
+