summaryrefslogtreecommitdiff
path: root/media-video/lives
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/lives
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/lives')
-rw-r--r--media-video/lives/Manifest1
-rw-r--r--media-video/lives/lives-1.4.6.ebuild78
-rw-r--r--media-video/lives/metadata.xml11
3 files changed, 90 insertions, 0 deletions
diff --git a/media-video/lives/Manifest b/media-video/lives/Manifest
new file mode 100644
index 00000000000..4236331ad62
--- /dev/null
+++ b/media-video/lives/Manifest
@@ -0,0 +1 @@
+DIST LiVES-1.4.6.tar.bz2 3086311 RMD160 8a3da63940f3449479b393cd1718c4842fa9c01e SHA1 6e5aa19ab29247d73d85be4924ad4bb50b863764 SHA256 67fb57571b80da680463f53f4e1aa2ac92d88f9437b7c9feb048faef7e617d59
diff --git a/media-video/lives/lives-1.4.6.ebuild b/media-video/lives/lives-1.4.6.ebuild
new file mode 100644
index 00000000000..74854555fce
--- /dev/null
+++ b/media-video/lives/lives-1.4.6.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+MY_P=LiVES-${PV}
+
+DESCRIPTION="LiVES is a Video Editing System"
+HOMEPAGE="http://lives.sf.net"
+SRC_URI="http://www.xs4all.nl/~salsaman/lives/current/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libvisual matroska nls ogg theora" # static-libs
+
+RDEPEND="media-video/mplayer
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ dev-lang/perl
+ >=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.16:2
+ media-libs/libsdl
+ media-libs/libv4l
+ virtual/ffmpeg
+ virtual/jpeg
+ media-sound/sox
+ virtual/cdrtools
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ media-plugins/frei0r-plugins
+ media-sound/jack-audio-connection-kit
+ >=media-video/mjpegtools-1.6.2
+ sys-libs/libavc1394
+ libvisual? ( media-libs/libvisual )
+ matroska? ( media-video/mkvtoolnix )
+ ogg? ( media-sound/ogmtools )
+ theora? ( media-libs/libtheora )"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED NEWS README )
+
+src_prepare() {
+ esvn_clean
+
+ # Don't try to detect installed copies wrt #295293
+ sed -i -e '/^PKG_CHECK_MODULES(WEED/s:true:false:' configure.in || die
+ sed -i -e '/test/s:sendOSC:dIsAbLeAuToMaGiC:' libOSC/sendOSC/Makefile.am || die
+
+ # Use python 2.x as per reference in plugins
+ sed -i \
+ -e '/#!.*env/s:python:python2:' \
+ lives-plugins/plugins/encoders/multi_encoder* \
+ lives-plugins/marcos-encoders/lives_*_encoder* || die
+
+ AT_M4DIR="mk/autoconf" eautoreconf # for the seds
+}
+
+src_configure() {
+ # $(use_enable static-libs static)
+ econf \
+ --disable-static \
+ $(use_enable libvisual) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"usr/bin/lives #384727
+ dosym lives-exe /usr/bin/lives
+
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+ # use static-libs ||
+ rm -f "${ED}"usr/lib*/libweed-*.a
+}
diff --git a/media-video/lives/metadata.xml b/media-video/lives/metadata.xml
new file mode 100644
index 00000000000..6c02db49f2f
--- /dev/null
+++ b/media-video/lives/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>lu_zero@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="libvisual">Enable libvisual support</flag>
+ </use>
+</pkgmetadata>