summaryrefslogtreecommitdiff
path: root/media-video/mjpg-streamer/mjpg-streamer-0_pre20120621-r1.ebuild
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2015-08-10 13:19:27 +0300
committerMikle Kolyada <zlogene@gentoo.org>2015-08-10 13:20:42 +0300
commit5356a342d4ad09098a73f130105ff049c56318ce (patch)
tree3208c2bff25c4e3ed7a77dd0d2f77f5313a2aa9c /media-video/mjpg-streamer/mjpg-streamer-0_pre20120621-r1.ebuild
parent36a13defe3ee8b47b7dc6019641eb0b9485b5252 (diff)
downloadgentoo-5356a342d4ad09098a73f130105ff049c56318ce.tar.gz
gentoo-5356a342d4ad09098a73f130105ff049c56318ce.tar.xz
media-video/mjpg-streamer: Fix compatibility with kernels newer than 3.18 (bug 556402)
Package-Manager: portage-2.2.20
Diffstat (limited to 'media-video/mjpg-streamer/mjpg-streamer-0_pre20120621-r1.ebuild')
-rw-r--r--media-video/mjpg-streamer/mjpg-streamer-0_pre20120621-r1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/media-video/mjpg-streamer/mjpg-streamer-0_pre20120621-r1.ebuild b/media-video/mjpg-streamer/mjpg-streamer-0_pre20120621-r1.ebuild
new file mode 100644
index 00000000000..76fc2e3a86c
--- /dev/null
+++ b/media-video/mjpg-streamer/mjpg-streamer-0_pre20120621-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mjpg-streamer/mjpg-streamer-0_pre20120421.ebuild,v 1.1 2012/04/23 10:00:59 aidecoe Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="MJPG-streamer takes JPGs from Linux-UVC compatible webcams"
+HOMEPAGE="http://sourceforge.net/projects/mjpg-streamer"
+SRC_URI="http://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+INPUT_PLUGINS="input_testpicture input_control input_file input_uvc"
+OUTPUT_PLUGINS="output_file output_udp output_http output_autofocus output_rtsp"
+IUSE_PLUGINS="${INPUT_PLUGINS} ${OUTPUT_PLUGINS}"
+IUSE="input_testpicture input_control +input_file input_uvc output_file
+ output_udp +output_http output_autofocus output_rtsp
+ www v4l"
+REQUIRED_USE="|| ( ${INPUT_PLUGINS} )
+ || ( ${OUTPUT_PLUGINS} )
+ v4l? ( input_uvc )"
+
+RDEPEND="virtual/jpeg
+ v4l? ( input_uvc? ( media-libs/libv4l ) )"
+DEPEND="${RDEPEND}
+ input_testpicture? ( media-gfx/imagemagick )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-make-var-instead-of-cmd.patch"
+ epatch "${FILESDIR}/${PV}-to-work-with-kernel-3.18.patch"
+
+
+ local flag switch
+
+ for flag in ${IUSE_PLUGINS}; do
+ use ${flag} && switch='' || switch='#'
+ sed -i \
+ -e "s|^#*PLUGINS +\?= ${flag}.so|${switch}PLUGINS += ${flag}.so|" \
+ Makefile
+ done
+}
+
+src_compile() {
+ local v4l=$(use v4l && use input_uvc && echo 'USE_LIBV4L2=true')
+ emake ${v4l}
+}
+
+src_install() {
+ into /usr
+ dobin ${PN//-/_}
+ dolib.so *.so
+
+ if use www ; then
+ insinto /usr/share/${PN}
+ doins -r www
+ fi
+
+ dodoc README TODO
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ elog "Remember to set an input and output plugin for mjpg-streamer."
+
+ if use www ; then
+ echo
+ elog "An example webinterface has been installed into"
+ elog "/usr/share/mjpg-streamer/www for your usage."
+ fi
+}