summaryrefslogtreecommitdiff
path: root/media-video/mpgtx
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/mpgtx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/mpgtx')
-rw-r--r--media-video/mpgtx/Manifest1
-rw-r--r--media-video/mpgtx/files/mpgtx-1.3.1-configure.patch69
-rw-r--r--media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch11
-rw-r--r--media-video/mpgtx/metadata.xml11
-rw-r--r--media-video/mpgtx/mpgtx-1.3.1-r2.ebuild48
5 files changed, 140 insertions, 0 deletions
diff --git a/media-video/mpgtx/Manifest b/media-video/mpgtx/Manifest
new file mode 100644
index 00000000000..8c23cbfebd4
--- /dev/null
+++ b/media-video/mpgtx/Manifest
@@ -0,0 +1 @@
+DIST mpgtx-1.3.1.tar.gz 89170 SHA256 8815e73e98b862f12ba1ef5eaaf49407cf211c1f668c5ee325bf04af27f8e377 SHA512 0f568673811f709383b3f262b19d3ec69de6807671c05a98266b21f2bfa6a8b85d2a8b95c3cec38bb012afb9d8add19a3f38b74b3e90f66cf233a1d26aaca805 WHIRLPOOL 7e52a0f74609837c07d2b0792f862e05a37598c037c2828b1521220527fc08922250cd6974e932877f726cfc699fc884f615d0ad307db6aaa45e44a35d7e0d53
diff --git a/media-video/mpgtx/files/mpgtx-1.3.1-configure.patch b/media-video/mpgtx/files/mpgtx-1.3.1-configure.patch
new file mode 100644
index 00000000000..ec36e76ba64
--- /dev/null
+++ b/media-video/mpgtx/files/mpgtx-1.3.1-configure.patch
@@ -0,0 +1,69 @@
+--- configure.old 2006-12-07 19:51:08.000000000 +0100
++++ configure 2006-12-07 19:51:02.000000000 +0100
+@@ -9,7 +9,6 @@
+ prefix="/usr/local"
+ manprefix='$(PREFIX)'
+ #compiler flags
+-CC="g++"
+ common_cflags="-Wall"
+ devel_cflags="-g -Werror -fno-builtin"
+ optimization_cflags="-O3"
+@@ -36,7 +35,6 @@
+
+ if [ "${HOSTNAME}" = "powerpc-apple-darwin6.0" ]; then
+ #compiler flags
+-CC="c++"
+ common_cflags="-pedantic -Wall"
+ #devel_cflags="-g -Werror -fno-builtin"
+ devel_cflags="-g -fno-builtin"
+@@ -153,8 +151,15 @@
+ if test "$gcc_minor" = "0" -o "$gcc_minor" = "1"; then
+ optimization_cflags="-O2";
+ fi
++ if test "$gcc_minor" -ge 4; then
++ optimization_cflags="$optimization_cflags -fno-unit-at-a-time"
++ fi
++elif test "$gcc_major" -ge "4"; then
++ optimization_cflags="$optimization_cflags -fno-unit-at-a-time"
+ fi
+
++
++
+ # Now check if the system handles large file support
+ # unless user has specified not to do so
+ if test $LFS = "yes"; then
+@@ -165,7 +170,7 @@
+ return (int)(fseeko(stdin,0,SEEK_SET));
+ }
+ EOF
+- $CC __LFStest.cpp -o __LFStestPASSED -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE 1>__LFSout 2>__LFSerror
++ ${CXX:-c++} __LFStest.cpp -o __LFStestPASSED -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE 1>__LFSout 2>__LFSerror
+ if test -f __LFStestPASSED; then
+ echo "PASSED";
+ cflags="$cflags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE";
+@@ -211,7 +211,6 @@
+ fi
+
+ if test $devel = "no" -a $debug = "no"; then
+-lflags="$lflags -s";
+ cflags="$cflags $optimization_cflags";
+ fi
+
+@@ -293,15 +298,15 @@
+ @echo ""
+
+ mpgtx : commandline.cxx mpegOut.o mpeg.o chunkTab.o id3command.o common.hh
+- $CC \$(CFLAGS) \$(OFLAGS) -o mpgtx commandline.cxx mpegOut.o mpeg.o chunkTab.o id3command.o \$(LFLAGS)
++ \$(CXX) \$(CFLAGS) \$(OFLAGS) \$(LDFLAGS) -o mpgtx commandline.cxx mpegOut.o mpeg.o chunkTab.o id3command.o \$(LFLAGS)
+ mpegOut.o : mpegOut.cxx mpegOut.hh mpeg.hh common.hh
+- $CC \$(CFLAGS) \$(OFLAGS) -c mpegOut.cxx
++ \$(CXX) \$(CFLAGS) \$(OFLAGS) -c mpegOut.cxx
+ mpeg.o : mpeg.cxx mpeg.hh mpegOut.hh common.hh
+- $CC \$(CFLAGS) \$(OFLAGS) -c mpeg.cxx
++ \$(CXX) \$(CFLAGS) \$(OFLAGS) -c mpeg.cxx
+ chunkTab.o : chunkTab.cxx chunkTab.hh common.hh
+- $CC \$(CFLAGS) \$(OFLAGS) -c chunkTab.cxx
++ \$(CXX) \$(CFLAGS) \$(OFLAGS) -c chunkTab.cxx
+ id3command.o : id3command.cxx id3command.hh common.hh
+- $CC \$(CFLAGS) \$(OFLAGS) -c id3command.cxx
++ \$(CXX) \$(CFLAGS) \$(OFLAGS) -c id3command.cxx
diff --git a/media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch b/media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch
new file mode 100644
index 00000000000..3a7f5da6745
--- /dev/null
+++ b/media-video/mpgtx/files/mpgtx-1.3.1-dont-ignore-cxx-flags.patch
@@ -0,0 +1,11 @@
+--- mpgtx-1.3.1/configure.old 2006-12-09 00:26:18.000000000 +0100
++++ mpgtx-1.3.1/configure 2006-12-09 00:28:52.000000000 +0100
+@@ -11,7 +11,7 @@
+ #compiler flags
+ common_cflags="-Wall"
+ devel_cflags="-g -Werror -fno-builtin"
+-optimization_cflags="-O3"
++optimization_cflags="${CXXFLAGS}"
+ release_cflags=$optimization_cflags
+ OFLAGS="-ansi"
+ cflags=$common_cflags
diff --git a/media-video/mpgtx/metadata.xml b/media-video/mpgtx/metadata.xml
new file mode 100644
index 00000000000..9d7e585c63e
--- /dev/null
+++ b/media-video/mpgtx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mpgtx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/mpgtx/mpgtx-1.3.1-r2.ebuild b/media-video/mpgtx/mpgtx-1.3.1-r2.ebuild
new file mode 100644
index 00000000000..34f40ead518
--- /dev/null
+++ b/media-video/mpgtx/mpgtx-1.3.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Command line MPEG audio/video/system file toolbox"
+SRC_URI="mirror://sourceforge/mpgtx/${P}.tar.gz"
+HOMEPAGE="http://mpgtx.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-configure.patch \
+ "${FILESDIR}"/${P}-dont-ignore-cxx-flags.patch
+ tc-export CXX
+}
+
+src_configure() {
+ ./configure --parachute || die
+}
+
+src_install() {
+ dobin mpgtx
+
+ dosym mpgtx /usr/bin/mpgjoin
+ dosym mpgtx /usr/bin/mpgsplit
+ dosym mpgtx /usr/bin/mpgcat
+ dosym mpgtx /usr/bin/mpginfo
+ dosym mpgtx /usr/bin/mpgdemux
+ dosym mpgtx /usr/bin/tagmp3
+
+ doman man/mpgtx.1 man/tagmp3.1
+
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgcat.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgjoin.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpginfo.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgsplit.1
+ dosym /usr/share/man/man1/mpgtx.1 /usr/share/man/man1/mpgdemux.1
+
+ dodoc AUTHORS ChangeLog README TODO
+}