summaryrefslogtreecommitdiff
path: root/media-video/mplayer-sh
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/mplayer-sh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/mplayer-sh')
-rw-r--r--media-video/mplayer-sh/Manifest2
-rw-r--r--media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff84
-rw-r--r--media-video/mplayer-sh/files/mplayer-sh-0.8.7-parameter-aid.diff84
-rw-r--r--media-video/mplayer-sh/metadata.xml12
-rw-r--r--media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild43
-rw-r--r--media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild43
6 files changed, 268 insertions, 0 deletions
diff --git a/media-video/mplayer-sh/Manifest b/media-video/mplayer-sh/Manifest
new file mode 100644
index 00000000000..7789fbc71a1
--- /dev/null
+++ b/media-video/mplayer-sh/Manifest
@@ -0,0 +1,2 @@
+DIST mplayer.sh-0.8.6.tar.gz 7568 SHA256 3d98b55f7b173296ac40d14b967f525459f415b340322de53cd8105cca4851ef
+DIST mplayer.sh-0.8.7.tar.gz 7851 SHA256 271f1105efcc6292117d826255f873da4ef70cf517f523d65a36036c74c60dcf
diff --git a/media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff b/media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff
new file mode 100644
index 00000000000..3b329215564
--- /dev/null
+++ b/media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff
@@ -0,0 +1,84 @@
+--- mplayer.sh.orig 2006-03-26 23:31:10.000000000 +0200
++++ mplayer.sh 2006-03-26 23:50:39.000000000 +0200
+@@ -6,6 +6,7 @@
+ declare VERSION="0.8.6"
+
+ # History (as always in the source code :-)
++# - add -aid to mplayer when AID is given (Matthias Schwarzott <zzam@gentoo.org>)
+ # 0.8.6 - fixed a copy'n'paste bug regarding the subtitle background
+ # alpha color (thanks to Christian Haider)
+ # - changed the fps values from rational values to integer ones
+@@ -208,6 +209,11 @@
+ fi
+ debugvar REMOTE "$REMOTE"
+
++ if test -n "${AID}"; then
++ AUDIO="-aid ${AID}"
++ fi
++ debugvar AUDIO "${AUDIO}"
++
+ if ! test -z "$USERDEF"; then echolog "*** Use Option USERDEF at your own risk!"; fi
+ debugvar USERDEF "$USERDEF"
+
+@@ -478,15 +484,24 @@
+ declare -i NEW_X NEW_Y
+ declare -i HALF_Y FULL_Y
+ declare ORIG_FPS NEW_FPS ORIG_ASPECT VIDEO_FORMAT AUDIO_CODEC
+-declare CMDLINE AOUT REMOTE USERDEF SUFFIX
++declare CMDLINE AOUT REMOTE AUDIO USERDEF SUFFIX
+ declare FILE="$1"
+-declare SLAVE="$2"
++shift
+ declare -a XResPAL[0]
+ declare -a XResNTSC[0]
+ declare FDSTR=""
+ declare SUBTITLES=""
+ declare DETC=""
+
++while [[ -n $1 ]]; do
++ case ${1} in
++ SLAVE) SLAVE=SLAVE ;;
++ AID) AID=${2}; shift ;;
++ esac
++
++ shift
++done
++
+ echolog "*** Starting mplayer.sh Version $VERSION"
+
+ if test -z "$FILE"; then echolog "*** USAGE: mplayer.sh <File_to_be_played>"; exit; fi
+@@ -504,18 +519,18 @@
+ if test \( "$FILE" == "$DVDFiles/DVD" -o "$FILE" == "$DVDFiles/VCD" \) -a -n "$DVDFiles" -a -n "$DVD"; then
+ if test "$FILE" == "$DVDFiles/DVD"; then
+ $USEAC3 && AOUT="$AC3AOUT"
+- CMDLINE="$MPLAYER -vo $VO $AOUT -alang $DVDLANG $DVDOPTIONS $FDSTR $CACHESTR $REMOTE $USERDEF -dvd-device $DVD dvd://"
++ CMDLINE="$MPLAYER -vo $VO $AOUT -alang $DVDLANG $DVDOPTIONS $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -dvd-device $DVD dvd://"
+ fi
+ if test "$FILE" == "$DVDFiles/VCD"; then
+- CMDLINE="$MPLAYER -vo $VO $AOUT $VCDOPTIONS $FDSTR $CACHESTR $REMOTE $USERDEF -cdrom-device $DVD vcd://"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $VCDOPTIONS $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -cdrom-device $DVD vcd://"
+ fi
+ unset FILE
+ elif test "${SUFFIX}" == ".cue"; then
+ if $MPLAYER_V1; then
+- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF cue://$FILE:2"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF cue://$FILE:2"
+ unset FILE
+ else
+- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF -vcd 2 -cuefile"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -vcd 2 -cuefile"
+ fi
+ else
+ # Try to determine the video attributes
+@@ -545,9 +560,9 @@
+ \( $NTSC -a $NEW_FPS == "30" -a \( \( $ORIG_X == "352" -a $ORIG_Y == "240" \) -o \( $ORIG_Y == "480" -a \
+ \( $ORIG_X == "352" -o $ORIG_X == "480" -o $ORIG_X == "512" -o $ORIG_X == "640" -o $ORIG_X == "704" -o $ORIG_X == "720" \) \) \) \) \
+ \) ; then
+- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF"
+ else
+- CMDLINE="$MPLAYER -vo $VO $AOUT -vop $VOP:$NEW_FPS,expand=$NEW_X:$REAL_Y:-1:-1:1,scale=$NEW_X:${NEW_Y}${DETC} $SPEED $FDSTR $CACHESTR $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
++ CMDLINE="$MPLAYER -vo $VO $AOUT -vop $VOP:$NEW_FPS,expand=$NEW_X:$REAL_Y:-1:-1:1,scale=$NEW_X:${NEW_Y}${DETC} $SPEED $FDSTR $CACHESTR $AUDIO $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
+ fi
+ fi
+
diff --git a/media-video/mplayer-sh/files/mplayer-sh-0.8.7-parameter-aid.diff b/media-video/mplayer-sh/files/mplayer-sh-0.8.7-parameter-aid.diff
new file mode 100644
index 00000000000..3de61e76cd1
--- /dev/null
+++ b/media-video/mplayer-sh/files/mplayer-sh-0.8.7-parameter-aid.diff
@@ -0,0 +1,84 @@
+--- mplayer.sh.orig 2007-02-11 16:34:07.000000000 +0100
++++ mplayer.sh 2007-05-05 18:17:48.000000000 +0200
+@@ -12,6 +12,7 @@
+ # - calculate USE_SPEED with 30 fps instead of 29.97
+ # - use '-vf' and '-af' instead of '-vop' and '-aop', as the
+ # latter are deprecated
++# - add -aid to mplayer when AID is given (Matthias Schwarzott <zzam@gentoo.org>)
+ #
+ # 0.8.6 - fixed a copy'n'paste bug regarding the subtitle background
+ # alpha color (thanks to Christian Haider)
+@@ -215,6 +216,11 @@
+ fi
+ debugvar REMOTE "$REMOTE"
+
++ if test -n "${AID}"; then
++ AUDIO="-aid ${AID}"
++ fi
++ debugvar AUDIO "${AUDIO}"
++
+ if ! test -z "$USERDEF"; then echolog "*** Use Option USERDEF at your own risk!"; fi
+ debugvar USERDEF "$USERDEF"
+
+@@ -485,15 +491,24 @@
+ declare -i NEW_X NEW_Y
+ declare -i HALF_Y FULL_Y
+ declare ORIG_FPS NEW_FPS ORIG_ASPECT VIDEO_FORMAT AUDIO_CODEC
+-declare CMDLINE AOUT REMOTE USERDEF SUFFIX
++declare CMDLINE AOUT REMOTE AUDIO USERDEF SUFFIX
+ declare FILE="$1"
+-declare SLAVE="$2"
++shift
+ declare -a XResPAL[0]
+ declare -a XResNTSC[0]
+ declare FDSTR=""
+ declare SUBTITLES=""
+ declare DETC=""
+
++while [[ -n $1 ]]; do
++ case ${1} in
++ SLAVE) SLAVE=SLAVE ;;
++ AID) AID=${2}; shift ;;
++ esac
++
++ shift
++done
++
+ echolog "*** Starting mplayer.sh Version $VERSION"
+
+ if test -z "$FILE"; then echolog "*** USAGE: mplayer.sh <File_to_be_played>"; exit; fi
+@@ -511,18 +526,18 @@
+ if test \( "$FILE" == "$DVDFiles/DVD" -o "$FILE" == "$DVDFiles/VCD" \) -a -n "$DVDFiles" -a -n "$DVD"; then
+ if test "$FILE" == "$DVDFiles/DVD"; then
+ $USEAC3 && AOUT="$AC3AOUT"
+- CMDLINE="$MPLAYER -vo $VO $AOUT -alang $DVDLANG $DVDOPTIONS $FDSTR $CACHESTR $REMOTE $USERDEF -dvd-device $DVD dvd://"
++ CMDLINE="$MPLAYER -vo $VO $AOUT -alang $DVDLANG $DVDOPTIONS $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -dvd-device $DVD dvd://"
+ fi
+ if test "$FILE" == "$DVDFiles/VCD"; then
+- CMDLINE="$MPLAYER -vo $VO $AOUT $VCDOPTIONS $FDSTR $CACHESTR $REMOTE $USERDEF -cdrom-device $DVD vcd://"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $VCDOPTIONS $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -cdrom-device $DVD vcd://"
+ fi
+ unset FILE
+ elif test "${SUFFIX}" == ".cue"; then
+ if $MPLAYER_V1; then
+- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF cue://$FILE:2"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF cue://$FILE:2"
+ unset FILE
+ else
+- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF -vcd 2 -cuefile"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -vcd 2 -cuefile"
+ fi
+ else
+ # Try to determine the video attributes
+@@ -552,9 +567,9 @@
+ \( $NTSC -a $NEW_FPS == "30" -a \( \( $ORIG_X == "352" -a $ORIG_Y == "240" \) -o \( $ORIG_Y == "480" -a \
+ \( $ORIG_X == "352" -o $ORIG_X == "480" -o $ORIG_X == "512" -o $ORIG_X == "544" -o $ORIG_X == "640" -o $ORIG_X == "704" -o $ORIG_X == "720" \) \) \) \) \
+ \) ; then
+- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF"
++ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF"
+ else
+- CMDLINE="$MPLAYER -vo $VO $AOUT -vf scale=$NEW_X:${NEW_Y}${DETC},expand=$NEW_X:$REAL_Y:-1:-1:1,$VOP:$NEW_FPS $SPEED $FDSTR $CACHESTR $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
++ CMDLINE="$MPLAYER -vo $VO $AOUT -vf scale=$NEW_X:${NEW_Y}${DETC},expand=$NEW_X:$REAL_Y:-1:-1:1,$VOP:$NEW_FPS $SPEED $FDSTR $CACHESTR $AUDIO $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
+ fi
+ fi
+
diff --git a/media-video/mplayer-sh/metadata.xml b/media-video/mplayer-sh/metadata.xml
new file mode 100644
index 00000000000..e346761c018
--- /dev/null
+++ b/media-video/mplayer-sh/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ API script between Plugin vdr-mplayer and mplayer.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild b/media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild
new file mode 100644
index 00000000000..01e1c0c9cc6
--- /dev/null
+++ b/media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+RESTRICT="mirror bindist"
+
+inherit eutils
+
+DESCRIPTION="Video Disk Recorder Mplayer API Script"
+HOMEPAGE="http://batleth.sapienti-sat.org/"
+SRC_URI="http://batleth.sapienti-sat.org/projects/VDR/mplayer.sh-${PV}.tar.gz"
+
+KEYWORDS="x86 ~amd64"
+SLOT="0"
+LICENSE="all-rights-reserved"
+IUSE=""
+
+RDEPEND=">=media-video/mplayer-0.90_rc4"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-parameter-aid.diff"
+
+ sed -i "s:^declare CFGFIL.*$:declare CFGFIL=\"\/etc\/vdr\/plugins\/mplayer\/mplayer.sh.conf\":" mplayer.sh
+ sed -i mplayer.sh.conf -e "s:^LIRCRC.*$:LIRCRC=\/etc\/lircd.conf:" \
+ -e "s:^MPLAYER=.*$:MPLAYER=\/usr\/bin\/mplayer:"
+}
+
+src_install() {
+
+ insinto /etc/vdr/plugins/mplayer
+ doins mplayer.sh.conf
+
+ into /usr/share/vdr/mplayer
+ dobin mplayer.sh
+
+ dodir /etc/vdr/plugins/DVD-VCD
+ touch "${D}"/etc/vdr/plugins/DVD-VCD/{DVD,VCD}
+ fowners vdr:video /etc/vdr/plugins/DVD-VCD/{DVD,VCD}
+}
diff --git a/media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild b/media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild
new file mode 100644
index 00000000000..8a645260ef2
--- /dev/null
+++ b/media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+RESTRICT="mirror bindist"
+
+DESCRIPTION="Video Disk Recorder Mplayer API Script"
+HOMEPAGE="http://batleth.sapienti-sat.org/projects/VDR/"
+SRC_URI="http://batleth.sapienti-sat.org/projects/VDR/versions/mplayer.sh-${PV}.tar.gz"
+
+KEYWORDS="x86 ~amd64"
+SLOT="0"
+LICENSE="all-rights-reserved"
+IUSE=""
+
+RDEPEND=">=media-video/mplayer-0.1.20070321"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-parameter-aid.diff"
+
+ sed -i "s:^declare CFGFIL.*$:declare CFGFIL=\"\/etc\/vdr\/plugins\/mplayer\/mplayer.sh.conf\":" mplayer.sh
+ sed -i mplayer.sh.conf -e "s:^LIRCRC.*$:LIRCRC=\/etc\/lircd.conf:" \
+ -e "s:^MPLAYER=.*$:MPLAYER=\/usr\/bin\/mplayer:"
+}
+
+src_install() {
+
+ insinto /etc/vdr/plugins/mplayer
+ doins mplayer.sh.conf
+
+ into /usr/share/vdr/mplayer
+ dobin mplayer.sh
+
+ dodir /etc/vdr/plugins/DVD-VCD
+ touch "${D}"/etc/vdr/plugins/DVD-VCD/{DVD,VCD}
+ fowners vdr:vdr /etc/vdr/plugins/DVD-VCD/{DVD,VCD}
+}