summaryrefslogtreecommitdiff
path: root/media-video/pgmfindclip
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/pgmfindclip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/pgmfindclip')
-rw-r--r--media-video/pgmfindclip/Manifest1
-rw-r--r--media-video/pgmfindclip/metadata.xml8
-rw-r--r--media-video/pgmfindclip/pgmfindclip-1.13.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/media-video/pgmfindclip/Manifest b/media-video/pgmfindclip/Manifest
new file mode 100644
index 00000000000..fff0a2ed723
--- /dev/null
+++ b/media-video/pgmfindclip/Manifest
@@ -0,0 +1 @@
+DIST pgmfindclip-1.13.tgz 4971 RMD160 15cd9365a2af33ed1cfdcacdc7e31505ad70f9c9 SHA1 ef7d91d48b52d9fe011a577e099eeb8a2f997a9f SHA256 eaa0f3d4e4904b14fba45ca45b06511839331c37c3c08463c633f4d3f12dbdf2
diff --git a/media-video/pgmfindclip/metadata.xml b/media-video/pgmfindclip/metadata.xml
new file mode 100644
index 00000000000..edccfe5754d
--- /dev/null
+++ b/media-video/pgmfindclip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+<email>media-video@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-video/pgmfindclip/pgmfindclip-1.13.ebuild b/media-video/pgmfindclip/pgmfindclip-1.13.ebuild
new file mode 100644
index 00000000000..84f03032f1e
--- /dev/null
+++ b/media-video/pgmfindclip/pgmfindclip-1.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+IUSE=""
+
+S="${WORKDIR}"
+
+DESCRIPTION="automatically find a clipping border for a sequence of pgm images"
+HOMEPAGE="http://www.lallafa.de/bp/pgmfindclip.html"
+SRC_URI="http://www.lallafa.de/bp/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's:gcc .* -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' "${S}"/Makefile
+}
+
+src_compile () {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ dobin ${PN} || die
+}