summaryrefslogtreecommitdiff
path: root/media-video/photofilmstrip
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/photofilmstrip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/photofilmstrip')
-rw-r--r--media-video/photofilmstrip/Manifest1
-rw-r--r--media-video/photofilmstrip/files/photofilmstrip-1.9.91-PIL_modules_imports_fix.patch103
-rw-r--r--media-video/photofilmstrip/metadata.xml20
-rw-r--r--media-video/photofilmstrip/photofilmstrip-1.9.91-r1.ebuild53
4 files changed, 177 insertions, 0 deletions
diff --git a/media-video/photofilmstrip/Manifest b/media-video/photofilmstrip/Manifest
new file mode 100644
index 00000000000..5c6179a43a5
--- /dev/null
+++ b/media-video/photofilmstrip/Manifest
@@ -0,0 +1 @@
+DIST photofilmstrip-1.9.91.tar.gz 23599455 SHA256 0c5a7e571213892b736d56aefc24b18ae1c908aa29ece3080948651999cfb46e SHA512 de4718b1090cdee39cc20f9181ca7afffb291ae922385652f8657fdfc826176e7dbc357f4805ffb55cd814456399a326ee2bf3b669e342a9ea9aec0bd503ae81 WHIRLPOOL 8f39a69cf0450ce86a4af82eecac9fb9c46a83d99f6f1a094a8b6d30687ecac94e0ac027c78d372705987989bb51448972ebff982585876875297558161f4433
diff --git a/media-video/photofilmstrip/files/photofilmstrip-1.9.91-PIL_modules_imports_fix.patch b/media-video/photofilmstrip/files/photofilmstrip-1.9.91-PIL_modules_imports_fix.patch
new file mode 100644
index 00000000000..2d5bb479da8
--- /dev/null
+++ b/media-video/photofilmstrip/files/photofilmstrip-1.9.91-PIL_modules_imports_fix.patch
@@ -0,0 +1,103 @@
+--- photofilmstrip-1.9.91-orig/photofilmstrip/core/__init__.py 2012-01-13 15:26:36.000000000 +0200
++++ photofilmstrip-1.9.91/photofilmstrip/core/__init__.py 2013-06-10 20:43:27.759638837 +0300
+@@ -22,47 +22,47 @@
+ # WA: py2exe and PIL
+ import os
+ if os.name == "nt":
+- import Image
++ import PIL.Image as Image
+
+- import ArgImagePlugin
+- import BmpImagePlugin
+- import BufrStubImagePlugin
+- import CurImagePlugin
+- import DcxImagePlugin
+- import EpsImagePlugin
+- import FitsStubImagePlugin
+- import FliImagePlugin
+- import FpxImagePlugin
+- import GbrImagePlugin
+- import GifImagePlugin
+- import GribStubImagePlugin
+- import Hdf5StubImagePlugin
+- import IcnsImagePlugin
+- import IcoImagePlugin
+- import ImImagePlugin
+- import ImtImagePlugin
+- import IptcImagePlugin
+- import JpegImagePlugin
+- import McIdasImagePlugin
+- import MicImagePlugin
+- import MpegImagePlugin
+- import MspImagePlugin
+- import PalmImagePlugin
+- import PcdImagePlugin
+- import PcxImagePlugin
+- import PdfImagePlugin
+- import PixarImagePlugin
+- import PngImagePlugin
+- import PpmImagePlugin
+- import PsdImagePlugin
+- import SgiImagePlugin
+- import SpiderImagePlugin
+- import SunImagePlugin
+- import TgaImagePlugin
+- import TiffImagePlugin
+- import WmfImagePlugin
+- import XbmImagePlugin
+- import XpmImagePlugin
+- import XVThumbImagePlugin
++ import PIL.ArgImagePlugin as ArgImagePlugin
++ import PIL.BmpImagePlugin as BmpImagePlugin
++ import PIL.BufrStubImagePlugin as BufrStubImagePlugin
++ import PIL.CurImagePlugin as CurImagePlugin
++ import PIL.DcxImagePlugin as DcxImagePlugin
++ import PIL.EpsImagePlugin as EpsImagePlugin
++ import PIL.FitsStubImagePlugin as FitsStubImagePlugin
++ import PIL.FliImagePlugin as FliImagePlugin
++ import PIL.FpxImagePlugin as FpxImagePlugin
++ import PIL.GbrImagePlugin as GbrImagePlugin
++ import PIL.GifImagePlugin as GifImagePlugin
++ import PIL.GribStubImagePlugin as GribStubImagePlugin
++ import PIL.Hdf5StubImagePlugin as Hdf5StubImagePlugin
++ import PIL.IcnsImagePlugin as IcnsImagePlugin
++ import PIL.IcoImagePlugin as IcoImagePlugin
++ import PIL.ImImagePlugin as ImImagePlugin
++ import PIL.ImtImagePlugin as ImtImagePlugin
++ import PIL.IptcImagePlugin as IptcImagePlugin
++ import PIL.JpegImagePlugin as JpegImagePlugin
++ import PIL.McIdasImagePlugin as McIdasImagePlugin
++ import PIL.MicImagePlugin as MicImagePlugin
++ import PIL.MpegImagePlugin as MpegImagePlugin
++ import PIL.MspImagePlugin as MspImagePlugin
++ import PIL.PalmImagePlugin as PalmImagePlugin
++ import PIL.PcdImagePlugin as PcdImagePlugin
++ import PIL.PcxImagePlugin as PcxImagePlugin
++ import PIL.PdfImagePlugin as PdfImagePlugin
++ import PIL.PixarImagePlugin as PixarImagePlugin
++ import PIL.PngImagePlugin as PngImagePlugin
++ import PIL.PpmImagePlugin as PpmImagePlugin
++ import PIL.PsdImagePlugin as PsdImagePlugin
++ import PIL.SgiImagePlugin as SgiImagePlugin
++ import PIL.SpiderImagePlugin as SpiderImagePlugin
++ import PIL.SunImagePlugin as SunImagePlugin
++ import PIL.TgaImagePlugin as TgaImagePlugin
++ import PIL.TiffImagePlugin as TiffImagePlugin
++ import PIL.WmfImagePlugin as WmfImagePlugin
++ import PIL.XbmImagePlugin as XbmImagePlugin
++ import PIL.XpmImagePlugin as XpmImagePlugin
++ import PIL.XVThumbImagePlugin as XVThumbImagePlugin
+ Image._initialized=2
+ # WA: end
+--- photofilmstrip-1.9.91-orig/photofilmstrip/core/PILBackend.py 2012-01-13 15:26:36.000000000 +0200
++++ photofilmstrip-1.9.91/photofilmstrip/core/PILBackend.py 2013-06-10 20:36:00.427888547 +0300
+@@ -22,7 +22,8 @@
+ import logging
+ import cStringIO
+
+-import Image, ImageDraw
++import PIL.Image as Image
++import PIL.ImageDraw as ImageDraw
+
+ from photofilmstrip.core.Picture import Picture
+
diff --git a/media-video/photofilmstrip/metadata.xml b/media-video/photofilmstrip/metadata.xml
new file mode 100644
index 00000000000..9f19064500e
--- /dev/null
+++ b/media-video/photofilmstrip/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>phobosk@fastmail.fm</email>
+ <name>PhobosK</name>
+ </maintainer>
+ <longdescription>
+PhotoFilmStrip creates movies out of your pictures in just three steps.
+There are several output possibilities for VCD, SVCD, DVD up to FULL-HD.
+First select your photos, customize the motion path of the Ken Burns effect and
+render the video. Comments of the pictures are generated into a subtitle file.
+Furthermore an audio file can be specified to setup the background music for the
+slideshow.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">photostoryx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/photofilmstrip/photofilmstrip-1.9.91-r1.ebuild b/media-video/photofilmstrip/photofilmstrip-1.9.91-r1.ebuild
new file mode 100644
index 00000000000..efd1a226582
--- /dev/null
+++ b/media-video/photofilmstrip/photofilmstrip-1.9.91-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Movie slideshow creator using Ken Burns effect"
+HOMEPAGE="http://www.photofilmstrip.org"
+SRC_URI="mirror://sourceforge/photostoryx/${PN}/${PV}-unstable/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo sdl"
+
+RDEPEND="dev-python/wxpython:2.8[cairo?,${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ media-video/mplayer[encode]
+ sdl? ( dev-python/pygame[${PYTHON_USEDEP}] )"
+
+DEPEND="${RDEPEND}"
+
+# Fix bug #472774 (https://bugs.gentoo.org/show_bug.cgi?id=472774)
+PATCHES=(
+ "${FILESDIR}/${P}-PIL_modules_imports_fix.patch"
+)
+
+DOCS=( CHANGES COPYING README )
+
+src_prepare() {
+ # Remove unneeded icon resources update needing running X
+ sed -i \
+ -e '/self\._make_resources\(\)/d' \
+ setup.py
+
+ # Fix desktop file entry
+ sed -i \
+ -e '/^Version.*/d' \
+ data/photofilmstrip.desktop
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ # Do not compress the apps help files
+ docompress -x /usr/share/doc/${PN}
+
+ distutils-r1_src_install
+}