summaryrefslogtreecommitdiff
path: root/media-video/vmaid
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/vmaid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/vmaid')
-rw-r--r--media-video/vmaid/Manifest1
-rw-r--r--media-video/vmaid/metadata.xml11
-rw-r--r--media-video/vmaid/vmaid-2.2.4.ebuild36
3 files changed, 48 insertions, 0 deletions
diff --git a/media-video/vmaid/Manifest b/media-video/vmaid/Manifest
new file mode 100644
index 00000000000..82c1afa32d7
--- /dev/null
+++ b/media-video/vmaid/Manifest
@@ -0,0 +1 @@
+DIST vmaid-2.2.4.tar.gz 1249758 SHA256 675b653c223fc7f09b6ff91632e16340138737b1261081e45ae4f26a0943e5fa SHA512 16a92a2b35b91428a2f59f3c7c0223225107e2cfdc9c082edf7a730181ea79a60cc5bc8ed4d18d126513b43d06eda6be56a650fa165d1c5a9bc4675836f49adc WHIRLPOOL 4b8f9ded96b8907531b9b1b640b86041a55478f851727b77cf3cc45bcd1ab2c76d3174d3254e565a5d0d8f45d51e85a9bb352d9b4431c091ba35a6ce4cb8ba84
diff --git a/media-video/vmaid/metadata.xml b/media-video/vmaid/metadata.xml
new file mode 100644
index 00000000000..dec2925e35d
--- /dev/null
+++ b/media-video/vmaid/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Video maid is the AVI file editor which operates by GNU/Linux system or other UNIX compatible OS. AVI file IO is provided the edit environment with the original function which specialized in edit. Moreover, it has the intuitive user interface which can edit an image.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge-jp">vmaid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/vmaid/vmaid-2.2.4.ebuild b/media-video/vmaid/vmaid-2.2.4.ebuild
new file mode 100644
index 00000000000..dcf05f718b9
--- /dev/null
+++ b/media-video/vmaid/vmaid-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Video maid is the AVI file editor"
+HOMEPAGE="http://vmaid.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/vmaid/48081/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao mime"
+
+RDEPEND="x11-libs/gtk+:2
+ ao? ( media-libs/libao )
+ !ao? ( alsa? ( >=media-libs/alsa-lib-0.9 ) )
+ mime? ( x11-misc/shared-mime-info )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ app-text/scrollkeeper"
+
+src_configure() {
+ econf \
+ $(use_enable mime) \
+ --with-ao=$(usex ao) \
+ --with-alsa=$(usex alsa) \
+ --without-w32
+}
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README
+ dohtml -r doc/{en,ja}
+}