summaryrefslogtreecommitdiff
path: root/media-video
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-17 00:20:00 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-17 00:23:09 +0200
commit752d12e78f044091a47d2c75927d2e4f8644a5de (patch)
treeac4f3f0b63677c7da659a031f164d17ca5e48e94 /media-video
parent8b79d5fda5f56ef4d06107b877fb3292ad96e7ab (diff)
downloadgentoo-752d12e78f044091a47d2c75927d2e4f8644a5de.tar.gz
gentoo-752d12e78f044091a47d2c75927d2e4f8644a5de.tar.xz
media-video/subtitleeditor: fix build with USE=-nls
Gentoo-bug: 589180 Package-Manager: portage-2.3.1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.52.1-disable-nls-fix.patch34
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild6
2 files changed, 39 insertions, 1 deletions
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.52.1-disable-nls-fix.patch b/media-video/subtitleeditor/files/subtitleeditor-0.52.1-disable-nls-fix.patch
new file mode 100644
index 00000000000..08e1558e06b
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.52.1-disable-nls-fix.patch
@@ -0,0 +1,34 @@
+From 0f8700f022c9917336919b35a93883a660144516 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 17 Oct 2016 00:07:59 +0200
+Subject: [PATCH] Fix compilation with --disable-nls
+
+---
+ src/i18n.h | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/src/i18n.h b/src/i18n.h
+index c8134a7..efce469 100644
+--- a/src/i18n.h
++++ b/src/i18n.h
+@@ -31,6 +31,17 @@
+ #include <libintl.h>
+ #include <glib/gi18n.h>
+ #else /* NLS is disabled */
++ // In certain environments, some standard headers like <iomanip>
++ // and <locale> include libintl.h. If libintl.h is included after
++ // gettext macros below are defined, it causes a syntax error
++ // at the declaration of the gettext function in libintl.h.
++ //
++ // Fix this by including such a header before defining the macro.
++ //
++ // Note that libintl.h cannot be included directly since in the
++ // ENABLE_NLS=0 case it cannot be assumed that gettext is installed.
++ #include <locale>
++
+ #define _(String) (String)
+ #define N_(String) (String)
+ #define textdomain(String) (String)
+--
+2.10.0
+
diff --git a/media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild
index 2b1fe6305cb..ac84b65c886 100644
--- a/media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild
+++ b/media-video/subtitleeditor/subtitleeditor-0.53.0.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
media-libs/gstreamer:1.0
media-plugins/gst-plugins-meta:1.0
x11-libs/gtk+:3
- virtual/libintl
+ nls? ( virtual/libintl )
"
# opengl? (
# >=dev-cpp/gtkglextmm-1.2.0-r2:1.0
@@ -43,6 +43,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.52.1-disable-nls-fix.patch
+)
+
src_configure() {
# Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
use debug && append-cxxflags -DDEBUG