summaryrefslogtreecommitdiff
path: root/media-video
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-08-14 17:19:06 +0200
committerSebastian Pipping <sping@gentoo.org>2016-08-14 17:37:33 +0200
commitd846d6537ed310b0b5cc846229d3f5e6216551f1 (patch)
tree8716ff253a8b88c80f1115c5d334b22cc779ce42 /media-video
parent5923229d2c7b63be3ffbad51070c29499300b030 (diff)
downloadgentoo-d846d6537ed310b0b5cc846229d3f5e6216551f1.tar.gz
gentoo-d846d6537ed310b0b5cc846229d3f5e6216551f1.tar.xz
media-video/minitube: 2.5.2 (bug #567516)
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-video')
-rw-r--r--media-video/minitube/Manifest1
-rw-r--r--media-video/minitube/files/minitube-2.5.1-disable-updates.patch11
-rw-r--r--media-video/minitube/minitube-2.5.2.ebuild94
3 files changed, 106 insertions, 0 deletions
diff --git a/media-video/minitube/Manifest b/media-video/minitube/Manifest
index 1e3d357767d..8e5a6125832 100644
--- a/media-video/minitube/Manifest
+++ b/media-video/minitube/Manifest
@@ -1,2 +1,3 @@
DIST minitube-2.0.tar.gz 713577 SHA256 1ba1dd7725e6e0c92653fdee7bcfa4b833346d2ef4c091d94b181b60bb592554 SHA512 f08f49549486f22d6156aa4344fd0698e03b0fcf669530010a648467cd3da1edbe6ee9e7c7578c69c7f410a03afe2e5c25bb84e6e1dc70c6534210566789f81e WHIRLPOOL 415d5b17a0862aa74c09a4950be43cd78b5ab5f26c7d0bd5d4c4b78d97989b181ecdc86955f843348b52fc582346fbae32d664f43e5ba76fcc995a59c572776b
DIST minitube-2.4.tar.gz 984265 SHA256 1d8a427a4120d623c689969d92904bf66bf7d3edafcb0f6f9eb7f24d6db39c7b SHA512 45a90322540a281b337511af5e52a25bb5d908d3e37b6d7d4a068a2cb0d598095b6a312f862c7043851ceeda63c66944213646ba154ae505229da7fbe48251dc WHIRLPOOL 932ebcbf2397ceba78af6823f6eeb56edbf9b4c58dfd15218d10572d6a47110867b969b4711a1bcc0a00d3d47361ddec3c98fea7f69d5b56db40b842dba57b97
+DIST minitube-2.5.2.tar.gz 1063794 SHA256 63678bf153e77e8cdaf6b43bb9a7bf2c5694c62698c3236f1a1133494362d6b5 SHA512 4001ea95e6d3b541e9a8a2555830238f6e3a0b4749566dfd67ae48fdc6102ec77a38e162e04fb2637cc5ff2b3dccdca541119531302332ffa3b90d9db8809284 WHIRLPOOL affb33b2a2b1dea771452c33b4167e0e250a4f5869080b6c4426c372303d62e1f220f62fc64f0d087a75940869042712678a523224cf250247de2bbda46b4248
diff --git a/media-video/minitube/files/minitube-2.5.1-disable-updates.patch b/media-video/minitube/files/minitube-2.5.1-disable-updates.patch
new file mode 100644
index 00000000000..a5f496e92b2
--- /dev/null
+++ b/media-video/minitube/files/minitube-2.5.1-disable-updates.patch
@@ -0,0 +1,11 @@
+--- minitube-2.5.1.orig/src/mainwindow.cpp
++++ minitube-2.5.1/src/mainwindow.cpp
+@@ -232,8 +232,6 @@
+
+ ChannelAggregator::instance()->start();
+
+- checkForUpdate();
+-
+ initialized = true;
+ }
+
diff --git a/media-video/minitube/minitube-2.5.2.ebuild b/media-video/minitube/minitube-2.5.2.ebuild
new file mode 100644
index 00000000000..5bf146af005
--- /dev/null
+++ b/media-video/minitube/minitube-2.5.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="ar ca ca_ES da de_DE el en es es_AR es_ES fi fi_FI fr he_IL hr hu
+ia it jv nl pl pl_PL pt_BR ro ru sk sl tr zh_CN"
+PLOCALE_BACKUP="en"
+
+inherit l10n qmake-utils
+
+DESCRIPTION="Qt5 YouTube Client"
+HOMEPAGE="http://flavio.tordini.org/minitube"
+SRC_URI="https://github.com/flaviotordini/${PN}/archive/${PV}.tar.gz ->
+${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug download gstreamer"
+
+DEPEND="dev-qt/qtgui:5[accessibility]
+ dev-qt/qtdbus:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ media-libs/phonon[gstreamer?,qt5]
+ gstreamer? (
+ media-plugins/gst-plugins-soup:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ media-plugins/gst-plugins-faac:0.10
+ media-plugins/gst-plugins-faad:0.10
+ media-plugins/gst-plugins-theora
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS CHANGES TODO"
+
+#455976
+PATCHES=( "${FILESDIR}"/${PN}-2.5.1-disable-updates.patch )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ # Remove unneeded translations
+ local trans=
+ for x in $(l10n_get_locales); do
+ trans+="${x}.ts "
+ done
+ if [[ -n ${trans} ]]; then
+ sed -i -e "/^TRANSLATIONS/s/+=.*/+=${trans}/" locale/locale.pri || die
+ fi
+ sed -i \
+ 's|include(src/qtsingleapplication/qtsingleapplication.pri)|CONFIG += qtsingleapplication|g' \
+ ${PN}.pro || die "Failed to unbundle qtsingleapplication"
+
+ # Enable video downloads. Bug #491344
+ use download && { echo "DEFINES += APP_DOWNLOADS" >> ${PN}.pro; }
+ echo "DEFINES += APP_GOOGLE_API_KEY=${MINITUBE_GOOGLE_API_KEY}" >> ${PN}.pro
+
+ epatch_user
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ newicon images/app.png minitube.png
+}
+
+pkg_postinst() {
+ elog ""
+ elog "Since version 2.4, you need to generate a Google API Key to use"
+ elog "with this application. Please head over to"
+ elog "https://console.developers.google.com/ and"
+ elog "https://github.com/flaviotordini/minitube/blob/master/README.md"
+ elog "for more information. Once you have generated your key,"
+ elog "please put it in QSettings key \"googleApiKey\", e.g.:"
+ elog "# echo 'googleApiKey=YourKeyHere' >> \"\${HOME}/.config/Flavio Tordini/Minitube.conf\""
+ elog ""
+
+ if use download; then
+ elog "You activated the 'download' USE flag. This allows you to"
+ elog "download videos from youtube, which might violate the youtube"
+ elog "terms-of-service (TOS) in some legislations. If downloading"
+ elog "youtube-videos is not allowed in your legislation, please"
+ elog "disable the 'download' use flag. For details on the youtube TOS,"
+ elog "see http://www.youtube.com/t/terms"
+ fi
+}