summaryrefslogtreecommitdiff
path: root/net-analyzer/arpwatch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/arpwatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/arpwatch')
-rw-r--r--net-analyzer/arpwatch/Manifest3
-rw-r--r--net-analyzer/arpwatch/arpwatch-2.1.15-r6.ebuild57
-rw-r--r--net-analyzer/arpwatch/arpwatch-2.1.15-r7.ebuild63
-rw-r--r--net-analyzer/arpwatch/files/arpwatch.confd11
-rw-r--r--net-analyzer/arpwatch/files/arpwatch.initd37
-rw-r--r--net-analyzer/arpwatch/metadata.xml13
6 files changed, 184 insertions, 0 deletions
diff --git a/net-analyzer/arpwatch/Manifest b/net-analyzer/arpwatch/Manifest
new file mode 100644
index 00000000000..a71337996cf
--- /dev/null
+++ b/net-analyzer/arpwatch/Manifest
@@ -0,0 +1,3 @@
+DIST arpwatch-2.1a15.tar.gz 202729 SHA256 c1df9737e208a96a61fa92ddad83f4b4d9be66f8992f3c917e9edf4b05ff5898 SHA512 f770b5b7954afe910dafb016e6e886a4e785564bcdc0ea0de9d7b1ca6a9a0b219a9d1b50b6f42a67afc2f836e782e8ff85ba5780583015d62c9694ac53f0bf90 WHIRLPOOL e653eb83d8dbc8777c3aaa5920bc1e5b46c64aa740c64a79b24a42abdee4625baa72a51f9f0441549b7325fcb07b94f1964887df1b6d707eddde162e1073691f
+DIST arpwatch-patchset-0.5.tbz2 127740 SHA256 aa69513ba36cdb9f41862f5f9c47e47d60786d01d302a1e8177f9e1f8aae71d3 SHA512 cd1a71fc39489f3498b7614fa793226cb3dd23dbac88082baab5598d441cd585da2d2f2ee8d40183b810893f4cddd0282f5cc8aa8b6009c40bfbf2c295365dc3 WHIRLPOOL 736be0f0ea18ebd96136c5b629134b0920c3c1a648974eac7f86f57c5d5ee58c1cd284371685562a73468a79b29fc130a668bc9487e85175f61d7a3642f58db9
+DIST arpwatch-patchset-0.6.tbz2 128973 SHA256 2bfc7078fc4d5bad6bf7bd5d512df669799d09939ca249c2fe3f9fa3b8969ad8 SHA512 01c8b85e859765783a783c09ed9470b7f109b20f6713bb40ebcdc8e838ea00290df7609aa96ed1a6a2e39250e9735d6cfbd19e444961b79fdd1b04819c729253 WHIRLPOOL 96ae54f3cffe3f5eba8153ff79a6c66956ac95424dfae87e438372a4a27bf9d00136271f1e3c0e56850011cae873b2de57c6af7589fdd5a0253ef482328a602f
diff --git a/net-analyzer/arpwatch/arpwatch-2.1.15-r6.ebuild b/net-analyzer/arpwatch/arpwatch-2.1.15-r6.ebuild
new file mode 100644
index 00000000000..0c7cdcbefd8
--- /dev/null
+++ b/net-analyzer/arpwatch/arpwatch-2.1.15-r6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils user versionator
+
+PATCH_VER="0.5"
+
+MY_P="${PN}-$(replace_version_separator 2 'a')"
+DESCRIPTION="An ethernet monitor program that keeps track of ethernet/ip address pairings"
+HOMEPAGE="http://ee.lbl.gov/"
+SRC_URI="ftp://ftp.ee.lbl.gov/${MY_P}.tar.gz
+ mirror://gentoo/arpwatch-patchset-${PATCH_VER}.tbz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc sparc x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="net-libs/libpcap
+ sys-libs/ncurses"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-arpwatch )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_preinst() {
+ enewuser arpwatch
+}
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}"/arpwatch-patchset/ EPATCH_SUFFIX="patch" epatch
+ cp "${WORKDIR}"/arpwatch-patchset/*.8 . || die
+}
+
+src_install () {
+ dosbin arpwatch arpsnmp arp2ethers massagevendor arpfetch bihourly.sh
+ doman arpwatch.8 arpsnmp.8 arp2ethers.8 massagevendor.8 arpfetch.8 bihourly.8
+
+ insinto /usr/share/arpwatch
+ doins ethercodes.dat
+
+ insinto /usr/share/arpwatch/awk
+ doins duplicates.awk euppertolower.awk p.awk e.awk d.awk
+
+ keepdir /var/lib/arpwatch
+ dodoc README CHANGES
+
+ newinitd "${FILESDIR}"/arpwatch.initd arpwatch
+ newconfd "${FILESDIR}"/arpwatch.confd arpwatch
+}
+
+pkg_postinst() {
+ fowners arpwatch:0 "${ROOT}"/var/lib/arpwatch
+}
diff --git a/net-analyzer/arpwatch/arpwatch-2.1.15-r7.ebuild b/net-analyzer/arpwatch/arpwatch-2.1.15-r7.ebuild
new file mode 100644
index 00000000000..78774b9d627
--- /dev/null
+++ b/net-analyzer/arpwatch/arpwatch-2.1.15-r7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils user versionator
+
+PATCH_VER="0.6"
+
+MY_P="${PN}-$(replace_version_separator 2 'a')"
+DESCRIPTION="An ethernet monitor program that keeps track of ethernet/ip address pairings"
+HOMEPAGE="http://ee.lbl.gov/"
+SRC_URI="
+ ftp://ftp.ee.lbl.gov/${MY_P}.tar.gz
+ https://dev.gentoo.org/~jer/arpwatch-patchset-${PATCH_VER}.tbz2
+"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-arpwatch )
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_preinst() {
+ enewuser arpwatch
+}
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}"/arpwatch-patchset/ EPATCH_SUFFIX="patch" epatch
+ cp "${WORKDIR}"/arpwatch-patchset/*.8 . || die
+}
+
+src_install () {
+ dosbin arpwatch arpsnmp arp2ethers massagevendor arpfetch bihourly.sh
+ doman arpwatch.8 arpsnmp.8 arp2ethers.8 massagevendor.8 arpfetch.8 bihourly.8
+
+ insinto /usr/share/arpwatch
+ doins ethercodes.dat
+
+ insinto /usr/share/arpwatch/awk
+ doins duplicates.awk euppertolower.awk p.awk e.awk d.awk
+
+ keepdir /var/lib/arpwatch
+ dodoc README CHANGES
+
+ newinitd "${FILESDIR}"/arpwatch.initd arpwatch
+ newconfd "${FILESDIR}"/arpwatch.confd arpwatch
+}
+
+pkg_postinst() {
+ fowners arpwatch:0 "${ROOT}"/var/lib/arpwatch
+}
diff --git a/net-analyzer/arpwatch/files/arpwatch.confd b/net-analyzer/arpwatch/files/arpwatch.confd
new file mode 100644
index 00000000000..98abe041774
--- /dev/null
+++ b/net-analyzer/arpwatch/files/arpwatch.confd
@@ -0,0 +1,11 @@
+# Config file for /etc/init.d/arpwatch
+# see arpwatch.8 for more information
+
+#IFACES="eth0 eth1"
+IFACES="eth0"
+
+# Additional options to pass to arpwatch.
+OPTIONS="-N -p"
+
+# Comment this line if you wish arpwatch to run as root user (not recommended)
+ARPUSER="arpwatch"
diff --git a/net-analyzer/arpwatch/files/arpwatch.initd b/net-analyzer/arpwatch/files/arpwatch.initd
new file mode 100644
index 00000000000..0a517e00c66
--- /dev/null
+++ b/net-analyzer/arpwatch/files/arpwatch.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ for IFACE in ${IFACES}
+ do
+ ebegin "Starting arpwatch on ${IFACE}"
+ DATAFILE=/var/lib/arpwatch/${IFACE}.dat
+ [ ! -f ${DATAFILE} ] && touch ${DATAFILE}
+
+ if [ -z ${ARPUSER} ]; then
+ start-stop-daemon --start --quiet --pidfile=/var/run/arpwatch.${IFACE}.pid --exec \
+ /usr/sbin/arpwatch -- -i ${IFACE} -f ${DATAFILE} -P /var/run/arpwatch.${IFACE}.pid ${OPTIONS}
+ else
+ chown ${ARPUSER} ${DATAFILE}
+ start-stop-daemon --start --quiet --pidfile=/var/run/arpwatch.${IFACE}.pid --exec \
+ /usr/sbin/arpwatch -- -i $IFACE -u ${ARPUSER} -f ${DATAFILE} -P /var/run/arpwatch.${IFACE}.pid ${OPTIONS}
+ fi
+ eend $?
+ done
+}
+
+stop() {
+ for IFACE in ${IFACES}
+ do
+ ebegin "Stopping arpwatch on ${IFACE}"
+ start-stop-daemon --stop --quiet --pidfile=/var/run/arpwatch.${IFACE}.pid --exec \
+ /usr/sbin/arpwatch
+ eend $?
+ done
+}
diff --git a/net-analyzer/arpwatch/metadata.xml b/net-analyzer/arpwatch/metadata.xml
new file mode 100644
index 00000000000..4fc697499bf
--- /dev/null
+++ b/net-analyzer/arpwatch/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+ <longdescription lang="en">
+ The arpwatch package contains arpwatch and arpsnmp. Arpwatch and arpsnmp
+ are both network monitoring tools. Both utilities monitor Ethernet or
+ FDDI network traffic and build databases of Ethernet/IP address pairs,
+ and can report certain changes via email. Install the arpwatch package
+ if you need networking monitoring devices which will automatically keep
+ track of the IP addresses on your network.
+ </longdescription>
+</pkgmetadata>