summaryrefslogtreecommitdiff
path: root/net-analyzer/check_mk/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/check_mk/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/check_mk/files')
-rw-r--r--net-analyzer/check_mk/files/check_mk-1.2.4p3-setup.sh.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/check_mk/files/check_mk-1.2.4p3-setup.sh.patch b/net-analyzer/check_mk/files/check_mk-1.2.4p3-setup.sh.patch
new file mode 100644
index 00000000000..e9a5080e4cf
--- /dev/null
+++ b/net-analyzer/check_mk/files/check_mk-1.2.4p3-setup.sh.patch
@@ -0,0 +1,36 @@
+--- check_mk-1.2.4p3.orig/setup.sh 2014-06-21 11:15:58.090225173 +0200
++++ check_mk-1.2.4p3/setup.sh 2014-06-22 09:57:51.658670398 +0200
+@@ -572,6 +572,11 @@
+ CONFIGURE_OPTS="--with-nagios4"
+ fi
+ fi
++ # disable stripping to get meaningful backtraces
++ sed -i -e 's/^INSTALL_STRIP_PROGRAM="\\\$(install_sh) -c -s"$/INSTALL_STRIP_PROGRAM="\\\$(install_sh) -c"/' configure
++ sed -i -e 's/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \\$/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" \\/' Makefile.in
++ sed -i -e 's/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \\$/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" \\/' src/Makefile.in
++ sed -i -e 's/\$(CXX) \$(LDFLAGS) -s -fPIC -shared \$(livestatus_so_OBJECTS) -o \$@ -lpthread -lstdc++/\$(CXX) \$(LDFLAGS) -fPIC -shared \$(livestatus_so_OBJECTS) -o \$@ -lpthread -lstdc++/' src/Makefile.in
+ ./configure --libdir=$libdir --bindir=$bindir $CONFIGURE_OPTS &&
+ make clean &&
+ cat <<EOF > src/livestatus.h &&
+@@ -581,7 +586,8 @@
+ #endif // livestatus_h
+ EOF
+ make -j 8 2>&1 &&
+- strip src/livestatus.o &&
++ # disable stripping to get meaningful backtraces
++ #strip src/livestatus.o &&
+ mkdir -p $DESTDIR$libdir &&
+ install -m 755 src/livestatus.o $DESTDIR$libdir &&
+ mkdir -p $DESTDIR$bindir &&
+@@ -1018,8 +1024,9 @@
+ # WATO. Also create an empty and Apache-writable auth.serials
+ serials_file=$DESTDIR${htpasswd_file%/*}/auth.serials &&
+ touch "$serials_file" &&
+- (chown $wwwuser "$serials_file" || true) &&
+- (chown $wwwuser "$htpasswd_file" || true) &&
++ # Permissions will be set within src_install
++ #(chown $wwwuser "$serials_file" || true) &&
++ #(chown $wwwuser "$htpasswd_file" || true) &&
+ create_sudo_configuration &&
+ if [ "$enable_mkeventd" = yes ]
+ then