summaryrefslogtreecommitdiff
path: root/net-analyzer/check_mk/files
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-12-23 16:16:24 +0800
committerIan Delaney <idella4@gentoo.org>2015-12-23 16:19:41 +0800
commit8e15250236cd6867b631ee982aa82bab51153800 (patch)
tree757db8f0dcd5150cbabad7d1821cfedc23dda62a /net-analyzer/check_mk/files
parentc66398f69df04dc763588f5ac5202ffea515542c (diff)
downloadgentoo-8e15250236cd6867b631ee982aa82bab51153800.tar.gz
gentoo-8e15250236cd6867b631ee982aa82bab51153800.tar.xz
net-analyzer/check_mk: revbump to vn. 1.2.4_p5-r1
tidy positioning of various vars, switched to inherit of python-r1 eclass, update install phase re the creation of users and or groups, add patch to address sudoers actions in setup.sh, thx to OP (S. Nikitin) for submitting patch disabling writing to sudoers in setup.sh, other patches and fixes supplied by proxy maintainer via the gentoo bug, fixes the bug. Gentoo bug: #5583721 Package-Manager: portage-2.2.24
Diffstat (limited to 'net-analyzer/check_mk/files')
-rw-r--r--net-analyzer/check_mk/files/check_mk-1.2.4p5-setup.sh.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/check_mk/files/check_mk-1.2.4p5-setup.sh.patch b/net-analyzer/check_mk/files/check_mk-1.2.4p5-setup.sh.patch
new file mode 100644
index 00000000000..07dffa35b2d
--- /dev/null
+++ b/net-analyzer/check_mk/files/check_mk-1.2.4p5-setup.sh.patch
@@ -0,0 +1,39 @@
+--- check_mk-1.2.4p5.orig/setup.sh 2014-07-04 09:24:45.000000000 +0200
++++ check_mk-1.2.4p5/setup.sh 2015-08-28 13:22:19.986733809 +0200
+@@ -572,6 +572,11 @@
+ CONFIGURE_OPTS="--with-nagios4"
+ fi
+ fi
++ # disable stripping to get meaningful backtraces
++ sed -i -e 's/^INSTALL_STRIP_PROGRAM="\\\$(install_sh) -c -s"$/INSTALL_STRIP_PROGRAM="\\\$(install_sh) -c"/' configure
++ sed -i -e 's/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \\$/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" \\/' Makefile.in
++ sed -i -e 's/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \\$/install_sh_PROGRAM="\$(INSTALL_STRIP_PROGRAM)" \\/' src/Makefile.in
++ sed -i -e 's/\$(CXX) \$(LDFLAGS) -s -fPIC -shared \$(livestatus_so_OBJECTS) -o \$@ -lpthread -lstdc++/\$(CXX) \$(LDFLAGS) -fPIC -shared \$(livestatus_so_OBJECTS) -o \$@ -lpthread -lstdc++/' src/Makefile.in
+ ./configure --libdir=$libdir --bindir=$bindir $CONFIGURE_OPTS &&
+ make clean &&
+ cat <<EOF > src/livestatus.h &&
+@@ -581,7 +586,8 @@
+ #endif // livestatus_h
+ EOF
+ make -j 8 2>&1 &&
+- strip src/livestatus.o &&
++ # disable stripping to get meaningful backtraces
++ #strip src/livestatus.o &&
+ mkdir -p $DESTDIR$libdir &&
+ install -m 755 src/livestatus.o $DESTDIR$libdir &&
+ mkdir -p $DESTDIR$bindir &&
+@@ -1018,9 +1024,11 @@
+ # WATO. Also create an empty and Apache-writable auth.serials
+ serials_file=$DESTDIR${htpasswd_file%/*}/auth.serials &&
+ touch "$serials_file" &&
+- (chown $wwwuser "$serials_file" || true) &&
+- (chown $wwwuser "$htpasswd_file" || true) &&
+- create_sudo_configuration &&
++ # Permissions will be set within src_install
++ #(chown $wwwuser "$serials_file" || true) &&
++ #(chown $wwwuser "$htpasswd_file" || true) &&
++ # disable sudo configuration as this will be done within src_install
++ #create_sudo_configuration &&
+ if [ "$enable_mkeventd" = yes ]
+ then
+ if [ -z "$YES" ] ; then echo -n "(Compiling Event Console binaries..." ; fi