summaryrefslogtreecommitdiff
path: root/net-analyzer/ipband
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ipband
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ipband')
-rw-r--r--net-analyzer/ipband/Manifest1
-rw-r--r--net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch20
-rw-r--r--net-analyzer/ipband/files/ipband-0.8.1-postfix.patch13
-rw-r--r--net-analyzer/ipband/files/ipband-init25
-rw-r--r--net-analyzer/ipband/ipband-0.8.1-r1.ebuild37
-rw-r--r--net-analyzer/ipband/metadata.xml5
6 files changed, 101 insertions, 0 deletions
diff --git a/net-analyzer/ipband/Manifest b/net-analyzer/ipband/Manifest
new file mode 100644
index 00000000000..1245a5e5f3f
--- /dev/null
+++ b/net-analyzer/ipband/Manifest
@@ -0,0 +1 @@
+DIST ipband-0.8.1.tgz 36675 SHA256 f0a5860647d5364df812f7660d28f1ee8fbd35eb27088ab0cd445963db5806ad SHA512 66347652fee7c7426620260ae615de2f4cfeedacac21d606643e4ae8da204cc81780bfd3f4062a16a9172a78a4a7799fc97e0141750ed26b0e21c8ac2eab3c4f WHIRLPOOL 85239172494d3210bf690c3fbef9b2f867661e75f727cd4804c3c3ea1a6b3ea52fac6194e45c7f5a0c7ec0fe2011cfbeeb2f0293f47228c678707a3c5d971527
diff --git a/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch b/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch
new file mode 100644
index 00000000000..e3929da8cfb
--- /dev/null
+++ b/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,6 @@
+ CPPFLAGS=-I/usr/include/pcap
+ LIBS=-lpcap
+ CFLAGS := -Wall $(CFLAGS)
+-CC=gcc
+
+ ifndef PREFIX
+ PREFIX=/usr
+@@ -49,8 +48,7 @@
+ all: $(BIN)
+
+ $(BIN): $(OBJ_C)
+- $(CC) -o $(BIN) $(OBJ_C) $(LIBS) $(CFLAGS)
+- strip $(BIN)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ_C) $(LIBS)
+
+ install-strip: install
+
diff --git a/net-analyzer/ipband/files/ipband-0.8.1-postfix.patch b/net-analyzer/ipband/files/ipband-0.8.1-postfix.patch
new file mode 100644
index 00000000000..9db8313afb3
--- /dev/null
+++ b/net-analyzer/ipband/files/ipband-0.8.1-postfix.patch
@@ -0,0 +1,13 @@
+--- a/ipband.sample.conf
++++ b/ipband.sample.conf
+@@ -61,7 +61,10 @@
+ # MTA string. Default is "/usr/sbin/sendmail -t -ba". Change it to
+ # whatever runs MTA of your choice. Note that the stringis tokenized and
+ # passed to exec(), so that shell's metacharacters are not interpreted.
++# Sendmail
+ #mtastring "/usr/sbin/sendmail -t -ba"
++# Postfix
++#mtastring "/usr/sbin/sendmail -t"
+
+ # Default number of subnet mask bits.
+ #maskbits 24
diff --git a/net-analyzer/ipband/files/ipband-init b/net-analyzer/ipband/files/ipband-init
new file mode 100644
index 00000000000..edfef8a1105
--- /dev/null
+++ b/net-analyzer/ipband/files/ipband-init
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ipband"
+ start-stop-daemon --start --exec /usr/bin/ipband -- -F > /dev/null
+ if [ $? -ne 0 ]; then
+ ewarn "Check settings in /etc/ipband.conf"
+ eend 1
+ else
+ eend 0
+ fi
+}
+
+stop() {
+ ebegin "Stopping ipband"
+ start-stop-daemon --stop --exec /usr/bin/ipband
+ eend $?
+}
diff --git a/net-analyzer/ipband/ipband-0.8.1-r1.ebuild b/net-analyzer/ipband/ipband-0.8.1-r1.ebuild
new file mode 100644
index 00000000000..b795b2d0778
--- /dev/null
+++ b/net-analyzer/ipband/ipband-0.8.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A pcap based IP traffic and bandwidth monitor with configurable reporting and alarm abilities"
+HOMEPAGE="http://ipband.sourceforge.net/"
+SRC_URI="http://ipband.sourceforge.net/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+DEPEND=">=net-libs/libpcap-0.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-postfix.patch
+
+ tc-export CC
+}
+
+src_install() {
+ dobin ipband
+ doman ipband.8
+ dodoc CHANGELOG README
+
+ newinitd "${FILESDIR}"/ipband-init ipband
+
+ insinto /etc/
+ newins ipband.sample.conf ipband.conf
+}
diff --git a/net-analyzer/ipband/metadata.xml b/net-analyzer/ipband/metadata.xml
new file mode 100644
index 00000000000..03aa50bab7e
--- /dev/null
+++ b/net-analyzer/ipband/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>