summaryrefslogtreecommitdiff
path: root/net-analyzer/libnasl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/libnasl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/libnasl')
-rw-r--r--net-analyzer/libnasl/Manifest1
-rw-r--r--net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch29
-rw-r--r--net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch29
-rw-r--r--net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch45
-rw-r--r--net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild55
-rw-r--r--net-analyzer/libnasl/metadata.xml5
6 files changed, 164 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/Manifest b/net-analyzer/libnasl/Manifest
new file mode 100644
index 00000000000..b59e7b91358
--- /dev/null
+++ b/net-analyzer/libnasl/Manifest
@@ -0,0 +1 @@
+DIST libnasl-2.2.9.tar.gz 366960 SHA256 2d9cebfe69e40963d790295993e096697a0bed37774b66ee8b14e48c2231fa93 SHA512 74a637d39f0d61c9e0f692d3a6754000ef635690a61b05c88608fd5bbee438ce720597babe25af80bccd4fca52f22531b3fc913820a13147c179f8a16c034e03 WHIRLPOOL 3d02768d18451c0a648f56bb55a118587c77598c1cefb1fba4db538b9266016f76710038e714813bfbce392a3054115a2345413269cbb58246519baee9338f83
diff --git a/net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch b/net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch
new file mode 100644
index 00000000000..91f91fa38e0
--- /dev/null
+++ b/net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch
@@ -0,0 +1,29 @@
+--- a/nasl/nasl_grammar.y
++++ b/nasl/nasl_grammar.y
+@@ -1,4 +1,6 @@
+-%pure_parser
++%pure-parser
++%parse-param {naslctxt * parm}
++%lex-param {naslctxt * parm}
+ %expect 1
+ %{
+ /* Nessus Attack Scripting Language version 2
+@@ -31,7 +33,7 @@
+ #include "nasl_lex_ctxt.h"
+ #include "nasl_debug.h"
+
+-static void naslerror(const char *);
++static void naslerror(naslctxt *, const char *);
+ #define YYERROR_VERBOSE
+ %}
+
+@@ -465,8 +467,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
+-static void
+-naslerror(const char *s)
++static void naslerror(naslctxt *parm, const char *s)
+ {
+ fputs(s, stderr);
+ }
diff --git a/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch b/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
new file mode 100644
index 00000000000..c82f76d6001
--- /dev/null
+++ b/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
@@ -0,0 +1,29 @@
+index 860653d..82bdf2f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ include nasl.tmpl
+
+ all:
+- cd nasl && ${MAKE}
++ ${MAKE} -C nasl
+
+ nasl.tmpl: nasl.tmpl.in configure
+ $(SHELL) configure $(CONFIGURE_ARGS)
+--- a/nasl/Makefile
++++ b/nasl/Makefile
+@@ -97,11 +97,11 @@ cflags :
+ @echo "echo \"$(NESSUS_CFLAGS) $(include) $(DEFS) \"" > cflags
+ @chmod +x cflags
+
+-nasl : cflags $(OBJS) nasl.c
+- $(CC) $(CFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
++nasl : cflags $(OBJS) nasl.c libnasl.la
++ $(CC) $(CFLAGS) $(LDFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
+
+ libnasl.la : cflags $(OBJS)
+- $(COMPILE) $(NESSUS_LIBS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
++ $(COMPILE) $(NESSUS_LIBS) $(LDFLAGS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ install : libnasl.la nasl
diff --git a/net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch b/net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch
new file mode 100644
index 00000000000..fc3b38be4c2
--- /dev/null
+++ b/net-analyzer/libnasl/files/libnasl-2.2.9-openssl-1.patch
@@ -0,0 +1,45 @@
+http://bugs.gentoo.org/326545
+
+--- a/nasl/nasl_crypto.c
++++ b/nasl/nasl_crypto.c
+@@ -22,7 +22,9 @@
+ */
+ #include <includes.h>
+ #ifdef HAVE_SSL
++#ifdef HAVE_OPENSSL_MD2_H
+ #include <openssl/md2.h>
++#endif
+ #include <openssl/md4.h>
+ #include <openssl/md5.h>
+ #include <openssl/ripemd.h>
+@@ -45,6 +47,7 @@
+
+
+ /*-------------------[ Std. HASH ]-------------------------------------*/
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_md2(lex_ctxt * lexic)
+ {
+ char * data = get_str_var_by_num(lexic, 0);
+@@ -63,6 +66,7 @@
+ retc->size = MD2_DIGEST_LENGTH;
+ return retc;
+ }
++#endif
+
+ tree_cell * nasl_md4(lex_ctxt * lexic)
+ {
+@@ -192,12 +196,12 @@
+ return retc;
+ }
+
+-
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_hmac_md2(lex_ctxt * lexic)
+ {
+ return nasl_hmac(lexic, EVP_md2());
+ }
+-
++#endif
+
+ tree_cell * nasl_hmac_md5(lex_ctxt * lexic)
+ {
diff --git a/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild b/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild
new file mode 100644
index 00000000000..6f6f00f9ad5
--- /dev/null
+++ b/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (libnasl)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ ~net-analyzer/nessus-libraries-${PV}
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-openssl-1.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-bison3.patch
+
+ sed \
+ -e "/^LDFLAGS/s:$:${LDFLAGS}:g" \
+ -i nasl.tmpl.in || die
+
+ tc-export CC
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-shared
+}
+
+src_compile() {
+ # emake fails for >= -j2. bug #16471.
+ emake -C nasl cflags
+ emake
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/net-analyzer/libnasl/metadata.xml b/net-analyzer/libnasl/metadata.xml
new file mode 100644
index 00000000000..03aa50bab7e
--- /dev/null
+++ b/net-analyzer/libnasl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>