summaryrefslogtreecommitdiff
path: root/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild')
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild126
1 files changed, 126 insertions, 0 deletions
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild
new file mode 100644
index 00000000000..6e506632c96
--- /dev/null
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+PERL_EXPORT_PHASE_FUNCTIONS=no
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools perl-module python-r1 eutils
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Nagios/Icinga event broker module that allows quick/direct access to your status data"
+HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
+SRC_URI="http://mathias-kettner.de/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples perl python test"
+
+RDEPEND="perl? (
+ dev-lang/perl:0
+ virtual/perl-Digest-MD5:0
+ virtual/perl-Scalar-List-Utils:0
+ >=virtual/perl-Thread-Queue-2.11:0
+ virtual/perl-Encode:0
+ dev-perl/JSON-XS:0
+ )"
+DEPEND="${RDEPEND}
+ perl? (
+ dev-perl/Module-Install:0
+ virtual/perl-ExtUtils-MakeMaker:0
+ virtual/perl-File-Path:0
+ virtual/perl-File-Spec:0
+ virtual/perl-File-Temp:0
+ test? (
+ dev-perl/File-Copy-Recursive:0
+ dev-perl/Test-Pod:0
+ dev-perl/Test-Perl-Critic:0
+ dev-perl/Test-Pod-Coverage:0
+ dev-perl/Perl-Critic:0
+ dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect:0
+ dev-perl/Perl-Critic-Deprecated:0
+ dev-perl/Perl-Critic-Nits:0
+ )
+ )"
+
+# For perl test
+SRC_TEST="parallel"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Use system Module::Install instead, it will be copied to $S by
+ # Module::install itself.
+ rm -rf api/perl/inc
+
+ if use perl; then
+ perl-module_src_prepare
+ fi
+
+ epatch "${FILESDIR}/${P}-no-strip.diff"
+ epatch "${FILESDIR}/${P}-test-RequireRcsKeywords.diff"
+
+ # Script too old
+ rm -f missing
+
+ eautoreconf
+}
+
+src_configure() {
+ econf
+
+ if use perl; then
+ cd api/perl/
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ emake
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ if use perl; then
+ cd api/perl
+
+ export TEST_AUTHOR="Test Author"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ emake -C src/ DESTDIR="${ED}" install-binPROGRAMS install-data-local
+
+ if use perl; then
+ cd api/perl
+ perl-module_src_install
+ cd "${S}"
+
+ if use examples; then
+ docinto examples/
+ dodoc api/perl/examples/dump.pl
+ fi
+ fi
+
+ if use python; then
+ python_foreach_impl python_domodule api/python/livestatus.py
+
+ if use examples; then
+ newdoc api/python/README README.python
+
+ docinto examples/
+ dodoc api/python/{example,example_multisite,make_nagvis_map}.py
+ fi
+ fi
+}