summaryrefslogtreecommitdiff
path: root/net-analyzer/mtr/mtr-0.87.ebuild
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-08-04 12:06:28 +0200
committerJeroen Roovers <jer@gentoo.org>2016-08-04 12:06:28 +0200
commit32642c702134d7d7074caa1a913a1a6a7971d385 (patch)
treee0244a6139864bcafb72ad54e43225ed1b2eee06 /net-analyzer/mtr/mtr-0.87.ebuild
parent27acaeb85113cf550a47294ddddb9ca6521523b3 (diff)
downloadgentoo-32642c702134d7d7074caa1a913a1a6a7971d385.tar.gz
gentoo-32642c702134d7d7074caa1a913a1a6a7971d385.tar.xz
net-analyzer/mtr: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-analyzer/mtr/mtr-0.87.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-0.87.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/mtr/mtr-0.87.ebuild b/net-analyzer/mtr/mtr-0.87.ebuild
new file mode 100644
index 00000000000..afac24180f5
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.87.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils fcaps flag-o-matic
+
+DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="gtk ipv6"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/autoconf
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
+FILECAPS=( cap_net_raw /usr/sbin/mtr )
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # In the source's configure script -lresolv is commented out. Apparently it
+ # is needed for 64bit macos still.
+ [[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with gtk) \
+ --disable-gtktest
+}