summaryrefslogtreecommitdiff
path: root/net-analyzer/mtr
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/mtr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/mtr')
-rw-r--r--net-analyzer/mtr/Manifest2
-rw-r--r--net-analyzer/mtr/files/0.80-impl-dec.patch12
-rw-r--r--net-analyzer/mtr/files/0.85-gtk.patch40
-rw-r--r--net-analyzer/mtr/metadata.xml5
-rw-r--r--net-analyzer/mtr/mtr-0.86.ebuild42
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild59
6 files changed, 160 insertions, 0 deletions
diff --git a/net-analyzer/mtr/Manifest b/net-analyzer/mtr/Manifest
new file mode 100644
index 00000000000..0ae35c92dcd
--- /dev/null
+++ b/net-analyzer/mtr/Manifest
@@ -0,0 +1,2 @@
+DIST gtk-2.0-for-mtr.m4.bz2 2508 SHA256 59152f9a4a1af5cf09f2aaa804c9071afe3eb6632162f1660d85c820db342eba SHA512 0f593b761d7a9399469f1f7bb3992133b391a2ce760ecfad96237561992802c192b810f4722763685d5f6e7a76bd2806abf08e1850bdce00e5cd3af4c810210f WHIRLPOOL 8bfa2cd70c2aba06473692cdf3e091a983aab69cdb5be3d0382b6b87c05bcc577ecb1afab26afc17ee16d07a1161fe84f17e3cc9ae0a150364f34667cfba5779
+DIST mtr-0.86.tar.gz 185374 SHA256 c5d948920b641cc35f8b380fc356ddfe07cce6a9c6474afe242fc58113f28c06 SHA512 e649825ab77987e369e0cd353a502b31f4aafa54a934467db907cb171af45b11bd0a8725d567d923422f32b886ad272b42151514c71893f0ba947f8d18719583 WHIRLPOOL bcf736514a48d6db24d1abf5c8d8b6c792fa8726b646d88d2810bf5f1ed237439a49dd4365f88cee1a9ebe3956cd2f30020abcc7a0d0b368161e0f1053dab290
diff --git a/net-analyzer/mtr/files/0.80-impl-dec.patch b/net-analyzer/mtr/files/0.80-impl-dec.patch
new file mode 100644
index 00000000000..5b41a54c744
--- /dev/null
+++ b/net-analyzer/mtr/files/0.80-impl-dec.patch
@@ -0,0 +1,12 @@
+diff --git a/gtk.c b/gtk.c
+index e42f4f6..333d7c8 100644
+--- a/gtk.c
++++ b/gtk.c
+@@ -24,6 +24,7 @@
+ #include <unistd.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
++#include <string.h>
+
+ #ifndef NO_GTK
+ #include <stdio.h>
diff --git a/net-analyzer/mtr/files/0.85-gtk.patch b/net-analyzer/mtr/files/0.85-gtk.patch
new file mode 100644
index 00000000000..f04d2419bed
--- /dev/null
+++ b/net-analyzer/mtr/files/0.85-gtk.patch
@@ -0,0 +1,40 @@
+--- a/display.c
++++ b/display.c
+@@ -45,7 +45,7 @@
+ #include "mtr-curses.h"
+ #endif
+
+-#ifdef NO_GTK
++#if (NO_GTK == 1)
+ #define gtk_open()
+ #define gtk_close()
+ #define gtk_redraw()
+@@ -71,7 +71,7 @@
+ DisplayMode = DisplayCurses;
+ #endif
+
+-#ifndef NO_GTK
++#if (NO_GTK == 0)
+ if(gtk_detect(argc, argv)) {
+ DisplayMode = DisplayGTK;
+ }
+--- a/gtk.c
++++ b/gtk.c
+@@ -26,7 +26,7 @@
+ #include <sys/types.h>
+ #include <string.h>
+
+-#ifndef NO_GTK
++#if (NO_GTK == 0)
+ #include <string.h>
+ #include <sys/types.h>
+ #include <gtk/gtk.h>
+@@ -38,7 +38,7 @@
+ #include "version.h"
+
+ #include "img/mtr_icon.xpm"
+-#endif
++#endif /* NO_GTK == 0 */
+
+ gint gtk_ping(gpointer data);
+ gint Copy_activate(GtkWidget *widget, gpointer data);
diff --git a/net-analyzer/mtr/metadata.xml b/net-analyzer/mtr/metadata.xml
new file mode 100644
index 00000000000..03aa50bab7e
--- /dev/null
+++ b/net-analyzer/mtr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/mtr/mtr-0.86.ebuild b/net-analyzer/mtr/mtr-0.86.ebuild
new file mode 100644
index 00000000000..46ed0089546
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.86.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fcaps flag-o-matic
+
+DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="gtk ipv6"
+
+RDEPEND="
+ sys-libs/ncurses
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/autoconf
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
+FILECAPS=( cap_net_raw /usr/sbin/mtr )
+
+src_configure() {
+ # In the source's configure script -lresolv is commented out. Apparently it
+ # is needed for 64bit macos still.
+ [[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with gtk) \
+ --disable-gtktest
+}
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
new file mode 100644
index 00000000000..346422db9f6
--- /dev/null
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools fcaps flag-o-matic git-r3
+
+DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+EGIT_REPO_URI="https://github.com/traviscross/mtr.git"
+SRC_URI="mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="gtk ipv6"
+
+RDEPEND="
+ sys-libs/ncurses
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/autoconf
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
+FILECAPS=( cap_net_raw /usr/sbin/mtr )
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack ${A}
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/0.80-impl-dec.patch \
+ "${FILESDIR}"/0.85-gtk.patch
+
+ sed -i -e "/^\s*xver=/s|$.*)|${EGIT_VERSION:0:8}|" Makefile.am || die
+
+ # Keep this comment and following mv, even in case ebuild does not need
+ # it: kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
+ mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 || die #222909
+ AT_M4DIR="." eautoreconf
+}
+
+src_configure() {
+ # In the source's configure script -lresolv is commented out. Apparently it
+ # is needed for 64bit macos still.
+ [[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
+ econf \
+ $(use_enable ipv6) \
+ $(use_with gtk)
+}