summaryrefslogtreecommitdiff
path: root/net-analyzer/nethogs
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-01-15 07:17:33 +0100
committerJeroen Roovers <jer@gentoo.org>2016-01-15 07:18:02 +0100
commitbf89fcb0e0f25ddc32053e9eb016f76e5d5164d3 (patch)
tree2fd9f04798b6406f8bde7fc0f83b929c26e862cb /net-analyzer/nethogs
parent4669af6e6dfd900ce748957fa7a0e0d0b5572e34 (diff)
downloadgentoo-bf89fcb0e0f25ddc32053e9eb016f76e5d5164d3.tar.gz
gentoo-bf89fcb0e0f25ddc32053e9eb016f76e5d5164d3.tar.xz
net-analyzer/nethogs: Version bump (bug #571876 by poncho).
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-analyzer/nethogs')
-rw-r--r--net-analyzer/nethogs/Manifest1
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/Manifest b/net-analyzer/nethogs/Manifest
index 27b656dec1a..974556c4bc5 100644
--- a/net-analyzer/nethogs/Manifest
+++ b/net-analyzer/nethogs/Manifest
@@ -1 +1,2 @@
DIST nethogs-0.8.0.tar.gz 38036 SHA256 b09cb3c2690a522f8b1314221095d5abb1958d50b56de6d36b11a8e6f28961d0 SHA512 6530c1bdbdf1ace7368941e8e0e53a83ac808bbea7a952936fa570ad2d49e8b4cef6a37d433f1873655edfd63cce556146a48ff81665905827237edf50419446 WHIRLPOOL 1b7c7456e2c55df0be188a0858ee039f7fde52ae58554ca16f7b92f732735ad4e225341526f6c4d36051898160cb063dac6fc4479ff1e3decabc9d62346dd3d5
+DIST nethogs-0.8.1.tar.gz 35986 SHA256 4c30ef43814549974a5b01fb1a94eb72ff08628c5a421085b1ce3bfe0524df42 SHA512 f1af7bb7208d08fc3a51bb38ee475da5a7b8f8814e2a7a653057d0c5d6b4e73be7742ffef5569525822160971f81dd22212d6854483928e621cfddce8d98409f WHIRLPOOL 4595abdb530329f41dc4d3c4e6ab8cf87a8589d9cd6f8f217644f435449c86747c66ed9884a2afcc858b7eaa9d216ef8d686bc7c5eff84bbec98151bea9ab6c3
diff --git a/net-analyzer/nethogs/nethogs-0.8.1.ebuild b/net-analyzer/nethogs/nethogs-0.8.1.ebuild
new file mode 100644
index 00000000000..83e92964ed5
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="https://github.com/raboof/nethogs"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC CXX
+ emake NCURSES_LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" install
+ dodoc Changelog DESIGN README.decpcap.txt README.md
+}