summaryrefslogtreecommitdiff
path: root/net-analyzer/netio
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/netio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/netio')
-rw-r--r--net-analyzer/netio/Manifest1
-rw-r--r--net-analyzer/netio/files/netio-1.26-linux-include.patch13
-rw-r--r--net-analyzer/netio/metadata.xml5
-rw-r--r--net-analyzer/netio/netio-1.32.ebuild44
4 files changed, 63 insertions, 0 deletions
diff --git a/net-analyzer/netio/Manifest b/net-analyzer/netio/Manifest
new file mode 100644
index 00000000000..eacbc95f4a2
--- /dev/null
+++ b/net-analyzer/netio/Manifest
@@ -0,0 +1 @@
+DIST netio132.zip 162484 SHA256 c21550dfac6634558a7a79957eed28c46c62e0543017ef9d5c97c49f3cd41ddd SHA512 3473b6b41c4a1e054fa0eb3316bc16e799034b4b9402c7751f29724d8ec70c674d3de59140fdbdc301c53f2a24b44d58e8cd50a68f107bd892b1d17b6e695232 WHIRLPOOL 105a55d85292c19d13e8cf61200d1cc6e51b17c061f32adf859f66f53b4000775f2eb248cd767895767369d7cc58963356da61cda7808c4b05c94d0e400f1b31
diff --git a/net-analyzer/netio/files/netio-1.26-linux-include.patch b/net-analyzer/netio/files/netio-1.26-linux-include.patch
new file mode 100644
index 00000000000..e006c82d71a
--- /dev/null
+++ b/net-analyzer/netio/files/netio-1.26-linux-include.patch
@@ -0,0 +1,13 @@
+Add missing include (see inet(3)) - JeR
+
+
+--- a/netio.c
++++ b/netio.c
+@@ -199,6 +199,7 @@
+ #include <sys/time.h>
+ #include <time.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <netdb.h>
+
+ #define psock_errno(x) perror(x)
diff --git a/net-analyzer/netio/metadata.xml b/net-analyzer/netio/metadata.xml
new file mode 100644
index 00000000000..03aa50bab7e
--- /dev/null
+++ b/net-analyzer/netio/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/netio/netio-1.32.ebuild b/net-analyzer/netio/netio-1.32.ebuild
new file mode 100644
index 00000000000..f346d6ffa1a
--- /dev/null
+++ b/net-analyzer/netio/netio-1.32.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a network benchmarking tool that measures net throughput with NetBIOS and TCP/IP protocols"
+HOMEPAGE="http://www.ars.de/ars/ars.nsf/docs/netio"
+SRC_URI='http://www.ars.de/ARS/ars.nsf/f24a6a0b94c22d82862566960071bf5a/aa577bc4be573b05c125706d004c75b5/$FILE/netio132.zip'
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+RESTRICT="mirror" # bug #391789 comment #1
+
+DEPEND="app-arch/unzip
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ edos2unix *.c *.h
+
+ sed -i \
+ -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
+ -e 's|\(CC\)=|\1?=|g' \
+ -e 's|\(CFLAGS\)=|\1+=|g' \
+ Makefile || die
+ epatch "${FILESDIR}"/${PN}-1.26-linux-include.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ linux
+}
+
+src_install() {
+ dobin netio
+ dodoc netio.doc
+}