summaryrefslogtreecommitdiff
path: root/net-analyzer/netwox
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/netwox
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/netwox')
-rw-r--r--net-analyzer/netwox/Manifest2
-rw-r--r--net-analyzer/netwox/metadata.xml9
-rw-r--r--net-analyzer/netwox/netwox-5.39.0.ebuild62
3 files changed, 73 insertions, 0 deletions
diff --git a/net-analyzer/netwox/Manifest b/net-analyzer/netwox/Manifest
new file mode 100644
index 00000000000..abb63cd6a95
--- /dev/null
+++ b/net-analyzer/netwox/Manifest
@@ -0,0 +1,2 @@
+DIST netwox-5.39.0-doc_html.tgz 146301 SHA256 430c5c53852005c8ab4012564b70bc78dceece573567b8babb9b09efd21365f3 SHA512 1bb6c87f2aeea8b10e9bec0725ed82b21c41290d2f2626024b13525fd92596e7aa9f91788d966a51900c0e1b346ac9fb30000344fa5b1450fe9ceb724df4be56 WHIRLPOOL 96272caaf6b5f77780507412cb6de7a89447c6e90bb0437e668b20891530ee8bdc2e1db282a44d2d66dbe063f9f5e0281f1d197c78915858dde9393916c86eaf
+DIST netwox-5.39.0-src.tgz 771942 SHA256 35eaabac4d11d6a2fa7001bd9c153e053e6080c5f5b66c37e463ad32e909fbfd SHA512 3781c1c860d1545c269b27a702c59f1cb6b12af2e66fb3cbe776f3e085681a75ed3096d64cfdf92f65eff7213ceaab474b7e15c169c12e2c05220790ce337e37 WHIRLPOOL 00b270e2cbad1542acff6c1a0fa40297e814ba513a6c5c36ea1a7e9a3f13cce1ad01b8902c6218f97e0cf659433bab9c6fbe2f817a8866042351e9c94a7f4576
diff --git a/net-analyzer/netwox/metadata.xml b/net-analyzer/netwox/metadata.xml
new file mode 100644
index 00000000000..3f4f876e43f
--- /dev/null
+++ b/net-analyzer/netwox/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>Toolbox of over 400 utilities for testing Ethernet/IP networks</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ntwox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/netwox/netwox-5.39.0.ebuild b/net-analyzer/netwox/netwox-5.39.0.ebuild
new file mode 100644
index 00000000000..2ad0b1cec80
--- /dev/null
+++ b/net-analyzer/netwox/netwox-5.39.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Toolbox of 217 utilities for testing Ethernet/IP networks"
+HOMEPAGE="
+ http://ntwox.sourceforge.net/
+ http://www.laurentconstantin.com/en/netw/netwox/
+"
+SRC_URI="mirror://sourceforge/ntwox/${P}-src.tgz
+ doc? ( mirror://sourceforge/ntwox/${P}-doc_html.tgz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc x86"
+IUSE="doc"
+
+DEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+ ~net-libs/netwib-${PV}
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-src/src
+
+src_prepare() {
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/lib:/$(get_libdir):" \
+ -e "s:/usr/local:/usr:" \
+ -e "s:=ar:=$(tc-getAR):" \
+ -e "s:=ranlib:=$(tc-getRANLIB):" \
+ -e "s:=gcc:=$(tc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ config.dat || die
+ sed -i \
+ -e "s:-o netwox:& \${LDFLAGS}:g" \
+ -e 's: ; make: ; \\$(MAKE):g' \
+ genemake || die
+}
+
+src_configure() {
+ sh genemake || die
+}
+
+DOCS=(
+ "${WORKDIR}"/${P}-src/README.TXT
+ "${WORKDIR}"/${P}-src/doc/{changelog.txt,credits.txt}
+ "${WORKDIR}"/${P}-src/doc/{problemreport.txt,problemusageunix.txt,todo.txt}
+)
+
+src_install() {
+ default
+
+ use doc && dohtml -r "${WORKDIR}"/${P}-doc_html/*
+}