summaryrefslogtreecommitdiff
path: root/net-analyzer/scanssh
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/scanssh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/scanssh')
-rw-r--r--net-analyzer/scanssh/Manifest1
-rw-r--r--net-analyzer/scanssh/files/scanssh-2.0-fix-warnings.diff61
-rw-r--r--net-analyzer/scanssh/metadata.xml6
-rw-r--r--net-analyzer/scanssh/scanssh-2.1.ebuild35
4 files changed, 103 insertions, 0 deletions
diff --git a/net-analyzer/scanssh/Manifest b/net-analyzer/scanssh/Manifest
new file mode 100644
index 00000000000..9dc819125a1
--- /dev/null
+++ b/net-analyzer/scanssh/Manifest
@@ -0,0 +1 @@
+DIST scanssh-2.1.tar.gz 111481 SHA256 057eec87edafbbe5bc22960cbac53e3ada0222400d649a5e2f22cc8981f5b035 SHA512 1ddff6f8e51735bab28032c8d7cbb641ff0cd19a404a27ab489589ef1e30e3721dd486854eb4fef15368cc53f10c9c2650ffaf7fa7f767dc2202fcc5540ae59c WHIRLPOOL 5b14b341d44a5f57e3263f35d063084f116feb315a4b1e92cf7a69d752266accab64c17cf713bf7bc5074e14f4a895f3b6bae0d30c6bc1e7d24436eebd8eeafa
diff --git a/net-analyzer/scanssh/files/scanssh-2.0-fix-warnings.diff b/net-analyzer/scanssh/files/scanssh-2.0-fix-warnings.diff
new file mode 100644
index 00000000000..0ced6821efa
--- /dev/null
+++ b/net-analyzer/scanssh/files/scanssh-2.0-fix-warnings.diff
@@ -0,0 +1,61 @@
+--- a/arc4random.c
++++ b/arc4random.c
+@@ -1,5 +1,6 @@
+ #include <sys/types.h>
+ #include <stdlib.h>
++#include <time.h>
+
+ #include "config.h"
+
+--- a/interface.c
++++ b/interface.c
+@@ -56,6 +56,13 @@
+
+ #include "interface.h"
+
++#ifndef HAVE_STRLCPY
++ size_t strlcpy(char *, const char *, size_t);
++#endif
++#ifndef HAVE_STRLCAT
++ size_t strlcat(char *, const char *, size_t);
++#endif
++
+ /* Prototypes */
+ static int pcap_dloff(pcap_t *);
+
+--- a/md5.c
++++ b/md5.c
+@@ -23,6 +23,7 @@
+ copyright in any changes I have made; this code remains in the
+ public domain. */
+
++#include <string.h>
+ #include <sys/types.h>
+
+ #ifdef HAVE_CONFIG_H
+--- a/scanssh.c
++++ b/scanssh.c
+@@ -78,6 +78,10 @@
+ #define DNFPRINTF(y, x)
+ #endif
+
++#ifndef HAVE_STRLCPY
++ size_t strlcpy(char *, const char *, size_t);
++#endif
++
+ struct address_node {
+ TAILQ_ENTRY (address_node) an_next;
+
+--- a/xmalloc.c
++++ b/xmalloc.c
+@@ -20,6 +20,10 @@
+
+ #include "config.h"
+
++#ifndef HAVE_STRLCPY
++ size_t strlcpy(char *, const char *, size_t);
++#endif
++
+ void *
+ xmalloc(size_t size)
+ {
diff --git a/net-analyzer/scanssh/metadata.xml b/net-analyzer/scanssh/metadata.xml
new file mode 100644
index 00000000000..4a05ae080d1
--- /dev/null
+++ b/net-analyzer/scanssh/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>Scanssh protocol scanner - scans a list of addresses an networks for running SSH protocol servers and their version numbers.</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/scanssh/scanssh-2.1.ebuild b/net-analyzer/scanssh/scanssh-2.1.ebuild
new file mode 100644
index 00000000000..09086e75c90
--- /dev/null
+++ b/net-analyzer/scanssh/scanssh-2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="network scanner that gathers info on SSH protocols and versions"
+HOMEPAGE="http://monkey.org/~provos/scanssh/"
+SRC_URI="http://monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~ppc64 sparc x86"
+
+DEPEND="
+ dev-libs/libdnet
+ dev-libs/libevent
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0-fix-warnings.diff
+ touch configure
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin scanssh
+ doman scanssh.1
+}