summaryrefslogtreecommitdiff
path: root/net-analyzer/tracebox
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/tracebox
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/tracebox')
-rw-r--r--net-analyzer/tracebox/Manifest1
-rw-r--r--net-analyzer/tracebox/files/tracebox-0.2-deps.patch30
-rw-r--r--net-analyzer/tracebox/metadata.xml8
-rw-r--r--net-analyzer/tracebox/tracebox-0.2.ebuild51
4 files changed, 90 insertions, 0 deletions
diff --git a/net-analyzer/tracebox/Manifest b/net-analyzer/tracebox/Manifest
new file mode 100644
index 00000000000..d94703dbeb0
--- /dev/null
+++ b/net-analyzer/tracebox/Manifest
@@ -0,0 +1 @@
+DIST tracebox-0.2.tar.gz 27954 SHA256 39a7a70edb386defe03fabafe0ec8dd448ec8a24adcb2df8ea70f4ea16dfffd8 SHA512 15bfaede7e4828c14efbf7395f3d1c681b672b47157c370f4fe92d5d306ccc8e3e061107c3d36a505d732451d67ea146c21c299e6e826205725ab12680ee773e WHIRLPOOL 89a0c7dd13a6fbadcd88678a7981ed8331b0217792e95404b8ec2be0eb2ff069c570ad441f5a3651c00512d1e6471f01dd719ecddcc740f8a2c0074ba5caf268
diff --git a/net-analyzer/tracebox/files/tracebox-0.2-deps.patch b/net-analyzer/tracebox/files/tracebox-0.2-deps.patch
new file mode 100644
index 00000000000..f6c748a410c
--- /dev/null
+++ b/net-analyzer/tracebox/files/tracebox-0.2-deps.patch
@@ -0,0 +1,30 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,15 +32,11 @@
+ ])
+ ])
+
+-# Make sure libcrafter build a static library by adding the --disable-shared
+-# argument to the configure script.
+-ac_configure_args_pre="$ac_configure_args"
+-ac_configure_args_post="$ac_configure_args --disable-shared"
+-ac_configure_args="$ac_configure_args_post"
++# check for libcrafter
++PKG_CHECK_MODULES(crafter, crafter, LIBS="$LIBS $crafter_LIBS",AC_MSG_ERROR([libcrafter is required]))
+
+-AC_CONFIG_COMMANDS_PRE([ac_configure_args="$ac_configure_args_pre"])
+-AC_CONFIG_COMMANDS_POST([ac_configure_args="$ac_configure_args_post"])
+-AC_CONFIG_SUBDIRS(noinst/libcrafter/libcrafter)
++# check for libpcap
++AC_CHECK_LIB(pcap,pcap_open_offline,LIBS="$LIBS -lpcap",AC_MSG_ERROR([libpcap is required]))
+
+ # Enable click submodule
+ AS_IF([test "x$enable_tests" = "xyes"], [
+@@ -50,7 +46,6 @@
+
+ AC_CONFIG_COMMANDS_PRE([ac_configure_args="$ac_configure_args_pre"])
+ AC_CONFIG_COMMANDS_POST([ac_configure_args="$ac_configure_args_post"])
+- AC_CONFIG_SUBDIRS(tests/tools/click)
+
+ AC_PATH_PROG([FAKEROOT], [fakeroot])
+ AS_IF([test -z "$FAKEROOT"], [
diff --git a/net-analyzer/tracebox/metadata.xml b/net-analyzer/tracebox/metadata.xml
new file mode 100644
index 00000000000..18403fc4878
--- /dev/null
+++ b/net-analyzer/tracebox/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="github">tracebox/tracebox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/tracebox/tracebox-0.2.ebuild b/net-analyzer/tracebox/tracebox-0.2.ebuild
new file mode 100644
index 00000000000..7b153b35c8e
--- /dev/null
+++ b/net-analyzer/tracebox/tracebox-0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A Middlebox Detection Tool"
+HOMEPAGE="http://www.tracebox.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/lua
+ net-libs/libcrafter
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-deps.patch
+
+ sed -i -e '/SUBDIRS/s|noinst||g' Makefile.am || die
+ sed -i -e '/DIST_SUBDIRS.*libcrafter/d' noinst/Makefile.am || die
+
+ sed -i \
+ -e '/[[:graph:]]*libcrafter[[:graph:]]*/d' \
+ -e '/dist_bin_SCRIPTS/d' \
+ src/${PN}/Makefile.am \
+ || die
+
+ sed -i \
+ -e 's|"crafter.h"|<crafter.h>|g' \
+ src/${PN}/PacketModification.h \
+ src/${PN}/PartialHeader.h \
+ src/${PN}/script.h \
+ src/${PN}/${PN}.h \
+ || die
+
+ rm README.md || die
+
+ eautoreconf
+}