summaryrefslogtreecommitdiff
path: root/net-dialup/sercd
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/sercd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/sercd')
-rw-r--r--net-dialup/sercd/Manifest1
-rw-r--r--net-dialup/sercd/files/sercd.confd23
-rw-r--r--net-dialup/sercd/files/sercd.initd25
-rw-r--r--net-dialup/sercd/files/sercd.xinetd15
-rw-r--r--net-dialup/sercd/metadata.xml10
-rw-r--r--net-dialup/sercd/sercd-3.0.0-r1.ebuild36
6 files changed, 110 insertions, 0 deletions
diff --git a/net-dialup/sercd/Manifest b/net-dialup/sercd/Manifest
new file mode 100644
index 00000000000..5d8b12526ed
--- /dev/null
+++ b/net-dialup/sercd/Manifest
@@ -0,0 +1 @@
+DIST sercd-3.0.0.tar.gz 116284 SHA256 5aa9c93ae436eac206a4d93867e12838dc16ad30192cea451f985421688e4207
diff --git a/net-dialup/sercd/files/sercd.confd b/net-dialup/sercd/files/sercd.confd
new file mode 100644
index 00000000000..4c6e078489c
--- /dev/null
+++ b/net-dialup/sercd/files/sercd.confd
@@ -0,0 +1,23 @@
+# sercd service configuration file
+
+# Run daemon as this user:group
+SERCD_USER=uucp:uucp
+
+# Serial port
+SERCD_DEVFILE=/dev/modem
+
+# Lock file
+SERCD_LOCKFILE=/run/lock/LCK..modem
+
+# Address on which this daemon listens on
+SERCD_ADDR=0.0.0.0
+SERCD_PORT=7000
+
+# Log level; available values are from 0 (LOG_EMERG) to 7 (LOG_DEBUG).
+SERCD_LOGLEVEL=5
+
+# Uncomment this if you want compatibility with Cisco IOS
+# SERCD_OPTS="-i"
+
+# Poll interval is in milliseconds. 0 means no polling
+SERCD_POLLINTERV=100
diff --git a/net-dialup/sercd/files/sercd.initd b/net-dialup/sercd/files/sercd.initd
new file mode 100644
index 00000000000..c36ac1f81cf
--- /dev/null
+++ b/net-dialup/sercd/files/sercd.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PIDFILE=/run/${SVCNAME}.pid
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --quiet --background --make-pidfile \
+ --exec /usr/sbin/sercd --chuid ${SERCD_USER} --pidfile "${PIDFILE}" \
+ -- ${SERCD_OPTS} -p ${SERCD_PORT} -l ${SERCD_ADDR} \
+ ${SERCD_LOGLEVEL} "${SERCD_DEVFILE}" "${SERCD_LOCKFILE}" ${SERCD_POLLINTERV}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --name sercd --pidfile "${PIDFILE}"
+ eend $?
+}
diff --git a/net-dialup/sercd/files/sercd.xinetd b/net-dialup/sercd/files/sercd.xinetd
new file mode 100644
index 00000000000..8b95a3d0822
--- /dev/null
+++ b/net-dialup/sercd/files/sercd.xinetd
@@ -0,0 +1,15 @@
+# default: on
+# description: RFC 2217 compliant Telnet serial port redirector
+service sredir
+{
+ type = UNLISTED
+ flags = REUSE
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = uucp
+ server = /usr/sbin/sercd
+ server_args = 5 /dev/modem /run/lock/LCK..modem 100
+ port = 7000
+ disable = yes
+}
diff --git a/net-dialup/sercd/metadata.xml b/net-dialup/sercd/metadata.xml
new file mode 100644
index 00000000000..7a12fc3fa39
--- /dev/null
+++ b/net-dialup/sercd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>sercd is an RFC 2217-compliant serial port redirector.
+It lets you share a serial port through network.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">sercd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-dialup/sercd/sercd-3.0.0-r1.ebuild b/net-dialup/sercd/sercd-3.0.0-r1.ebuild
new file mode 100644
index 00000000000..ba2204b78b8
--- /dev/null
+++ b/net-dialup/sercd/sercd-3.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="RFC2217-compliant serial port redirector"
+HOMEPAGE="http://sourceforge.net/projects/sercd"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="xinetd"
+
+RDEPEND="xinetd? ( virtual/inetd )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ epatch_user
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/${PN}.xinetd" "${PN}"
+ fi
+}