summaryrefslogtreecommitdiff
path: root/net-dialup/tkvoice
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/tkvoice
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/tkvoice')
-rw-r--r--net-dialup/tkvoice/Manifest1
-rw-r--r--net-dialup/tkvoice/files/tkvoice.desktop7
-rw-r--r--net-dialup/tkvoice/metadata.xml7
-rw-r--r--net-dialup/tkvoice/tkvoice-1.5.ebuild54
4 files changed, 69 insertions, 0 deletions
diff --git a/net-dialup/tkvoice/Manifest b/net-dialup/tkvoice/Manifest
new file mode 100644
index 00000000000..46886e0a158
--- /dev/null
+++ b/net-dialup/tkvoice/Manifest
@@ -0,0 +1 @@
+DIST tkvoice-1.5.tar.gz 153967 SHA256 ab4cf6f098186fe6efe013f28262c8dcaff187224512c0cbd5668225c953ff25 SHA512 d9b2ead55131ef37a4d2e9d4d3065bb7945bbef7ffc38a336765c0d81cdfba44d6453b92277832ef0c2af4f5b9aff4eb27cfcedf119a74683d1d2a0d2fc8ca0c WHIRLPOOL 27f8ac07e34988d1aa7d29f384262529e7d03ba94cadceffe9f03ebd4404df948eab7464de4516c695dda9d7465c0396ee7dbbd52fcd146b68363f3eb04cb8e5
diff --git a/net-dialup/tkvoice/files/tkvoice.desktop b/net-dialup/tkvoice/files/tkvoice.desktop
new file mode 100644
index 00000000000..389305340e0
--- /dev/null
+++ b/net-dialup/tkvoice/files/tkvoice.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=TkVoice
+Type=Application
+Comment=Phone/Fax Utility
+Exec=tkvoice
+Icon=tkvoice
+Categories=Utility;
diff --git a/net-dialup/tkvoice/metadata.xml b/net-dialup/tkvoice/metadata.xml
new file mode 100644
index 00000000000..30ff1aec809
--- /dev/null
+++ b/net-dialup/tkvoice/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>Tk-Voice is a Telephone Answering Machine frontend for vgetty
+and also a Facsimile Answering Machine frontend for mgetty.</longdescription>
+</pkgmetadata>
diff --git a/net-dialup/tkvoice/tkvoice-1.5.ebuild b/net-dialup/tkvoice/tkvoice-1.5.ebuild
new file mode 100644
index 00000000000..bc380c4f1ea
--- /dev/null
+++ b/net-dialup/tkvoice/tkvoice-1.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Voice mail and Fax frontend program"
+HOMEPAGE="http://tkvoice.netfirms.com"
+SRC_URI="http://tkvoice.netfirms.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tk
+ media-libs/netpbm
+ media-sound/sox
+ net-dialup/mgetty"
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s:/usr/local/etc:/etc:g; s:/usr/local/bin:/usr/bin:g; s:/usr/local/tkvoice:/usr/lib/${P}:g" \
+ "${S}/tkvoice" "${S}/TCL/tkvfaq.tcl" "${S}/TCL/tkvsetupvoice.tcl" || die
+ sed -i -e "s:set STARTDIR .*:set STARTDIR /usr/lib/${P}:" \
+ "${S}/tkvoice" || die
+}
+
+src_install() {
+ exeinto /usr/lib/${P}
+ doexe ${PN}
+ dodir /usr/bin
+ dosym /usr/lib/${P}/${PN} /usr/bin/${PN}
+ insinto /usr/lib/${P}/TCL
+ doins TCL/*
+ insinto /usr/lib/${P}/image
+ doins image/*
+
+ domenu "${FILESDIR}/${PN}.desktop"
+ insinto /usr/share/pixmaps
+ doins ${PN}.xpm
+
+ dodoc BUGS FAQ README TODO
+}
+
+pkg_postinst() {
+ elog "${P} has been installed. Run ${EPREFIX}/usr/bin/${PN}."
+ elog "For more information, see the home page, ${HOMEPAGE}"
+ elog "or consult the documentation for this program as well as"
+ elog "for mgetty/vgetty."
+}